NFS on Manjaro ARM for Raspberry PI 400

I have a Manjaro Gnome on a X86 PC; no problem. I have connected my NAS with NFS protocol --> everything is right.
I’ve used Manjaro Plasma ARM for PI400. I have the last update.
After adding the correct line on /etc/fstab, the following command return me

[patrick@PI400 etc]$ sudo mount -a
mount.nfs: Protocol not supported
[patrick@PI400 etc]$

Is the NFS protocol not yet supported on ARM version ? A manual mount return me the same error.

Let me know.

Sorry for my bad english, I’m french.

Do you have “nfs-utils” package installed?

pamac search nfs-utils

Yes indeed. My original command

sudo pacman -Sy --noconfirm nfs-utils

and the return of yours:

[patrick@PI400 etc]$ pamac search nfs-utils
mkinitcpio-nfs-utils 0.3-7 core
ipconfig and nfsmount tools for NFS root support in mkinitcpio
nfs-utils [Installés] 2.5.2-2 core
Support programs for Network File Systems
[patrick@PI400 etc]$

And after a reboot, the first command reply me:

[patrick@PI400 ~]$ sudo mount -a
[sudo] Mot de passe de patrick :
Created symlink /run/systemd/system/ → /usr/lib/systemd/system/rpc-statd.service.
mount.nfs: Protocol not supported

Seems like I ran into that a while back and I believe this helped. I believe it is in the arch wiki also.

Good evening Darksky.
In your first link, I’ve read the response and the first I’ve tested was the good one.
And the winner is …

try to use this option
… nfs rsize=8192,wsize=8192,timeo=14,intr 0 0

Don’t ask me why, it was not explained.
Many thanks and … to the next issue.
I close.Vangeles from France.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.