Newsflash recently stopped working

newsflash wouldnt start after an update, heres a link to the AUR page I installed libhandy0 and it started again but I cant update my feeds, the little loading icon just turns and turns. here’s what the terminal says : pastebin

there doesnt seem to be a “newsflash” folder in /var/tmp/pamac-build-gtrjrkjrfkdk/

thanks for the help

here’s the output with the RUST backtrace option, not sure that’s how its supposed to be set

com.gitlab.newsflash RUST_BACKTRACE=1
17:44:08 - INFO - Loading backend local_rss (news_flash:105)
17:44:08 - INFO - Successful load from config (news_flash_gtk::app:194)

(NewsFlashGTK:32904): GLib-GIO-CRITICAL **: 17:44:08.155: This application can not open files.


com.gitlab.newsflash RUST_BACKTRACE=full
17:44:39 - INFO - Loading backend local_rss (news_flash:105)
17:44:39 - INFO - Successful load from config (news_flash_gtk::app:194)

(NewsFlashGTK:33075): GLib-GIO-CRITICAL **: 17:44:39.914: This application can not open files.

I just built and it ran just fine. I edited the PKGBUILD to correct the dependencies, but as long as you have them installed it should have worked:

depends=(libhandy0 webkit2gtk)
makedepends=(git meson rust)

I installed it using the pamac manager I dont know what PKGBUILD is.

Location: /var/tmp/pamac-build-gtrjrkjrfkdk/newsflash/src/news_flash_gtk/_build/target/cargo-home/registry/src/

The binary should not be referrencing the SRCDEST.

See PKGBUILD - ArchWiki and Arch User Repository - ArchWiki

Try building it the proper way as outlined in the wiki:

sudo pacman -Syu --needed git base-devel
git clone
cd newsflash
makepkg -srcif

should I uninstall it first using pamac manager ?

It doesn’t matter, it will update the installed package.

You may want to clear out the Pamac build cache either way:

pamac clean --build-files --verbose

I built the package and it does not seem to have fixed the issue, I still cannot update feeds and the same errors pop up in the terminal output here a pastebin of the building of the package and then newsflash failing to update feeds and just loading endlessly. Maybe I did not build it as I should have ?

You built it properly, that’s not the issue. Perhaps try newsflash-git as newer commits have updated the codebase for GNOME 3.38.

Installed newsflash-git via pamac manager and same behavior as before and same error message pastebin

Hmm, could be an upstream issue, then. However, the only supported method of installing Newsflash is via Flatpak.

I uninstalled newsflash-git and installed the flatpak newsflash package via pamac manager, couldnt figure out where the .local and the .config folders for the flatpak newsflash were so I imported my OPML file from the previously installed newsflash to the flatpak newsflash and same behavior same error message. pastebin

I would create a new issue upstream then if there’s not already an open issue for the problem.

I will do that, thanks ofr the help Yochanan