Newcomer to Manjaro

I just want to state some first impressions and some issues as a first time user of Manjaro. I’ve been a Linux user since the late 90’s and know my way around pretty well for the most part but my experience has been mostly limited to Debian and derivatives.
The install went smooth and was quick. After the first reboot, which was also quick, I found Manjaro to be quite responsive and snappy to use. The default desktop was good looking for the most part. I chose the Cinnamon desktop version which is also relatively new to me. I’ve used XFCE for the better part of the last 20 years almost exclusively but needed a change. Other than the default panel size, which is huge in my opinion, the desktop is pretty intuitive at a glance. So far so good. Just some minor adjustments for preference.
On to some issues. I fired up the graphical package manager for the first time to get the packages I like to use that are not installed by default and update the system. Again, pretty intuitive. I selected the packages, click apply, I am presented with a password request. Neither root or user password would satisfy the request. I searched the forum for a solution. Everything seemed to point to polkit/polkit-gnome but it is installed. Further investigation showed polkit was not running. I started it with

systemctl enable polkit.service

It complained that it shouldn’t need to be enabled this way and should be started automatically. Then I started it manually

systemctl start polkit.service

It started without argument and I proceeded with the package manager and it worked as expected. It also survived a reboot. I’m not sure why this is but it works. The next issue, which I have not looked into yet is bluetooth audio. I connected my phone, graphically, started an audio stream. Volume was extremely low even though it was set to max on the phone and the laptop and it was choppy and broken up. To double check this I tested it with another laptop and a bluetooth speaker and it worked as it should. It seems there is something I’m missing in Manjaro. I tested the volume with a video via Youtube. The sound was smooth but lower than it should be considering I had it set to max. I need to look at this in more detail. Any suggestions would be welcome.
All in all Manjaro is quite fast and user friendly on this 2014 era laptop. Unless I find something fatally wrong it’s going to stay here.


The systemctl start command only starts the service, and the systemctl enable command tells systemd that the service must be enabled at boot time. You did both, which is why it persists across reboots. :wink:

That said, you can do both in a single command… :arrow_down:

systemctl enable --now name-of-service

… will cause it to be started and to be enabled at boot time.

As for why you were running into this issue, all I can say is that the Manjaro Cinnamon Edition is a community edition, not an official edition, and that I do not know who maintains it, but it sounds like not enabling polkit by default would be a serious enough bug, and that the maintainer of that edition should be notified of this.

As for the sound issues — I cannot help with Bluetooth, sorry — the official editions of Manjaro would to the best of my knowledge still be using PulseAudio, but there is a (still not fully mature) contender for PulseAudio named Pipewire, and on some systems Pipewire works better, while on others it’s a source of problems. I do not know what the Cinnamon Edition uses by default, but there are instructions on the forum on how to switch between them. :wink:

1 Like

Thank you for that. Yes, you are correct. I couldn’t remember the syntax at the time and did what I knew would get it started. It’s not something one needs to do on a regular basis as mostly just a user. I appreciate the input. I will try and dig more into it and see if it’s actually a bug.
I will also look into the pipewire switch. Thanks again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.