Newbie question on VRAM and CPU load

Do you have hw-accel enabled and working?

Anyhoo … if you want to supply system info …

1 Like

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    [HowTo] Provide System Information
    and press the three dots below your post and press the :pencil2: to give us more information so we can see what’s really going on.
    Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text. (use the option “preformatted text”)


1 Like

The VRAM doesn’t mattter much. From your description, it’s simply your hardware is missing any required hardware acceleration (yes, they’re too old apart from for 1080p gaming). Thus, the CPU is tasked to do the hard work. I also recently just upgraded from 7th gen intel to Ryzen 6000, my old machine can’t even play 4K videos smoothly, it’s super choppy as indeed the CPU is used. Not anymore in my new machine, CPU usage is low as the hardware decoder is the one working.

1 Like

I have a slightly older xfce laptop with with a 4th gen Intel proc and a comparable geforce 860m (-10% benchmark) feeding 2 monitors and I’ll run into similar issues when streaming hi-res content. Setting one monitor to a lower resolution like 1280x720 brings load down considerably.

Also, check which of the eye candy features in display settings you really need. On plasma in particular you can burn a lot of resources on transparencies, windows animations etc, hence the relatively large difference in ram and cpu use between a freshly installed kde minimal and a ‘fully customised plasma desktop’.

1 Like
  Kernel: 6.1.26-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=a28effd1-1c29-4e88-85c2-f55b97bdbe05 rw quiet splash
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: TUF Z270 MARK 1 v: Rev 1.xx
    serial: <superuser required> UEFI: American Megatrends v: 1501
    date: 07/13/2021
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter>
    charge: 55% (should be ignored) rechargeable: yes status: discharging
  System RAM: available: 15.56 GiB used: 2.56 GiB (16.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-7700 bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 2900 high: 3600 min/max: 800/4200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3600 2: 3600 3: 3600
    4: 3600 5: 3600 6: 800 7: 3600 8: 800 bogomips: 57616
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb erms est f16c flush_l1d fma fpu fsgsbase fxsr ht hwp
    hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid
    invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr
    nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln
    pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap
    smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc
    tsc_adjust tsc_deadline_timer vme x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: NVIDIA GM107 [GeForce GTX 750 Ti] vendor: driver: nvidia
    v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-05) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-19 pcie: gen: 3 speed: 8 GT/s lanes: 2
    link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1380 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: nvidia gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 92 s-size: 1060x301mm (41.73x11.85")
    s-diag: 1102mm (43.38") monitors: <missing: xrandr>
  API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GTX 750
    Ti/PCIe/SSE2 direct-render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0 class-ID: 0403
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
    vendor: driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s
    lanes: 2 link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0fbc
    class-ID: 0403
  API: ALSA v: k6.1.26-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15b8 class-ID: 0200
  IF: enp0s31f6 state: down mac: <filter>
  Device-2: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 3.19 TiB used: 493.42 GiB (15.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: 4B2QEXM7 temp: 28.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:3 vendor: Samsung model: MZVLQ512HALU-000H1
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: HPS4NFXV temp: 30.9 C
    scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Toshiba model: DT01ACA200
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: HDD rpm: 7200 serial: <filter> fw-rev: ABB0 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%)
    used: 493.42 GiB (53.9%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: a28effd1-1c29-4e88-85c2-f55b97bdbe05
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 316 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: 30DD-5CFD
  Alert: No swap data was found.
  ID-1: /dev/nvme1n1p1 maj-min: 259:4 size: 100 MiB fs: vfat label: N/A
    uuid: 1029-6F1F
  ID-2: /dev/nvme1n1p2 maj-min: 259:5 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-3: /dev/nvme1n1p3 maj-min: 259:6 size: 476.33 GiB fs: ntfs label: N/A
    uuid: 26862A58862A292F
  ID-4: /dev/nvme1n1p4 maj-min: 259:7 size: 509 MiB fs: ntfs label: N/A
    uuid: FED03778D037366D
  ID-5: /dev/sda1 maj-min: 8:1 size: 300 MiB fs: vfat label: NO_LABEL
    uuid: C078-6B2B
  ID-6: /dev/sda2 maj-min: 8:2 size: 914.09 GiB fs: ext4 label: N/A
    uuid: 5cb8ecf5-1791-4b9b-b1d6-e141ad34a8d1
  ID-7: /dev/sda3 maj-min: 8:3 size: 17.12 GiB fs: swap label: swap
    uuid: b8119075-eb6a-474d-b2e9-917b34e8e924
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-14:2 info: Logitech Unifying Receiver type: keyboard,mouse
    driver: logitech-djreceiver,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 98mA
    chip-ID: 046d:c534 class-ID: 0301
  Hub-2: 2-0:1 info: super-speed hub ports: 10 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  Hub-3: 3-0:1 info: hi-speed hub with single TT ports: 2 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Hub-4: 4-0:1 info: super-speed hub ports: 2 rev: 3.1
    speed: 10 Gb/s (1.16 GiB/s) lanes: 1 mode: 3.2 gen-2x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 32.0 C mobo: N/A gpu: nvidia temp: 31 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 40%
  Processes: 211 Uptime: 8m wakeups: 3 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1295
  pm: pacman pkgs: 1294 libs: 380 tools: pamac pm: flatpak pkgs: 1 Shell: Zsh
  v: 5.9 default: Bash v: 5.1.16 running-in: yakuake inxi: 3.3.27
    ~                                    

Thanks all of you for the information and suggestions. First time I have used the back ticks here I hope this works as designed, thats a lot of info.

running vainfo fails with error code 1 unknown libva error and exits on that
vdpauinfo yields much of which I do not understand so

vdpauinfo                                                                                                                                                                                127 ✘  15s  
display: :0   screen: 0
API version: 1
Information string: NVIDIA VDPAU Driver Shared Library  530.41.03  Thu Mar 16 19:21:47 UTC 2023

Video surface:

name   width height types
420     4096  4096  NV12 YV12 
422     4096  4096  UYVY YUYV 
444     4096  4096  NV24 YV24 
420_16  4096  4096  P010 P016 
422_16  4096  4096  UYVY YUYV 
444_16  4096  4096  Y_U_V_444_16 

Decoder capabilities:

name                        level macbs width height
MPEG1                           0 65536  4080  4080
MPEG2_SIMPLE                    3 65536  4080  4080
MPEG2_MAIN                      3 65536  4080  4080
H264_BASELINE                  51 65536  4096  4096
H264_MAIN                      51 65536  4096  4096
H264_HIGH                      51 65536  4096  4096
VC1_SIMPLE                      1  8190  2048  2048
VC1_MAIN                        2  8190  2048  2048
VC1_ADVANCED                    4  8190  2048  2048
MPEG4_PART2_SP                  3  8192  2048  2048
MPEG4_PART2_ASP                 5  8192  2048  2048
DIVX4_QMOBILE                   0  8192  2048  2048
DIVX4_MOBILE                    0  8192  2048  2048
DIVX4_HOME_THEATER              0  8192  2048  2048
DIVX4_HD_1080P                  0  8192  2048  2048
DIVX5_QMOBILE                   0  8192  2048  2048
DIVX5_MOBILE                    0  8192  2048  2048
DIVX5_HOME_THEATER              0  8192  2048  2048
DIVX5_HD_1080P                  0  8192  2048  2048
H264_CONSTRAINED_BASELINE      51 65536  4096  4096
H264_EXTENDED                  51 65536  4096  4096
H264_PROGRESSIVE_HIGH          51 65536  4096  4096
H264_CONSTRAINED_HIGH          51 65536  4096  4096
H264_HIGH_444_PREDICTIVE       51 65536  4096  4096
VP9_PROFILE_0                  --- not supported ---
VP9_PROFILE_1                  --- not supported ---
VP9_PROFILE_2                  --- not supported ---
VP9_PROFILE_3                  --- not supported ---
HEVC_MAIN                      --- not supported ---
HEVC_MAIN_10                   --- not supported ---
HEVC_MAIN_STILL                --- not supported ---
HEVC_MAIN_12                   --- not supported ---
HEVC_MAIN_444                  --- not supported ---
HEVC_MAIN_444_10               --- not supported ---
HEVC_MAIN_444_12               --- not supported ---
AV1_MAIN                       --- not supported ---
AV1_HIGH                       --- not supported ---
AV1_PROFESSIONAL               --- not supported ---

Output surface:

name              width height nat types
B8G8R8A8         16384 16384    y  Y8U8V8A8 V8U8Y8A8 A4I4 I4A4 A8I8 I8A8 
R10G10B10A2      16384 16384    y  Y8U8V8A8 V8U8Y8A8 A4I4 I4A4 A8I8 I8A8 

Bitmap surface:

name              width height
B8G8R8A8         16384 16384
R8G8B8A8         16384 16384
R10G10B10A2      16384 16384
B10G10R10A2      16384 16384
A8               16384 16384

Video mixer:

feature name                    sup
INVERSE_TELECINE                 y
NOISE_REDUCTION                  y
SHARPNESS                        y
LUMA_KEY                         y

parameter name                  sup      min      max
VIDEO_SURFACE_WIDTH              y         1     4096
VIDEO_SURFACE_HEIGHT             y         1     4096
CHROMA_TYPE                      y  
LAYERS                           y         0        4

attribute name                  sup      min      max
BACKGROUND_COLOR                 y  
CSC_MATRIX                       y  
NOISE_REDUCTION_LEVEL            y      0.00     1.00
SHARPNESS_LEVEL                  y     -1.00     1.00
LUMA_KEY_MIN_LUMA                y  
LUMA_KEY_MAX_LUMA                y  

Note the following info–

# grep -iE 'vdpau | dri driver' xorg_log_file
grep: xorg_log_file: No such file or directory

also this

[Manjouno carr]# grep -iE 'vdpau | dri driver' xorg_log_file
grep: xorg_log_file: No such file or directory
[Manjouno carr]# sha1sum /usr/lib/dri/* | sort
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
1c9fad641547672ad6fa3f6ca1be9b03c2e18ed5  /usr/lib/dri/
2149b00774b601b217f33c33cb5c2a338e6f32cc  /usr/lib/dri/
2149b00774b601b217f33c33cb5c2a338e6f32cc  /usr/lib/dri/
2149b00774b601b217f33c33cb5c2a338e6f32cc  /usr/lib/dri/
387c7f146333240993b2ffe45994d28c5b477c42  /usr/lib/dri/
f641be8ea3afb13454ef41530e729a1d82723660  /usr/lib/dri/
f641be8ea3afb13454ef41530e729a1d82723660  /usr/lib/dri/
f641be8ea3afb13454ef41530e729a1d82723660  /usr/lib/dri/
f641be8ea3afb13454ef41530e729a1d82723660  /usr/lib/dri/
f641be8ea3afb13454ef41530e729a1d82723660  /usr/lib/dri/

thanks cscs for the pointer to the Arch wiki.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Thanks for the guide and my apologies. I was afraid I would screw up getting the terminal output formatted correctly.

6 x 12
Thanks for the suggestions. When I recently changed from the spinning drive to an M2 I reinstalled Manjaro and imported most of the content from the spinning drive. I didnt import any config files. I run a pretty plain Plasma desktop without much eye candy. This installation is 3 days old, done with a fresh download of the os so there isnt much cruft there.

The xorg_log_file is located here normally: /var/log/Xorg.0.log That was a pattern to replace with the normal path.

1 Like

Note that vdpau is not used in chromium or Firefox as you see here: Hardware video acceleration - ArchWiki Only VAAPI is supported and that’s why it is utilizing video decoding only on the CPU. But most media players support it.

You could try installing libva-nvidia-driver from the AUR, which is a community effort to make nvidia VAAPI compatible. See here the project page: GitHub - elFarto/nvidia-vaapi-driver: A VA-API implemention using NVIDIA's NVDEC

After that, you should see the supported codecs in vainfo. However… you need also explicitly enable video decoding in the browser.

Firefox - ArchWiki
Chromium - ArchWiki

1 Like

thanks for this, will read more on it and may try it. Nano’ed Xorg.0.log and while it looked similar in some ways to many xorg.conf files I didnt see much of anything that reflects on what I am trying to do. Thanks for the pointer. When i ran grep -iE ‘vdpau | dri driver’ /var/log/Xorg.0.log the system didnt report anything back had to ctl+c to get back to the prompt. Looking int Firefox config now. I am amazed at how much I do not know.

Firefox media.ffmpeg. vaapi.enabled was set on false now true. About:support shows compositing on Web Render, also reflects the installed NVidia driver in various places so. Also finally figured out what I was dong wrong on grep so # grep -iE ‘vdpau | dri driver’ Xorg.0.log yields
[ 6.600] (II) NVIDIA(0): [DRI2] VDPAU driver: nvidia-- which solves another part of it. After the change in Firefox settings, still high CPU usage on some websites. Maybe time to build a more modern system and make this one a media server :slight_smile:

Have you also set media.ffmpeg.vaapi.enabled ?

And launched with something like MOZ_DRM_DEVICE=/dev/dri/card0 ?

What is the output of stat /dev/dri/* ?

1 Like

You followed this right?

1 Like
 stat /dev/dri/*                                                                                                                                                                                     ✔ 
  File: /dev/dri/by-path
  Size: 80              Blocks: 0          IO Block: 4096   directory
Device: 0,5     Inode: 936         Links: 2
Access: (0755/drwxr-xr-x)  Uid: (    0/    root)   Gid: (    0/    root)
Access: 2023-05-14 13:13:53.404597094 -0500
Modify: 2023-05-14 13:13:53.404597094 -0500
Change: 2023-05-14 13:13:53.404597094 -0500
 Birth: 2023-05-14 13:13:53.404597094 -0500
  File: /dev/dri/card0
  Size: 0               Blocks: 0          IO Block: 4096   character special file
Device: 0,5     Inode: 935         Links: 1     Device type: 226,0
Access: (0660/crw-rw----)  Uid: (    0/    root)   Gid: (  985/   video)
Access: 2023-05-14 13:13:53.404597094 -0500
Modify: 2023-05-14 13:13:53.404597094 -0500
Change: 2023-05-14 13:14:03.937930356 -0500
 Birth: 2023-05-14 13:13:53.371263760 -0500
  File: /dev/dri/renderD128
  Size: 0               Blocks: 0          IO Block: 4096   character special file
Device: 0,5     Inode: 934         Links: 1     Device type: 226,128
Access: (0666/crw-rw-rw-)  Uid: (    0/    root)   Gid: (  989/  render)
Access: 2023-05-14 13:13:53.404597094 -0500
Modify: 2023-05-14 13:13:53.404597094 -0500
Change: 2023-05-14 13:13:53.404597094 -0500
 Birth: 2023-05-14 13:13:53.371263760 -0500

Have not tried the vaapi driver for Firefox yet… I am somewhat limited by what I can do, system is busy shredding some spinning drives this afternoon. Many thanks for the kindness and interest. I should be able to get back on this tomorrow. What we are dealing with here is an area I am totally unfamiliar with…my ignorance is vast. Whats indicated by stat /dev/dri*


It was just a prerequisite for following the FF-Hw-Accel instructions.
Though that is technically debated.

A changed .desktop line might look like this and you can use it as a test:

/usr/bin/sh -c "MOZ_DRM_DEVICE=/dev/dri/card0 MOZ_DISABLE_RDD_SANDBOX=1 /usr/lib/firefox/firefox"

But this is assuming you followed the link above, installing the package and setting the other options.

1 Like

Thanks for this very much. I need to do some reading to understand more at the risk of becoming an appliance operator.There is just a hell of a lot I do not know.

Edit- question… VAAPI is designed to allow Firefox, VLC and other programs to use GPU hardware acceleration and from what I read is supported by AMD drivers… but given the VAAPI driver on Github for NVIdia systems, not natively supported by NVidia. I am assuming possibly incorrectly that lack of VAAPI support (among other things) is responsible for the higher CPU usage I see when I stream videos on youtube… given my monitors, the somewhat primitive standards (old) of my motherboard and 2GB of RAM on the video card. As leledumbo pointed out VRAM wouldnt make much difference so would a video card with more capabilities help aside from the VRAM or is the rest of the system unable to take advantage of a more advanced video card (I have been tempted by Intel’s Arc but after reading among other places Phoronics have held off…). Admittedly the 7700 based platform is pretty ancient by modern standards PCIEV3, slower RAM &c&c. I have lived with this system for 5 years without any hardware problems, I built it and will build the next one as well and it will be AMD I think. But I am trying to decide whether its worth it to put in a new video card or build new from the ground up. Many thanks to all of you. If my shredding will finish I may try the driver albeit given the caveat that it may not work with some apps…

Aside from photo editing on this system and some day trading, I am also an amateur radio operator contemplating purchase of Software Defined Radio–SDR equipment. From what I read about GnuRadio and other programs the processing load is heavy so this might not be the machine to try that on…
Again thanks to all of you.

You can still use, apparently, the latest nvidia driver … which does have the capabilities … just a little extra is required, such as that libva-nvidia-driver package, settings, and the augmented start command.
Which seems like a bit … but its not very different from everyone else who also need to set some options and change the startup to have hw-accel working.
Yes - nvidia was/is worse at it … particularly VAAPI, which is what the browsers use … but the above things should sort that out.
Similarly … VLC is pretty bad at its default/fall-back settings … so in order for it to work right you either need to make sure it runs entirely in software, or set up hw-accel correctly.
(see this thread as an example: DE froze with graphic glitches... lots of kernel, drm, and amdgpu entries in journal - #26 by cscs)
I prefer smplayer for a number of reasons … but this is another one … its better at falling back and most folks wont even notice an issue … but setting hw-accel works splendidly … and you can use VAAPI or VDPAU (which nvidia is much happier about).

1 Like

Thanks very much for the reference to the thread. I am going to give smplayer a try. Interesting thread, again many thanks!

Like SM Player as well works on both vaapi and vdpau.

Brief note to thank all of you for the interest and help. I think I am going to start investigating a new motherboard/GPU/RAM combination, this time AMD…rather than invest more $$ in an already old system. Again my thanks to all.

I don’t think your system is old at all. If you don’t like it replace it though.

You may use these tests to see how your system relatively performs: