Newbie hardware error --- no real solution unfortunately

Hi there my freshly installed manjaro deepin outputs this:

stock configuration BIOS on a Jumper Ezbook 3 Atom N3350

Live USB outputs the same, anyone as an idea how to solve this?

THANX


Danilo

Does the error go away after a while (say, two or three minutes), or is it fatal? I ran into the same issue installing Manjaro on my Mac but it went away after a minute or so. Sometimes patience is the key.

if this is a fresh install and not yet updated for the first time, get yourself to a terminal or TTY if you cant get to a desktop (ctrl+alt+f2, or f3,f4,f5)

  • login with regular user and pass (not root)
  • then run nmtui and activate your network connection and quit nmtui
  • then run these commands:
sudo pacman-mirrors -f8
sudo pacman -Syyu

this will probably be a decent sized update, answer yes to any prompts and if everything finishes without issues, then reboot.

hi, no it stays but it s not fatal, manjaro usually boots well .....well it's not very stable, it randomly freezes and/or reboots randomly

hi, it does boot well even if it is not very stable (freezes and/reboots randomly)

already updated correctly but it doesn't make any difference at all.

this is my inxi -Fxxxz hope it helps

System:    Host: danilo-pc Kernel: 4.19.42-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: Deepin 15.10.1 
           tk: Qt 5.12.3 info: dde-dock wm: DeepinWM dm: LightDM 1.28.0 Distro: Manjaro Linux 
Machine:   Type: Laptop System: JUMPER product: EZbook 3 v: N/A serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: JUMPER model: EZbook 3 serial: <filter> UEFI: American Megatrends v: ZB-BI-14-Y116AR120-AA55C-101-A 
           date: 12/14/2016 
Battery:   ID-1: BAT0 charge: 27.0 Wh condition: 42.9/48.0 Wh (89%) volts: 7.6/N/A model: Intel SR 1 SR Real Battery 
           type: Unknown serial: <filter> status: Discharging 
CPU:       Topology: Dual Core model: Intel Celeron N3350 bits: 64 type: MCP arch: Goldmont rev: 9 
           L2 cache: 1024 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 4378 
           Speed: 818 MHz min/max: 800/2400 MHz Core speeds (MHz): 1: 796 2: 796 
Graphics:  Device-1: Intel driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5a85 
           Display: x11 server: X.Org 1.20.4 driver: intel unloaded: modesetting alternate: fbdev,vesa 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6) v: 4.5 Mesa 19.0.4 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster driver: snd_hda_intel 
           v: kernel bus ID: 00:0e.0 chip ID: 8086:5a98 
           Sound Server: ALSA v: k4.19.42-1-MANJARO 
Network:   Message: No Device data found. 
           IF-ID-1: enp0s21f0u5c4i2 state: up speed: N/A duplex: N/A mac: <filter> 
           IF-ID-2: wlp0s21f0u7i2 state: down mac: <filter> 
Drives:    Local Storage: total: 58.24 GiB used: 9.65 GiB (16.6%) 
           ID-1: /dev/mmcblk1 model: DF4064 size: 58.24 GiB serial: <filter> rev: 0x8 scheme: MBR 
Partition: ID-1: / size: 53.51 GiB used: 9.65 GiB (18.0%) fs: f2fs dev: /dev/mmcblk1p2 
           ID-2: swap-1 size: 4.04 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/mmcblk1p3 
Sensors:   System Temperatures: cpu: 45.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 161 Uptime: 14m Memory: 3.68 GiB used: 777.1 MiB (20.6%) Init: systemd v: 242 Compilers: 
           gcc: 8.3.0 Shell: bash v: 5.0.7 running in: deepin-terminal inxi: 3.0.34

please edit post and put 3 backtics ``` above and below any terminal output so it's formatted properly. you can also use the </> button which does the same.

check for any firmware updates from ezbook or whoever and/or try some other kernels. i would try some of the earlier ones that are still updated like 4.14 or 4.9

sudo mhwd-kernel -i linux414
#or linux49, linux50

if there are still issues, check entropy

cat /proc/sys/kernel/random/entropy_avail 

if that returns a number close to or less than 1000, enable haveged
sudo systemctl enable haveged --now

no good still? post logs

cat /var/log/Xorg.0.log | grep -E "(EE)|(WW)|error|failed|Time"

also: you need to select the new kernel from grub after installing it.

Could be a heat issue? My Mac has occasionally done that, and you'll see it in the journal. Like so:

[nick@athena ~]$ sudo dmesg | grep -e "temp"
[    0.344869] MDS: Vulnerable: Clear CPU buffers attempted, no microcode
[    5.573138] mce: CPU2: Core temperature above threshold, cpu clock throttled (total events = 1)
[    5.573140] mce: CPU3: Core temperature above threshold, cpu clock throttled (total events = 1)
[    5.574177] mce: CPU2: Core temperature/speed normal
[    5.574177] mce: CPU3: Core temperature/speed normal
[    6.311960] applesmc: key=387 fan=2 temp=22 index=22 acc=1 lux=2 kbd=1
[  319.600977] mce: CPU2: Core temperature above threshold, cpu clock throttled (total events = 1394)
[  319.600978] mce: CPU3: Core temperature above threshold, cpu clock throttled (total events = 1394)
[  319.602000] mce: CPU2: Core temperature/speed normal
[  319.602001] mce: CPU3: Core temperature/speed normal

Sometimes, switching out the kernel helps - you can try an older one, or a newer one.

hi, I don't think it throttles , it runs constantly between 61 and 75 C :slight_smile:

Did you try changing out the window manager for better performance? It probably won't affect this specific hardware error, but the random crashes etc. might be fixed if you install deepin-kwin in Pamac.

hi, I feel stupid: i have absolutely no idea how to edit my previous posts.

I will try to downgrade the kernel as soon as I will have a reliable connection and update you,

meanwhile

cat /proc/sys/kernel/random/entropy_avail 

outputs:

3782

Sounds like you may have failing hardware. Maybe try contacting the manufacturer see if they have any help.
Heat problems can be spurious, every thing looks good, heat briefly shoots up and down screwing things up. Try cleaning the fans if you can (can't hurt), make sure vent holes aren't being blocked sometimes.

Edit: to edit look for the pencil with eraser on top and click it.

hi it's a fanless laptop and temps never got higher than 75 C

I don't have a pencil...maybe because I'm on Brave...?

Yeah heat may not be a problem, but I still wouldn't rule it out yet and check vents (you can refrigerate it for awhile but since this is intermittent that probably won't be very useful). More likely something is failing. So see what the maker has to say (how old it it?).

Yeah, don't know that one, was thinking Firefox...you could switch to Firefox :wink:
Edit looks like there is a ... icon try clicking on that see if you see more icons.

I actually like brave, it's based on chromium and has a good (not perfect) ad blocker embedded out of the box

I just bought this laptop second hand and this model came out originally in 2016 but it could have been sold later as the BIOS seems to have preinstalled customisations of the last batch for this specific model

what do you mean by that? you checked the manufacturer and the bios are the latest available? if not check and get the latest firmware available.

try disabling compositing from deepin settings, i seen someone else having issues and segfault errors that stopped with it disabled.

Are you saying it has a custom BIOS? If so flash with the latest from the manufacturer for sure. I have no idea how it's built...guessing most things will be soldered in, otherwise all I could suggest is looking to see if anything is coming lose from a socket esp. the CPU...if you are comfortable looking inside it. You never know how roughly it was treated (appearances can be deceiving),

I mean that the latest batches have 400hz eMMC as default while previous ones had a lower default setting or so it seems on the youtube videos I've watched

did you check for newer firmware versions yet?
have you tried other kernels yet?

I'm connected through a usb hotspot on my phone, if I downgrade right now I won't finish the process

Jumper (manufacturer) doesn't really have updates for their custom MegaTrends (bios dev) bios available, I wasn't even able to find this model on their website.

Jumper Ezbook 3 (it's not the pro version) http://en.jumper.com.cn/downloadcenter/list.aspx?lcid=17&pid=9

I have disabled the ad blocker for this forum and I am finally able to edit posts :smiley: sorry for being dumb, it's 1:37 AM in Italy