New Wi-Fi Network doesn't want to connect

Hi,
I’m not an expert in Manjaro, and all of my current wi-fi networks work fine, but I set-up a new wi-fi box. The connection works perfectly fine with ethernet, however when I try to connect to the wi-fi, my computer detects it, but it never passes the “configuring interface” part, always asking for me to re-enter my password (even though I put the correct one). I am running on KDE 5.19.4 and kernel 5.4.60-2.

Output for sudo lspci -v (for ethernet and network only):

00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-LM (rev 21)
Subsystem: Lenovo Device 2233
Flags: bus master, fast devsel, latency 0, IRQ 131
Memory at f1300000 (32-bit, non-prefetchable) [size=128K]
Capabilities: [c8] Power Management version 3
Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [e0] PCI Advanced Features
Kernel driver in use: e1000e
Kernel modules: e1000e

04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
Subsystem: Intel Corporation Device 0130
Flags: bus master, fast devsel, latency 0, IRQ 132
Memory at f1100000 (64-bit, non-prefetchable) [size=8K]
Capabilities: [c8] Power Management version 3
Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
Capabilities: [40] Express Endpoint, MSI 00
Capabilities: [100] Advanced Error Reporting
Capabilities: [140] Device Serial Number e4-a4-71-ff-ff-69-a3-57
Capabilities: [14c] Latency Tolerance Reporting
Capabilities: [154] L1 PM Substates
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

Thanks for any help!

this is just a guess but try disabling IPV6 and make sure security is set to wpa& wpa2
Also if you have secure boot turned on turn it off.

Start journalctl -f and try to connect, and see what it prints.

Thanks for the responses. I tried with journalctl -f and got:

NetworkManager[544]: [1599574944.2843] device (wlp4s0): state change: need-auth -> prepare (reason ‘none’, sys-iface-state: ‘managed’)
NetworkManager[544]: [1599574944.2852] device (wlp4s0): state change: prepare -> config (reason ‘none’, sys-iface-state: ‘managed’)
NetworkManager[544]: [1599574944.2858] device (wlp4s0): Activation: (wifi) connection ‘[wifi name]’ has security, and secrets exist
. No new secrets needed.
NetworkManager[544]: [1599574944.2866] Config: added ‘ssid’ value ‘[wifi name]’
NetworkManager[544]: [1599574944.2867] Config: added ‘scan_ssid’ value ‘1’
NetworkManager[544]: [1599574944.2867] Config: added ‘bgscan’ value ‘simple:30:-70:86400’
NetworkManager[544]: [1599574944.2868] Config: added ‘key_mgmt’ value ‘WPA-PSK WPA-PSK-SHA256 FT-PSK’
NetworkManager[544]: [1599574944.2868] Config: added ‘psk’ value ‘’
NetworkManager[544]: [1599574944.3048] device (wlp4s0): supplicant interface state: inactive -> scanning
NetworkManager[544]: [1599574944.3048] device (p2p-dev-wlp4s0): supplicant management interface state: inactive -> scanning
wpa_supplicant[614]: wlp4s0: SME: Trying to authenticate with [mac address] (SSID=’[wifi name]’ freq=2417 MHz)
kernel: wlp4s0: authenticate with [mac address]
NetworkManager[544]: [1599574944.8658] device (wlp4s0): supplicant interface state: scanning -> authenticating
NetworkManager[544]: [1599574944.8663] device (p2p-dev-wlp4s0): supplicant management interface state: scanning -> authenticating
kernel: wlp4s0: send auth to [mac address] (try 1/3)
wpa_supplicant[614]: wlp4s0: Trying to associate with [mac address] (SSID=’[wifi name]’ freq=2417 MHz)
NetworkManager[544]: [1599574944.8782] device (wlp4s0): supplicant interface state: authenticating -> associating
NetworkManager[544]: [1599574944.8783] device (p2p-dev-wlp4s0): supplicant management interface state: authenticating -> associating
kernel: wlp4s0: authenticated
kernel: wlp4s0: associate with [mac address] (try 1/3)
kernel: wlp4s0: associate with [mac address] (try 2/3)
kernel: wlp4s0: associate with [mac address] (try 3/3)
kernel: wlp4s0: association with [mac address] timed out
wpa_supplicant[614]: wlp4s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="[wifi name]" auth_failures=1 duration=10 reason=CONN_FAILED
NetworkManager[544]: [1599574945.2745] device (wlp4s0): supplicant interface state: associating -> disconnected
NetworkManager[544]: [1599574945.2746] device (p2p-dev-wlp4s0): supplicant management interface state: associating -> disconnected
NetworkManager[544]: [1599574955.2810] device (wlp4s0): supplicant interface state: disconnected -> scanning
NetworkManager[544]: [1599574955.2811] device (p2p-dev-wlp4s0): supplicant management interface state: disconnected -> scanning

I tried disabling IPV6, setting security to wpa/wpa2, downgrading in kernels, but still no luck

Have you tried changing the wifi channel, bandwidth, using no encryption/WEP, moving the laptop closer to the AP, etc.?

Yes, tried it all, tried wifi-menu, network-manager, updating the system, firmware, etc., changing kernels but no luck. Might by the wifi card not being able to be compatible with the router, but will try a live-usb with a different OS to see if it will work.

I meant that you could try playing with the router’s settings: channel, bandwidth, band (2.4/5 GHz), encryption, etc.

I actually had this problem and couldn’t get it resolved so I ended doing a complete reinstall after changing kernels from 6.8 back down to 5.7. Do you have any other devices that can connect to the said wifi for comparison?

I tried as well to change the routers settings, and my other laptop (running on windows) and my phone (android) both work and connect to the wifi. Hopefully I don’t have to do a complete reinstall but it could be a good solution