New to Manjaro/Arch. Need help setting up my printer!

drivers
printer
canon

#1

I have a Canon MF4770N printer. I’ve tried everything I could find researching the net. This printer was working fine under Xubuntu (Canon has an installation script that is compatible with Debian), but I recently wanted to try out Manjaro and am loving it so far except for this small issue.

I’ve tried both of these packages: https://aur.archlinux.org/packages/?O=0&K=canon+mf

The driver appears to be installed because it is found with CUPS and also through Manjaro-Printer. However, the printer has 2 different interfaces 1 is the printer and 2 is for FAX…I believe. So I have it configured with the interface=1. When I print…nothing happens. Scan seems to work just fine as it did under Xubuntu…which seemed a little strange to me.

Any ideas on what I can do to get this working? I figure it is something small that I am leaving out…but I am not sure what it could be.


#2

Have you tried the carps-cups and capt-src drivers as suggested here?
https://wiki.archlinux.org/index.php/CUPS/Printer-specific_problems#Canon


#3

Well, canon recommends the driver that you’ve already tried for linux: https://aur.archlinux.org/packages/cndrvcups-lb-bin/

See http://www.canon-supportdrivers.co/2017/02/canon-imageclass-mf4770n-printer-driver.html

Did you have a look at that? (for ubuntu)
http://printersquestions.com/How-to-install-Canon-imageCLASS-MF4770n-on-Ubuntu.html


#4

So I think I was pretty close to getting it working. I was able to get the printer to wake from sleep, but it hung up on sending to printer…I ended up having to reinstall xubuntu, which has its own set of problems on that macine but I work from home and need the printer.

I run Manjaro on my laptop so I’m going to try it with that machine and see


#5

Tred it with my laptop and it is also hanging when I try to print a test page:
Processing - Sending data to printer.

and nothing happens. Seems to communicate because if the printer is asleep the display light comes on…but never prints