New to linux, need some suppot to install Manjaro


#1

Hello all.

What to start to say this is my first experience with Manjaro/linux.

So i have for a long time whanted to give Linux a try, and after last forced restart i decided enought is enough.

So i downloaded the Manjaro KDE Edition (17.0.1) from the site. And used Rufus to get it to an usb. I then got the wrong file format error. Spendt one day formating my usb stick and trying to get it to work. Also downloaded both from torrent and link. Same problem.

Tried a few other programs then Rufus but always the same problem. Then i tried another USB pen and used DD method to “burn” the image to the usb and for the first time i got past the error msg.

I was able to choose timesone, language and so on.

But the installation always stopped at:
[ OK ] Started TLP system startup/shutdown

I waited 30 mins each time.

Some HW info:
GPU: GTX 1050 TI 4Gb
MB: ASUS P8Z68-V PRO, Socket-1155
CPU: i5-2500K 3.3Ghz
RAM: 8 Gb
Asus PCE-AC88 ac3100 wifi adapter
tried to install on a SSD with win10 on it.

Anyone that can offer some support on this one? This noob is getting frustrated :stuck_out_tongue:

One last question: how does battle.net games preforme on linux compared to windows?

Thanks in advance :slight_smile:


#2

During installation did you try installing with nonfree drivers? I am not super familiar with the new install media but this used to be an option and may work for you.


#3

Blizzard doesn’t have any games native on Linux. You’ll have to dual boot or use PlayOnLinux/WINE.


#4

Thanks for the answers.

Since i failed to understand what nonefree drivers ment i was abit afraid to try that. Think it might be the only thing i didnt try :stuck_out_tongue: What does none free drivers means? Do i have to install all drivers when i get to the OS? That can be a problem since i use asus wifi and dont have cabeld internet to my computer.

I do know that Blizzard dont have any native games for linux, and in the beginning the plan was to dual boot but im hopeing to switch from windows all together some day.

Do you have any experience playing games on linux and if so whats your experience from it?


#5

As a noob you probably ought to spend sometime learning the basics… there is no better place than here: https://wiki.manjaro.org/index.php?title=Main_Page


#6

As for your [TLP] issue - you have a few different options.

This is a bug with older manjaro-tools I believe - You can either try to update manjaro-tools in your current iso or you can use the next release preview which will have the update
https://manjaro.org/manjaro-preview-releases/


#7

Thanks for the answers again. Wil try the suggested things when i come home from work.

I have been thinking to try the preview release, but i see it marked as unstable (or not stable) so i decided not to. I might be wrong but i think a stable version is kinda a must for a newbie like my self ^^


#8

Wow so much info here. So far i have used google to answer my questions but this is clearly a bether site :slight_smile: Thanks


#9

The .iso’s are just snapshots of our rolling release. They change every so often to keep up with package changes, and try to make sure that the image is stable and functioning for use as live/install media. To this end releases are updated and groomed, but it doesnt mean you will get a different kind of manjaro by the time you’ve installed and applied updates [unless the branch is somehow switched to testing or unstable … but I dont believe that is the case, and it is easily changeable].


#10

None-free drivers refers to proprietary graphics card drivers developed by the graphics card’s manufacturer (and thus closed source), as opposed to the free drivers which are open source alternatives. For ordinary everyday usage there tends to be no major difference between the two and they both work equally well, but depending on your particular usage (graphics intensive applications) you may/may not come across limitations of the open source drivers.


#11

Its “Non-Free” (as in not free) which might clear up some confusion.
Otherwise what you have said really only applies to newer nvidia cards.
Intel open-sources their xf86-video-intel so free/non-free makes no difference.
[Though I should note that the kernels built-in ‘modesetting’ driver can/will arguably outperform intels own driver (achieved by removing or not installing any video driver … it just doesnt have as many options… yet)]
AMD/ATI has open-sourced their newest implementation for high-end cards ‘AMDGPU-PRO’. There was once catalyst as the proprietary option … but more and more you would prefer the opensource ‘ati’ driver on older cards, and the open ‘amdgpu’ for newer ones.
Nvidia will force you into either ‘nouveau’ or closed/proprietary ‘nvidia’ drivers. Again - you probably have best results with the opensource driver on older cards, but on newer ones/3Dgaming you might require the non-free ‘nvidia’ driver.


#12

Quick question, I just skimmed through last posts and didn’t wake up yet :slight_smile:

Did you get Manjaro installed? Preparation of USB wrong way will cause problems errors at installation. Rufus is OK if ISO is burned in DD mode. If you need to burn USB again, use Etcher. Works on windows and Linux and it is the easiest of all.

Start with Xfce. At least for your first try. While KDE looks nicer and better, with more whistles and bells, I couldn’t install it on one machine either. Xfce may be the most robust of all versions.


#13

I agree with @AlManja, use etcher to burn iso to usb. Battle.net games work great on playonlinux. Only Overwatch need some extra tweaks to work.


#14

@MysticoN
I’ve been banned from Blizzard 3 times for bitching about there non-porting of their games to Linux, and I’m a Level-70 solo Monk in D3, even though, every one of their developers admitted to using Linux to develop their games, AND, on top of that, they use BSD/Linux on vast networked-servers for their games.

So, just like the rest of us, why don’t you start emailing/facebook/twiiter Blizzard to respect Linux?


#15

Wow… I wil not scjet!

Anyway. i got Manjaro installed. Useing the Manjaro KDE Edition (17.0.2-pre4) with non-free drivers.
The problem for me didnt stop there, i have no internet and it seems like there is no easy way to get my wifi to work on linux.

I spent most of the day to try this to work, read a few workarounds that i didnt understand and/or was afraid to try.

Aslo found this site:
https://wikidevi.com/wiki/ASUS_PCE-AC88

But for one that are used to links that download a exe file this is another site that makes no sense for me:/ I have also tried to setup a new wifi but no luck. I have only wifi and not able to cable the internet.

Anyway. Thanks for all the help. i wil continue to work on this problem when i get home. Do you whant me to make a new thread if i need any more support on my wifi problem or continue on this one? Im going off topic now :slight_smile:


#16

Don’t forget to reboot. Sometimes it works a miracle.


#17

I would suggest you open new topic, with the title describing your problem. It is good you are trying to solve problems but when you are trying for a whole day, let’s rather more experienced here help you.

There is command line tool that may be of help, it should already be pre installed on your system:

nmtui

Here you can see it’s screen shoot second from top down in first post. (btw, this is alternate installer if you ever want to install Manjaro more customized)


#18

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.