New root error, can't find UUID


I’m a bit new user of Manjaro and Arch!

My problem is not very simple, I’ll try to tell every my step.

I installed the Manjaro and started to configure some features.

Now my problem is that after some changes in settings (for example saving profiles for my displays) and rebooting - the error appears. File system is BTRFS

/new_root error: can’t find UUID=

My steps to solve the problem:

  1. boot from Live USB
  2. chroot
  3. sudo mkinitcpio -P linux
  4. reboot, didn’t help
  5. Tried to change the sequence of HOOKS in mkinitcpio.conf
    from “base udev autodetect modconf block keyboard keymap filesystems”
    to “base udev block autodetect modconf keyboard keymap filesystems”
    (solution from stackoverflow)
  6. chroot, sudo mkinitcpio -P linux
  7. success!

But the problem is that after some changes in setup it actually gives me the same error after reboot.

So what can possibly cause this and is there any way to fix it finally?

Come on, explain what these “changes” were so that we can understand what you actually did.

Changes are:

Install plank dock
Install ulauncher
Install lightdm-webkit2-greeter
Install theme, cursors, icons from pling com
Install conky-lua
Configure panels(just add system actions, time, tray and pulseaudio and setup their appearence)
Configure profiles for monitors (2 profiles with one FHD monitor and with two monitors (FHD + 2K))

These don’t seem to influence the UUID.

Can you post the output of sudo blkid, your /etc/fstab and the kernel commandline?

sudo blkid

/dev/nvme0n1p1: LABEL_FATBOOT="NO_LABEL" LABEL="NO_LABEL" UUID="D39C-FBA5" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="1516c539-a522-724d-a788-49c64991dcd3"
/dev/nvme0n1p2: UUID="f9c64415-de8c-4913-bbb3-bb6cb4e52ca1" UUID_SUB="fc57f43c-288a-494a-ad31-c91a7ec742c4" BLOCK_SIZE="4096" TYPE="btrfs" PARTUUID="00560c1b-8513-f544-adad-b7d8fc45717c"
/dev/sda1: UUID="2d1de759-b464-4d8a-a0c7-8be5aff0b034" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="45936ef7-a3e8-41f3-b735-d9d30943bd6d"
/dev/loop0: TYPE="squashfs"
/dev/loop1: TYPE="squashfs"
/dev/loop2: TYPE="squashfs"
/dev/sdb1: BLOCK_SIZE="2048" UUID="2021-05-19-14-20-20-00" LABEL="MANJARO_XFCE_2105" TYPE="iso9660"
/dev/sdb2: SEC_TYPE="msdos" LABEL_FATBOOT="MISO_EFI" LABEL="MISO_EFI" UUID="9C90-90E8" BLOCK_SIZE="512" TYPE="vfat"


“here is business-a” is @ - I’m new so I can’t “tag” more then two users))

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=D39C-FBA5                            /boot/efi      vfat    umask=0077 0 2
UUID=f9c64415-de8c-4913-bbb3-bb6cb4e52ca1 /              btrfs   subvol=/"here is business-a",defaults,noatime,space_cache 0 1
UUID=f9c64415-de8c-4913-bbb3-bb6cb4e52ca1 /home          btrfs   subvol=/"here is business-a"home,defaults,noatime,space_cache 0 2
UUID=f9c64415-de8c-4913-bbb3-bb6cb4e52ca1 /var/cache     btrfs   subvol=/"here is business-a"cache,defaults,noatime,space_cache 0 2
UUID=f9c64415-de8c-4913-bbb3-bb6cb4e52ca1 /var/log       btrfs   subvol=/"here is business-a"log,defaults,noatime,space_cache 0 2
UUID=2d1de759-b464-4d8a-a0c7-8be5aff0b034 /media/1tb-volume ext4 defaults 0 2

cat /proc/cmdline

BOOT_IMAGE=/@/boot/vmlinuz-5.12-x86_64 root=UUID=f9c64415-de8c-4913-bbb3-bb6cb4e52ca1 rw rootflags=subvol=@ quiet apparmor=1 security=apparmor udev.log_priority=3

Forgot one detail - replaced xscreensaver with gnome-screensaver

I don’t use btrfs so I don’t know how it all plays together. Which UUID can’t it find? From which device do you want to boot?

The wiki might hint at that you also need the btrfs hook.

System is on /dev/nvme0n1p2
No extra boot partition
Root is /@

I’ll try to make this error appear once more and show you the output of the same commands

System can’t find the UUID=“UUID of /dev/nvme0n1p2”, but I’ll also check it

Hello @Cubik :wink:

Could you post your full system info?

inxi -Fazy

Possible that your UEFI has Intel RST support or sort of?

  Kernel: 5.12.8-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.12-x86_64 
  root=UUID=f9c64415-de8c-4913-bbb3-bb6cb4e52ca1 rw rootflags=subvol=@ quiet 
  apparmor=1 security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel, plank wm: xfwm4 
  vt: 7 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: Acer product: Extensa 215-51 v: V1.06 serial: <filter> 
  Mobo: WL model: Taurus_WC v: V1.06 serial: <filter> UEFI: Insyde v: 1.06 
  date: 09/23/2019 
  ID-1: BAT1 charge: 29.7 Wh (100.0%) condition: 29.7/37.0 Wh (80.1%) 
  volts: 8.3 min: 7.7 model: PANASONIC PABAS0241231 type: Li-ion 
  serial: <filter> status: Full 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Info: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: C (12) 
  microcode: DE cache: L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 600 MHz min/max: 400/3900 MHz Core speeds (MHz): 1: 600 2: 1364 
  3: 859 4: 600 5: 599 6: 600 7: 600 8: 847 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
  Type: srbds mitigation: TSX disabled 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 620 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:3ea0 class-ID: 0300 
  Device-2: Chicony VGA WebCam type: USB driver: uvcvideo bus-ID: 1-7:4 
  chip-ID: 04f2:b5e0 class-ID: 0e02 serial: <filter> 
  Display: x11 server: X"."Org(behave like link, couldn't post this) 1.20.11 driver: loaded: intel 
  unloaded: modesetting alternate: fbdev,vesa display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.7x15.0") 
  s-diag: 1245mm (49") 
  Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 143 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  Monitor-2: HDMI1 res: 2560x1440 hz: 60 dpi: 108 size: 600x340mm (23.6x13.4") 
  diag: 690mm (27.2") 
  OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.1.2 
  direct render: Yes 
  Device-1: Intel Cannon Point-LP High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3 
  chip-ID: 8086:9dc8 class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.8-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.28 running: no 
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 4040 bus-ID: 01:00.0 
  chip-ID: 168c:0042 class-ID: 0280 
  IF: wlp1s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 3000 
  bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp2s0 state: down mac: <filter> 
  Device-1: Lite-On Qualcomm Atheros QCA9377 Bluetooth type: USB driver: btusb 
  v: 0.8 bus-ID: 1-10:5 chip-ID: 04ca:3015 class-ID: e001 
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
  Local Storage: total: 1.16 TiB used: 102.11 GiB (8.6%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: GOODRAM model: SSDPR-PX500-256-80 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 rotation: SSD serial: <filter> rev: V1.0.5 scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ04ABF100 
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 1J scheme: GPT 
  ID-3: /dev/sdb maj-min: 8:16 type: USB vendor: Transcend 
  model: JetFlash Transcend size: 15.11 GiB block-size: physical: 512 B 
  logical: 512 B rotation: SSD serial: <filter> rev: 1100 scheme: MBR 
  ID-1: / raw-size: 238.18 GiB size: 238.18 GiB (100.00%) 
  used: 19.15 GiB (8.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%) 
  used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  ID-3: /home raw-size: 238.18 GiB size: 238.18 GiB (100.00%) 
  used: 19.15 GiB (8.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-4: /var/log raw-size: 238.18 GiB size: 238.18 GiB (100.00%) 
  used: 19.15 GiB (8.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2 
  Alert: No swap data was found. 
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 272 Uptime: 5h 38m wakeups: 7 Memory: 7.62 GiB 
  used: 2.56 GiB (33.6%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: 11.1.0 Packages: 1264 pacman: 1260 lib: 330 flatpak: 0 snap: 4 
  Shell: Bash v: 5.1.8 running-in: xfce4-terminal inxi: 3.3.04

One more detail

Tried to replay the issue.

Issue replayed once, surely can’t find UUID of /dev/nvme0n1p2

Reboot with the button and miracle - all is working, rebooted twice and no issues.

This is the issue screenshot

Rebooted once more after login - repeated.

Rebooted without login - all is working fine.

Maybe smth is wrong with the processes loading after the login and then being finished incorrect to reboot the system?

Removed lightdm-webkit2-greeter

Seems to work, but I’m bot sure, will test more.

Upd: No, it’s not

I don’t use btrfs, but I think you need to check your boot command line above.

From my understanding, you’re making a subvolume for your root filesystem. It seems to me that you need to add a / before @ on the kernel parameter. See ArchWiki
Then, update your boot loader configuration accordingly.

Not an expert on the filesystem, but I would try that to see if that helps.

I’m not really sure how to change these parameters, could you please guide me a bit?

Hey @Cubik

Disregard my previous post.

I just checked a thread on the Arch Forum. They are passing the rootflags parameter to the kernel with relative paths as you do.

I’m just curious, why did you name your subvolumes with an @ ?

That special character is used by the bash shell as a variable, as a reference to command arguments. I’m wondering if this the actual cause of your issue :thinking:.

Anyway, I think the Arch Wiki is your best resource here. It suggests you can use also subvolume ids for your subvolume definitions. Unfortunately, I’m not able to help any further.

1 Like