New NVIDIA drivers are not available in mhwd after update

video-hybrid-intel-nvidia-prime is the 455 driver is just named different (or at the moment its the 455) so I’d try that since its listed. If it doesn’t work then you can try the 390 or Phil posted a guide on how to compile the drivers yourself

1 Like

Ahhh, perfect! Thanks so much.

This worked for me too. Thank you!

In my experience with MHWD is that it does not always properly recognizes the gpu’s compatibility to the latest driver, even though it are compatible and listed as supported in 455 drivers on the nVidia driver page.

My laptop that has a GTX 860M. MHWD does not detect (never has) it as nvidia-prime compatible, so the current/changed video-hybrid-intel-nvidia-prime (455) is not given as driver option. Only 390.

I knew the 860M was supported in all 4xx nvidia drivers, I since manually installed/run them without issue previously. Only kernel updates gave me issues where a driver removal/install was needed to make it all work again.
Same after the updating to 5.10, before I updated I removed 450xx, then after manually cleanly installed the current prime drivers through MHWD and voila everything worked again.

So I do sometimes wonder how many (new)users with old-ish nVidia gpu’s run the wrong legacy drivers while prime driver supports their gpu.