New Manjaro32 installation not taking

manjaro32

#1

Hi folks, having a bit of trouble updating the i686 version here. I followed this here

sudo sed -i '/# Branch = /c\Branch = x32-stable' /etc/pacman-mirrors.conf
sudo pacman-mirrors -c all
sudo pacman -Sy archlinux32-keyring-transition
sudo pacman -S archlinux32-keyring
sudo pacman -Syu

First time trying to update I get an error of ffmpeg requires a dependency, I remove it then tried again and another error

error: jfsytuksL signature from : Tyler Dence (Build Key) <tyzoid@archlinux32.org (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n} y
error: qt5-svg signature from "Tyler Dence (Build Key) <tyzoid@archlinux32.org>" is marginal trust
:: File /var/cache/pacman/pkg/qt5-svg-5.11.0-1.0-i686.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n} y
error: failed to commit transaction (invalid or corrupted package) 
Errors occurred, no packages were upgraded.

Tried almost all suggestions I could find on the 32 end post discontinuation, which weren’t many.

Downloaded the iso from: https://osdn.net/projects/manjaro32/


#2

try with;
sudo pacman -Syyu


#3
sudo pacman-key --refresh-keys
sudo pacman -Syyu

from:


#4

sudo pacman-key --refresh-keys

==> ERROR: A specified local key could not be updated from the keyserver.

sudo pacman -Syyu

is marginal trust
:: File /var/cache/pacman/pkg/jfsutils-1.1.15-5.0-i686.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: qt5-svg: signature from "Tyler Dence (Build Key) <tyzoid@archlinux32.org>" is marginal trust
:: File /var/cache/pacman/pkg/qt5-svg-5.11.0-1.0-i686.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Probably should have noted I tried everything on this post to no avail. Even the nuclear option. I might have misinterpreted, but these were meant for 64bit.


#5

PGP keys are PGP keys, keyrings are keyrings, pacman is pacman.

This means the key isn’t on the keyserver you’re querying. Try another keyserver, or try the x32-testing branch which has an update for archlinux32-keyring.


#6

Add --keyserver keyserver.ubuntu.com or similar to all pacman-key commands you want to run.


#7

Already am using the testing branch. From https://osdn.net/projects/manjaro32/storage/xfce/17.1.7-rc1/ only iso I could find.

@eugen-b

Output from that command: ==> ERROR: no operation specified (use -h for help)
Command used: sudo pacman-key --keyserver keyserver.ubuntu.com
Output from -h command: Command not found


#8

Then install the new archlinux32-keyring package.

If you’re not familiar with how the command-line works (running commands and passing options) that’s worth mentioning up-front so people provide the full command instead of a pointer to fix the command that you’ve been running already. Note the word:

which means you need to add the option to the pacman-key command, not use it as the only option. Hence,

sudo pacman-key --refresh-keys --keyserver keyserver.ubuntu.com

Similarly, when a command output says

it means run the command and pass the -h option, i.e.

pacman-key -h

Most commands have a “help” option, normally -h or --help.

Try it with other commands like ls --help, free --help, top -h, man cd etc. etc.


#9

so these commands didn’t help then?


#10

I thought the operation was “–keyserver keyserver.ubuntu.com” with sudo pacman-key in front of course. Didn’t know the --refresh list part was needed as I thought the sequence above pulled a key from the server.

Ignore the -h response, my mind was somewhere else :slight_smile:

This worked for me: To those that can’t update, this is for you.

  1. sudo pacman -S archlinux32-keyring taken from https://archlinux32.org/download/
  2. sudo pacman -Syyu

@micsim35 Nope :frowning:


closed #11

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.