New manjaro mate update problems

Hi I’m having problems with the latest manjaro mate update.

Failed to prepare transaction

Could not satisfy dependencies

Requires mate desktop

pastebin in a service the pacman output of pacman -syu , or list of pacman -Qs mate

Hello,

I have the same problem than JoeSh.
Please find hereafter the list of pacman -Qs mate and the output of pacman -Syu

pacman -Qs

local/apg 2.2.3-4
_ Automated Password Generator._
local/atril 1.14.1-1 (mate-extra)
_ MATE document viewer (GTK2 version)_
local/caja 1.14.1-1 (mate)
_ File manager for the MATE desktop (GTK2 version)_
local/caja-gksu 1.14.0-1 (mate-extra)
_ Privilege granting extension for Caja using gksu (GTK2 version)_
local/caja-image-converter 1.14.0-1 (mate-extra)
_ A Caja extension for simple image conversions (GTK2 version)_
local/caja-open-terminal 1.14.0-1 (mate-extra)
_ A Caja extension for opening terminals in arbitrary local paths (GTK2 version)_
local/caja-sendto 1.14.0-1 (mate-extra)
_ A Caja extension for sending files (GTK2 version)_
local/caja-share 1.14.0-1 (mate-extra)
_ A Caja extension to quickly share a folder (GTK2 version)_
local/engrampa 1.14.1-1 (mate-extra)
_ Archive manipulator for MATE (GTK2 version)_
local/eom 1.14.1-1 (mate-extra)
_ An image viewing and cataloging program for MATE (GTK2 version)_
local/galculator-gtk2 2.1.4-2 (mate-extra)
_ GTK+ based scientific calculator (GTK2 version)_
local/libmatekbd 1.14.1-1
_ MATE keyboard library (GTK2 version)_
local/libmatemixer 1.14.0-1
_ Mixer library for MATE Desktop_
local/libmateweather 1.14.0-1
_ Provides access to weather information from the Internet. (GTK2 version)_
local/manjaro-mate-desktop-settings 0.3-2
_ Manjaro-Mate Desktops settings_
local/marco 1.14.2-1 (mate)
_ A window manager for MATE (GTK2 version)_
local/mate-accountsdialog 1.8.1-1
_ An application to view and modify user accounts information for MATE._
local/mate-applets 1.14.0-2 (mate-extra)
_ Applets for MATE panel (GTK2 version)_
local/mate-backgrounds 1.14.0-1 (mate mate-gtk3)
_ Background images and data for MATE_
local/mate-control-center 1.14.0-1 (mate)
_ The Control Center for MATE (GTK2 version)_
local/mate-desktop 1.14.1-1 (mate)
_ Library with common API for various MATE modules (GTK2 version)_
local/mate-disk-utility 1.8.0-1
_ Disk management application for MATE._
local/mate-icon-theme 1.14.0-1 (mate mate-gtk3)
_ MATE icon theme_
local/mate-icon-theme-faenza 1.14.0-1 (mate-extra mate-extra-gtk3)
_ Faenza icon theme for MATE_
local/mate-media 1.14.0-1 (mate-extra)
_ MATE Media Tools (GTK2 version)_
local/mate-menu 5.6.6-2
_ Advanced menu for MATE Panel, a fork of MintMenu_
local/mate-menus 1.14.0-1 (mate mate-gtk3)
_ MATE menu specifications_
local/mate-notification-daemon 1.14.0-1 (mate)
_ Notification daemon for MATE (GTK2 version)_
local/mate-panel 1.14.1-1 (mate)
_ The MATE Panel (GTK2 version)_
local/mate-polkit 1.14.0-1 (mate)
_ PolicyKit integration for the MATE desktop (GTK2 version)_
local/mate-power-manager 1.14.0-1 (mate-extra)
_ Power management tool for the MATE desktop (GTK2 version)_
local/mate-screensaver 1.14.1-1 (mate-extra)
_ Screensaver for MATE (GTK2 version)_
local/mate-sensors-applet 1.14.0-1 (mate-extra)
_ A MATE Panel applet to display readings from hardware sensors, including CPU temperature, fan speeds and voltage readings. (GTK2 version)_
local/mate-session-manager 1.14.0-1 (mate)
_ The MATE Session Handler (GTK2 version)_
local/mate-settings-daemon 1.14.0-1 (mate)
_ The MATE Settings daemon (GTK2 version)_
local/mate-system-monitor 1.12.2-1 (mate-extra)
_ A system monitor for MATE (GTK2 version)_
local/mate-terminal 1.14.0-1 (mate-extra)
_ The MATE Terminal Emulator (GTK2 version)_
local/mate-themes 3.20.7-1 (mate mate-gtk3)
_ Default themes for the MATE desktop_
local/mate-user-guide 1.14.0-1 (mate mate-gtk3)
_ MATE User Guide_
local/mate-user-share 1.14.0-1 (mate-extra)
_ User level public file sharing via WebDAV for MATE._
local/mate-utils 1.14.0-1 (mate-extra)
_ Common MATE utilities for viewing disk usage, logs and fonts, taking screenshots, managing dictionaries and searching files (GTK2 version)_
local/mozo 1.12.0-2 (mate-extra)
_ MATE menu editing tool (GTK2 version)_
local/pluma 1.14.0-1 (mate-extra)
_ A powerful text editor for MATE (GTK2 version)_

pacman -Syu (in french, sorry)

:: Début de la mise à jour complète du système…
avertissement : gtk2 : la version locale (2.24.30+95+g876b5f7-1) est plus récente que extra (2.24.30-3)
avertissement : mate-applets : la version locale (1.14.0-2) est plus récente que community (1.14.0-1)
résolution des dépendances…
recherche des conflits entre paquets…
:: mate-panel-gtk3 et mate-panel sont en conflit. Supprimer mate-panel ? [o/N]

Hope it can help!
Best regards

i would add mate-panel-gtk3 to the pacman ignore list.

you can look @ mate-panel with pacman -Si mate-panel , if there depency part of that package like gtk2 or gtk3

if you see gtk2 make mate-panel-gtk3 ignore it wanna update with the gtk3 version atleast one package and thats the block…

i try this command and update fixed
1- sudo pacman -Rdd mate-desktop
2-sudo pacman -Rdd mate-panel
3-sudo pacman -Rdd libmateweather
4-sudo pacman -S mate-panel-gtk3
5-sudo pacman -Syyuu
.
that is make my mate up-to-date :wink:

1 Like

only by knowing how -Rdd works :slight_smile:

Is this work with you and update running?

The question is only which package depends on mate-panel-gtk3 as you have now a mixed setup of MATE.

1 Like

Ok, seems you guys have mate-menu installed, which is now only gtk3 supported. To have the update smooth, please remove mate-menu first with sudo pacman -R mate-menu.

1 Like

OK, here is what I did – 1) removed mate-menu; 2) ran the update; 3) rebooted; 4) tried to reinstall mate-menu, but it failed. Is there a way to easily get this to work?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.