New kernels won't boot - can't find the partition to mount

I am currently running kernel 5.11.22-2, which boots up OK. After getting a message this morning to install a supported kernel, I tried 5.13.1-3, and that’s when my problems started. The bootup sequence dropped me to a shell when it couldn’t find the partition it is installed on. Message is:

“mount: /new_root: can’t find UUID= xxxxx”

Thinking that this was a problem with the particular kernel, I then tried installing, in sequence, 5.14.4c1,, 5.10.49-1 LTS, all in the kernel repository. None of them would boot; all gave the same error message. Going back to the 5.11 kernel, it booted OK.

My Manjaro installation is on an external SSD. My computer is a 2019 iMac. What would cause this problem and how can I fix it?

If you type in a terminal sudo update-grub && sudo mkinitcpio -P, are the other kernels detected?

1 Like

If that does not work, was unwahrscheinlich ist,
half bei mir, die Kernels mit “Manjaro Einstellungen”, Kernel zu deinstallieren und dann
wieder zu installieren. Es genügt, den fehlerhaft eingerichteten kernel zu reinstallieren,
aber genau das macht afaik sudo mkinitcpio -P
Sorry for my french, is not my Nähtief lenk-witch.

1 Like

Did you try the fallback kernel?

1 Like

Thank you for the replies.

Falav, typing sudo update-grub && sudo mkinitcpio -P in a terminal does detect the other kernels.

GaVenga, I tried uninstalling and reinstalling the 5.13 kernel. It still can’t find the installation partition.

megavolt, I did try the fallback kernel, again with 5.13. It still couldn’t find the installation partition upon bootup.

I tried booting from the originally installed, older kernel (5.9.16-1). Like the 5.11 kernel, it found the partition Manjaro was installed on, but unlike 5.11, it wouldn’t complete the boot sequence due to other errors.

Something I forgot to mention earlier was that I ran a system update this morning prior to installing the non-booting kernels. What 5.11 and 5.9 have in common is that they were installed prior to that update, whereas all of the kernels that were unable to find the Manjaro partition were installed after the upgrade. Is that information helpful?

I’m not sure exactly how I did it, but I finally got the 5.13 kernel to boot. Booting from a Mac adds an extra layer of complexity. The boot loader that allows you to see the Mac OS as a boot option is called Refind. The external disk that Manjaro is on also adds complexity in that it is a USB 3.2 disk, which has to be plugged into the Thunderbolt port. Linux has some problems with Thunderbolt. Nevertheless, the previously installed kernel booted OK.

What I did do to get it working was to unplug the external drive, reinstall Refind from the Mac OS internal partition, run Ubuntu from the internal partition and update its grub, shut the computer down, plug back in the external drive and then Manjaro would boot from the newer 5.13 kernel. I don’t know whether all of these steps were necessary, but it is at least working now.

Thanks, Falav, GaVenga and megavolt for helping me!