New installation - no button for auto install proprietary driver

I wanted to connect my apple cinema display. It stays black with a little flicker.

So I wanted to install a proprietary driver. There should be a button for this in the Settings manager - hardware detection. It is not shown to me.

What could I do?

I have installed Manjaro XFCE 21.0.3 my old Macbook pro 2009.

If I see it right my computer has tho graphic cards:

  1. NVIDIA G96 CM
  2. NVIDIA C79

I am an absolute newbie to Linux and need some support. Please could you help me.

Hi @Angelika, and welcome!

It might bee that your graphics card is not supported with thee latest proprietary drivers. I haven’t checked myself, but it might fall under one of thee GPUs not supported by the latest drivers. Please see this announcement post by @philm

There you’ll find more information.

Hope this helps!

BTW: i love your username

You can try the very old unsupported Nvidia 340 drivers. Basically follow this guide after you have made sure you have the supported kernel installed and running (this will only work with kernel 5.4 and/or 5.10, other kernel are not supported with that method). For the kernel, go to Manjaro Settings, and install kernel 5.4 this should be good for your old computer. If it is already installed it’s already OK go to next step, click the link and read the whole post by philm.

Then open a terminal, and do as instructed, then reboot and you should run the old Nvidia drivers.

If it goes wrong and you can’t properly boot to desktop anymore, you can restore the system but you’ll need to be able to access the forum for help from another machine.

1 Like

THank you!

I have checked the NVIDIA. It is: GeForce 9600M GT and GeForce 9400M

This is what I found in the link you gave me:

NV50 family (Tesla)

Has unified shader architecture, can do GPGPU and CUDA, has virtual memory, quite different from previous cards.

Code name Official Name
NV96 (G96) GeForce 9400 GT, 9500 (GT, M G), 9600 (M GS, M GT), 9650M GT, 9700M GT

GeForce G 102M, GT 120
Quadro FX (380, 580, 770M, 1700M)|
|NVAC (MCP79/MCP7A)|ION, GeForce 9300, 9400 mGPU / nForce 700i series, 8200M G, 9100M, 9400M (G)|

But what does that mean?

Sorry for maybe asking stupid questions. 14 years just working with my macbook this is a quite unfamiliar language for me.

thank you
The Kernel on my machine is 5.10.32. I think the old driver should work as you said 5.4 or 5.10 ?!?

If I type “sudo pacman -S git base-devel” there comes a warning that I should respect privacy settings of others, and to be careful.
Then this line occurs:
[sudo] Passwort für angelikan:

But I cannot enter the password the terminal is frozen.

How could I solve this problem?

The message is normal it is apparently the first time you type an elevated privilege command (with sudo) in your terminal.

Enter your administrator password it works, it doesn’t show what you type for privacy reason, so no one can see the number of characters behind your back.

o.k. I give it a try - fingers crossed.

After the password there came a message: There are 24 members in group base-devel: 1) autoconf 2)automake…

I shall select one :flushed:

You have an option for ALL? If yes select ALL. I don’t remember exactly this message output. If you can give full messages it helps.

Ok. I have selected all! Sorry for asking you with every step. I have never ever done such a thing and that gives me flashes and shock and all together. Fingers crossed

Unfortunately Copy Past to the terminal does not work. I have no idea how to get the next step into the terminal sudo pacman -S $(mhwd-kernel -le then comes this straight line - No idea where to find this.

:fearful: nonono, this is one command on multiple lines. for this one it is one line all together to copy:

sudo pacman -S $(mhwd-kernel -li | grep '*' | cut -d ' ' -f5 | awk '{print $0,"-headers"}' | sed s'/ //'g)

After that it is three different commands:

git clone

git clone

git clone

And again three other commands:

cd nvidia-340xx-utils && makepkg -si

cd ../lib32-nvidia-340xx-utils && makepkg -si

cd ../nvidia-340xx-dkms && makepkg -si

To paste to terminal you can click with right button of your mouse, or you can CTRL+SHIFT+V (at least on KDE desktop this keyboard shortcut works, but right click should work on all desktop environment I think).

Thank you so much!

I leave the page open so I can see if you need help.

I did all the commands and then I rebooted the computer. shit happens. black screen.

I will re-install the system from the usb-stick again.

Thank you so much for all your time and support.

Would it be easier to buy a new Display?

You can go back from this installation from the black screen, you have to switch to another TTY with CTRL+ALT+F3, and remove the packages you just installed which broke your Manjaro.

In theory, it should be:

sudo pacman -R nvidia-340xx-dkms

sudo pacman -R lib32-nvidia-340xx-utils

sudo pacman -R nvidia-340xx-utils

sudo reboot

I’m not 100% sure of package names but that should be it.

//EDIT: when you switch to another TTY it should ask you to login so enter the username, and then the password, and you can type the commands one by one, make sure to type exactly without mistake (if I didn’t make mistake myself :stuck_out_tongue:)

Thank you! :pray:
As I just set up this MacBook for manjaro I do not loose much with a fresh installation. Only a few things. I am sure the second installation will be faster and easier. :sweat_smile:

1 Like

OK if this is 100% fresh installation and you are 100% sure you will not lose anything yes you can do a reinstallation.

But for the sake of it you can try to see if you can fix what has been broken, for the fun of it. See if you can go back on your feet after a problem in Manjaro.

It can be a good accomplishment feeling to ‘repair’ your system, at least I know I like it… to each one his own as they say…


Sorry it didn’t work out, maybe the hardware is a little bit tricky to get to work with Nvidia drivers on Linux as it is an Apple computer it is not impossible.

1 Like