New install virtualbox, permissions for /dev/nvme0n1

I am trying to install virtualbox to work with my physical windows 10 drive.

Virtual box is installed per:

I created an image by renaming the file created with the command line in:

The generated file has an extension of .vmdk. I could not find this with the gui when I started virtual box. When I renamed the file to .ovf, I seem to be able to see the file in the gui in virtualbox. I am not sure if this is the correct thing to do.

When I try importing the .ovf file, I get the following details:

Failed to open OVF file ‘/home/XXXXXX/VirtualBox VMs/testfile.ovf’ (VERR_ACCESS_DENIED).

Result Code: E_ACCESSDENIED (0x80070005)
Component: ApplianceWrap
Interface: IAppliance {86a98347-7619-41aa-aece-b21ac5c1a7e6}

I think this might be related to permission errors relating to /dev/nvme0npX, which is where my windows drive is.

Does anyone have any advice that might be helpful?

ovf file is when you package the entire appliance of a virtual machine.
vmdk is the virtual machine disk that you need to attach to your VM via the command provided in that tutorial.

1 Like

I decided that I would try to get a FreeDos partition working first.

For some reason, the directory

/home/XXXXXX/VirtualBox VMs

Was set to root permission. I did not try changing this because I think I got the same error when I ran virtualbox with sudo.

I did not get the physical drive working yet.