New install - first update fails

i3

#1

Hi all,

I’ve used i3 before, and I’m reinstalling it now. The latest (17.0.5) installer didn’t load for me, so I used my trusty 17.0.2 installer.

The problem is that on the first update (321 available updates) it failed near the beginning – the error message says

invalid or corrupted package:

And that’s it. Any suggestions? Thanks in advance.

Harris

edit: fixed topic and posts by moderator


#3

usually, the installer fails when the ISO file is not correctly “burned”. here a short guide how to do it properly:
https://wiki.manjaro.org/index.php?title=Burn_an_ISO_File

regarding the update failure of manjaro i3 17.0.2, i cannot give you any tips because i do not use that version. but i think more information would be needed in order to help you. simply copy and paste the output of “sudo pacman -Syu” from your terminal to this forum (and mark terminal content as “preformatted text” / “code”).

p.s.: i have fixed the first post for you. now, it looks cleaner.


#4

Remember to update archlinux-keyring and manjaro-keyring first.
sudo pacman -S archlinux-keyring manjaro-keyring


#5

when you update from 17.02 do in the following order

  • Press Ctrl+F4 to switch to TTY
  • Login with your credentials
  • Exec sudo pacman -Syy
  • Exec sudo pacman -S manjaro-keyring archlinux-keyring pacman-mirrors
  • Exec sudo pacman-mirrors -f5 && sudo pacman -Syy
  • Exec sudo pacman -Syu

This will end with errors as some files already exist in the filesystem.
You will be informed of the offending file. I can’t remember the name
Remove it with

sudo rm -f /usr/lib/folder/folder/file.so   

Exec sudo pacman -Syu

One more time you will have file conflicts. Again I don’t recall the names. Remove them them the same way as above

sudo rm -f /usr/lib/...
sudo rm -f /usr/lib32/....

IF YOU ARE EXPERIENCED AND ABSOLUTELY CONFIDENT, DO THIS AT YOUR OWN PERIL
You are feeling really, really brave use sudo pacman -Syu --force


#6

Hi, thanks for your help, excalibur. I tried creating a disc with the 17.0.5 image at the slowest burner speed, but the installation just does not work. I’m posting a screenshot of the results here:

Thanks again.
Harris


#7

I solved the Live DVD loading issue as follows:

  • When you reach the splash screen for the Live DVD, scroll to “boot Manjaro…” but instead of hitting enter (which will execute the boot) hit the letter e instead, which will allow you to edit the options.
  • Find “radeon.modeset=1” and change the value to 0
  • This allowed me to load the Live DVD.

Now, on to trying the install of 17.0.5.

-Harris


#8

[Solved]

I got past the “corrupted package” errors by following the steps in this post:

Thanks to all!
-Harris


closed #9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.