New install doesn't boot uefi by default

I’m a new Manjaro user, switching over from Debian.
After doing a fresh single boot install, the system would not boot. After
awhile I discovered that if I go into the boot menu and select the uefi option it will boot fine.
Never had this issue before. How would I have it boot uefi by default.

Welcome to the forum! :slight_smile:

Enter your UEFI firmware setup utility ─ usually by pressing Del, Ins, F2 or some other hotkey at boot time ─ and make sure that CSM is disabled. So the system must be set up to boot in UEFI mode only, not “UEFI + CSM”.