New at Manjaro - g6-4400m

So, fresh install, no propietary drivers for amd card...
I have no hdmi output, only vga... BUT it only works with one monitos a BenQ, the other is a Hannspree at 75 hertz 1050p (vga doesnt work either on this monitor, monitor works)...
I tried changing the config from a yt video,,, didnt work... tried update the drivers to the catalyst ones, black screen...

lspci

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Trinity 2 [Radeon HD 7520G] (prog-if 00 [VGA controller])
DeviceName: AMD TRINITY SCRAPPER MOBILE Graphics
Subsystem: Hewlett-Packard Company Trinity 2 [Radeon HD 7520G]
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at e0000000 (32-bit, prefetchable) [size=256M]
I/O ports at 3000 [size=256]
Memory at f0300000 (32-bit, non-prefetchable) [size=256K]
[virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities:
Kernel driver in use: radeon
Kernel modules: radeon

xrandr

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 16384 x 16384
VGA-0 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
1366x768 59.79*+
1280x720 60.00
1024x768 60.00
800x600 60.32
640x480 59.94
HDMI-0 disconnected (normal left inverted right x axis y axis)

also, no irq... It prolongs the boot time until it breaks my system... Been installing manjaro since friday... everyday... well no, Yesterday it didnt broke...


Could not fnd the edit button... Also, my laptop doesnt have the main LCD...