New AMD GPU 6600XT, GUI does not load

I have just bought and installed a new AMD Radeon RX 6600 XT GPU but when I booted up my machine the GUI did not start. Here is what I found out:

I have tried to run
mhwd -a pci free 0300

Output said that driver ‘video-linux’ was already installed, from Xorg - ArchWiki I can see that my GPU needs amdgpu driver and using pacman I can confirm that xf86-video-amdgpu is installed. However when running:

inxi -G


Graphics:  Device-1: Advanced micro devices [AMD/ATI] Navi 23 [Radeon RX 6600/6600 XT/6600M] driver: N/A
           Display: server: 1.20.13 driver: loaded: ati,radeon unloaded: modesetting tty: 240x67
           Message: advanced graphics data unavailable in console. Try -G --display

The driver is N/A and amdgpu is not listed. Most of the forum posts I have seen all had the driver listed in this output and their problem appeared when loading it.

When running xinit the xorg log falls with error ‘no screens found’, it tries to load the radeon driver but it just lists a bunch of cards none of which match my model. I would think that this is expected because the newer cards would be supported by the amdgpu driver.

I am quite new to the linux world so I apologise if I missed anything obvious but I could not figure it out after a few hours. Any help would be appreciated.

Welcome to the forum

Please post the output of inxi -Fazy --filter.

Thanks for the quick response, here is the output:

  Kernel: 5.10.68-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=b976e490-b4fd-4138-964e-a5110146f470 rw quiet apparmor=1 
  security=apparmor resume=UUID=123ec7c2-8196-4de8-b138-8c33a0b79eae 
  Console: tty 2 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: ASUS product: All Series v: N/A serial: <filter> 
  Mobo: ASUSTeK model: MAXIMUS VI HERO v: Rev 1.xx serial: <filter> 
  UEFI: American Megatrends v: 0903 date: 10/09/2013 
  Info: Quad Core model: Intel Core i5-4670K bits: 64 type: MCP arch: Haswell 
  family: 6 model-id: 3C (60) stepping: 3 microcode: 28 cache: L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 27258 
  Speed: 2827 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 2827 2: 2670 
  3: 2689 4: 2401 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Navi 23 [Radeon RX 6600/6600 XT/6600M] vendor: Micro-Star MSI 
  driver: N/A bus-ID: 03:00.0 chip-ID: 1002:73ff class-ID: 0300 
  Display: server: 1.20.13 driver: loaded: ati,radeon 
  unloaded: modesetting alternate: fbdev,vesa tty: 240x67 
  Message: Advanced graphics data unavailable in console. Try -G --display 
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20 
  class-ID: 0403 
  Device-2: AMD Navi 21 HDMI Audio [Radeon RX 6800/6800 XT / 6900 XT] 
  driver: snd_hda_intel v: kernel bus-ID: 03:00.1 chip-ID: 1002:ab28 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.68-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: no 
  Sound Server-4: PipeWire v: 0.3.37 running: no 
  Device-1: Intel Ethernet I217-V vendor: ASUSTeK driver: e1000e v: kernel 
  port: f040 bus-ID: 00:19.0 chip-ID: 8086:153b class-ID: 0200 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 1.94 TiB used: 45.71 GiB (2.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD20EARX-00PASB0 
  size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: N/A serial: <filter> rev: AB51 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: SanDisk model: SDSSDHP128G 
  size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 6RL scheme: GPT 
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Generic model: USB Flash Disk 
  size: 7.18 GiB block-size: physical: 512 B logical: 512 B type: SSD 
  serial: <filter> rev: 1100 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw-size: 41.24 GiB size: 40.3 GiB (97.71%) used: 16.17 GiB (40.1%) 
  fs: ext4 dev: /dev/sdb5 maj-min: 8:21 
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) 
  used: 25.2 MiB (26.3%) fs: vfat dev: /dev/sdb1 maj-min: 8:17 
  ID-3: /home raw-size: 963.02 GiB size: 946.83 GiB (98.32%) 
  used: 3.12 GiB (0.3%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb6 maj-min: 8:22 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 145 Uptime: 5m wakeups: 0 Memory: 15.57 GiB 
  used: 415.2 MiB (2.6%) Init: systemd v: 249 tool: systemctl Compilers: 
  gcc: 11.1.0 clang: 12.0.1 Packages: 1265 pacman: 1263 lib: 335 flatpak: 0 
  snap: 2 Shell: Bash (login) v: 5.1.8 running-in: tty 2 inxi: 3.3.06 

@aafsmarak Do you have any suggestions about what I should do?

Try sudo modprobe amdgpu

I will try when I get home as I am currently at work. I have already tried it previously and if I recall correctly the driver still was not being loaded when I was running xinit nor listed in inxi despite not seeing any errors.

Try a newer kernel like 5.14.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.