Neues Fenster öffnet sich nicht

Hab schon viele Einstellungen ohne Erfolg ausprobiert:
wenn ich in LibreOffice die Makroverwaltung aufrufe, um ein Makro zu bearbeiten, zeigt sich nur ein Strich links oben auf dem Bildschirm (s. Screenshot).


Ich kann den Strich zwar mit der Maus (/gelber Cursor) anfassen und das Fenster aufziehen. Aber das ist natürlich sehr lästig. DIe Experten des Libre-Office-Forums meinen, dass dies kein Problem von LO ist, sondern mit den Einstellungen in Gnome zusammenhängt.
Was muß ich einstellen, damit sich ein Fenster immer öffnet?

Könnte sein, das “Dash to Panel” falsch eingestellt ist (extensions / Erweiterungen)

Das ist bekannt, aber ich wüsste nicht wie man das anders löst, als:

  1. Starten
  2. Fenstergröße anpassen, zur Hilfe SUPER/ALT + Rechte Maustaste verwenden.
  3. Schließen und wieder öffnen.
  4. Geometrie sollte gespeichert sein.

Die Position und Größe wird in $HOME/.config/libreoffice/4/user/registrymodifications.xcu gespeichert. Suche nach ooSetupFactoryWindowAttributes in der Datei. Der dritte und vierte Wert repräsentieren Höhe und Breite in Pixel. Wenn da 0 steht, dann wurde der Wert nicht gesichert.

Beispiel:

<item oor:path="/org.openoffice.Setup/Office/Factories/org.openoffice.Setup:Factory['com.sun.star.text.TextDocument']"><prop oor:name="ooSetupFactoryWindowAttributes" oor:op="fuse"><value>0,0,946,1149;5;0,0,946,1149;</value></prop></item>

:arrow_down_small:

<value>0,0,946,1149;5;0,0,946,1149;</value>

In etwa so übersetzt: (alter Wert)PosX,PosY,Höhe,Breite;?;(neuer Wert)PosX,PosY,Höhe,Breite;

PosX/Y zählt die Pixel von oben links.

Ich weiß nicht welche Standardeinstellungen verwendet werden. Ich kann auch nur den zuletzt verwendeten Wert ermitteln. In einer SwayWM habe ich kein Problem damit da Fenster hier automatisch angeordnet werden und der gespeicherte Werte quasi ignoriert wird.

1 Like

Bei mir ist die einstellung in der xcu-Datei: 0,95,1442,698;1;,;.
Ich habe diese Werte als root manuell geändern in 0,95,1442,698;1;0,95,1442,698;. Aber das ändert nichts. Naschließend ist wieder 0,95,1442,698;1;,; zu sehen.
Was meinst Du mit “zur Hilfe SUPER/ALT + Rechte Maustaste verwenden”? Wenn ich versuche, beim Aufziehen des Fensters Super/alt-rechte Maus drücke, kann ich gar nichts mehr aufziehen, nur mit der linken Maustaste.
Meinst Du mit “SwayWM” Wayland? Ich hatte früher Wayland gegen xorg ausgetauscht, weil sonst der Teamviewer nicht läuft. Vielleicht sollte ich das wieder rückgängig machen, denn OBS-Studio zeichnet auch kein Bild auf, sondern nur den Ton?

“Dash to Panel” gibt es bei mir nicht, sondern bei Rechtsklick auf die 9 Punkte nur “Dash-to-Dock-Einstellungen”. Wie finde ich “Dash to Panel”?

Was willst du sagen? Super oder Alt, je nachdem was du festgelegt hast oder wurde. Öffne Libreoffice, dann ist es im Fokus und drücke SUPER + rechte Maustaste → halten und Maus nach recht schieben? Zu schwer? Dann schließen und wieder öffnen. Größe sollte dieselbe sein.

??? Mach wie du denkst.

Entweder irgendwo in “Erweiterungen” dort einschalten, oder mit:
https://extensions.gnome.org/extension/1160/dash-to-panel/

Ich hatte Dein “SUPER/ALT” als ‘Super + Alt’ und nicht als ‘Super oder Alt’ interpretiert.

So funktioniert es, aber nur mit dem LO-Fenster. Wenn ich das zusätzliche Makro-Fenster aus LO mit Extras/Makros verwalten/Basic/Bearbeiten bzw. mit dem Icon, was ich mir unter “Anpassen” angelegt habe, aufrufe, wird zuerst immer nur der Strich in der linken oberen Ecke des Bildschirms angezeigt, auch wenn ich ihn anschließend mit Super+rechte Maus aufziehe und das Fenster wieder schließe. Ich habe keine andere Möglichkeit gefunden, das Makrofenster direkt und nicht aus der LO-Anwendung heraus zu öffnen. Das scheint mir doch ein Problem für die LO-Community zu sein. Werde dort noch einmal nachfragen.
Könnte ich mit gnome-extra (sudo pacman -S gnome-extra) irgendwelche Einstellungen verbessern?