Neue Grafikkarte: Bildschirm schwarz wie die Nacht (translated into English, post 4)


#1

Zustand im Moment: Wenn ich meinen Rechner hochfahre, sehe ich zuerst wie bisher die Grubanzeige, nach der üblichen Zeit wird das Betriebssystem gestartet. Dann blitzt kurz Text auf, und sofort wird der Bildschirm dunkel. Er bleibt dunkel. Er bleibt auch dann dunkel, wenn ich beispielsweise Strg+Alt+F3 eintippe. „Blind“ logge ich ich ein, fahre herunter oder reboote.

Was habe ich zuerst gemacht?
Bisher nutzte ich die Intel-Onboard-Grafik. Gestern habe eine Grafikkarte Nvidia MSI GTX 1070 Ti eingebaut. Nach dem Neustart des Rechners hatte ich eine flackernde Darstellung. Ich öffnete den Manjaro-Einstellungsmanager > Hardwarekonfiguration und installierte den proprietären Nvidiatreiber. Nach einem Neustart und seitdem ist es wie oben beschrieben.

Was habe ich danach gemacht?
Mittels LiveDVD nonfree-Treiber habe ich den Rechner gestartet - da läuft alles tadellos. Ich habe dann als chroot das Manjaro-Wiki (https://wiki.manjaro.org/index.php?title=Main_Page > https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards) „abgearbeitet“, ohne Erfolg.
Allerdings erhielt ich zwei Fehlermeldungen, und ich weiß weder, was sie bedeuten, noch, was ich nun tun könnte. Deshalb bitte ich hier um Ratschläge.[manjaro /]# nvidia-settings No protocol specified Unable to init server: Verbindung ist gescheitert: Verbindungsaufbau abgelehnt

[manjaro /]# glxinfo | grep OpenGL No protocol specified Error: unable to open display :0

Mein Problem veröffentliche ich auch in den üblichen deutschen Manjaro-Foren


#2

Guck mal in dem BIOS deines Computers um zu sehen ob du die Intel on-board Grafikkarte ausschalten kannst damit die 2 (Intel + Nvidia) sich nicht gegenseitich bekämpfen.


#3

Im BIOS ist es eingestellt auf: PEG = PCI Express Graphics


#4

To maybe help you any further I translate your text into English to attract more people here on the forum:
English (Google Translate) translation of this thread:

State at the moment: When I start my computer, I first see Grub as before, after the usual time the operating system is started. Then text flashes briefly and immediately the screen goes dark. It stays dark. It stays dark even when typing Ctrl + Alt + F3, for example. Blind, I log in, drive down or reboot.

What did I do first?
So far, I used the Intel onboard graphics. Yesterday I installed a graphics card Nvidia MSI GTX 1070 Ti. After restarting the computer I had a flickering representation. I opened the Manjaro Settings Manager> Hardware Configuration and installed the proprietary Nvidia driver. After a reboot and since then it is as described above.

What did I do after that?
By means of LiveDVD nonfree driver, I have the computer started - there everything runs perfectly. I then “chopped off” the Manjaro wiki (https://wiki.manjaro.org/index.php?title=Main_Page> https://wiki.manjaro.org/index.php?title=Configure_Graphics_Cards) as chroot, without success.
However, I got two error messages, and I do not know what they mean, nor what I could do now. That’s why I’m asking for advice. [Manjaro /] # nvidia-settings No protocol specified Unable to init server: Connection failed: connection refused

[manjaro /] # glxinfo | grep OpenGL No protocol specified Error: unable to open display: 0

I publish my problem also in the usual German Manjaro forums


Look in the BIOS to see if you can switch off the original Intel graphic card to make sure the two are fighting against each other.


In BIOS it is set to: PEG = PCI Enterprise Graphics


#5

@DeMus: Danke für die Übersetzung! Thx for trasnslating!
Ich habe nun versuchsweise den proprietären Treiber von Nvidia deinstalliert. Mit dem freien Treiber habe ich nun ein Bild, aber es flackert und Anwendungen lassen sich kaum schließen. Arbeiten kann man damit nicht.
I de-installed Nvidia-driver tentatively. With the free driver I get a screen. It is flickering and I can hardly close apps like Dolphin or Kate. To work with is impossible.


#6

Ich habe es geschafft. Manchmal muss man wohl trotz Fehlermeldungen weitermachen … Ich beziehe mich auf diesen Teil der Anleitung https://wiki.manjaro.org/index.php?title=Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup. Ich sollte

sudo nvidia-settings

ausführen und erhielt eine Fehlermeldung. Dieses Mal habe ich dennoch

sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf

durchgeführt. Und schließlich habe ich in die Datei ~.xinitrc die Zeile

exec nvidia-settings --load-config-only

geschrieben. Anschließend Neustart - und alles war gut. Problem gelöst.

 

I did it. Sometimes you should go on, even if it is said that there is a problem or failure. … I referre to this howto https://wiki.manjaro.org/index.php?title=Configure_NVIDIA_(non-free)_settings_and_load_them_on_Startup. I should do

sudo nvidia-settings

but got a faultindication. This time I executed

sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf

despite faultindication. And finally I added the line

exec nvidia-settings --load-config-only into the file ~.xinitrc

Afterwards reboot - and everything is fine.

The problem is solved.

 


#7

Fabelhaft. Endlich jemand der die Handbücher liest. Gratuliere.

Great. Finally somebody who reads the manuals. Congratulations.


#8

Nachklapp zu dem bisher Geschriebenen:
Da ich auf meinem Desktop drei Manjaro-Betriebssysteme habe, hatte ich zwei weitere Male das Vergnügen, den unfreien Treiber zu installieren. Es funktionierte nie ohne Probleme. Aus einem nicht beschreibbaren Gefühl heraus habe ich die Installation gemacht, zwei oder dreimal gebootet in das Schwarze hinein und erst dann via chroot das System geupdatet. Und danach erst “kam ich rein”. Und ich weiß immer noch nicht wirklich, ob das ein glücklicher Zufall war. Solange es nicht klappte, hatte ich das Gefühl, im Nebel zu stochern.

Appendix to what I wrote yesterday:
I installed three Manjaro-OS on my desktop-computer. So it was two times a pleasure to me to install the unfree driver. It never worked without problems. I had a emotion I cannot describe that it would be better to first install the driver and the update the system. So each time I rebootet into the black two or three times. Afterwards I updatet via chroot, and the “I got in”. Until now I do not know if it was a kind of luck. As long as I had no success I felt like being in the fog.


closed #9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.