NetworkManager Static ipv4 Manjaro-arm with kde


#1

hi there, I have manjaro-arm with kde in my rpi3

 saeb-pi  ~  screenfetch 
                             saeb@saeb-pi
                             OS: manjaro-arm 
                             Kernel: aarch64 Linux 4.19.1-2-MANJARO-ARM
         #####               Uptime: 18m
        #######              Packages: Unknown
        ##O#O##              Shell: fish 2.7.1
        #######              CPU: 4x Unkown
      ###########            GPU: DRM
     #############           RAM: 541MiB / 904MiB
    ###############         
    ################        
   #################        
 #####################      
 #####################      
   #################        
                            
                            
                            
 saeb-pi  ~  cat /etc/os-release 
NAME="Manjaro-ARM"
ID=manjaro-arm
PRETTY_NAME="Manjaro ARM"
ANSI_COLOR="1;32"
HOME_URL="http://www.manjaro-arm.org/"
SUPPORT_URL="https://forum.manjaro.org/c/manjaro-arm/"

 saeb-pi  ~  

I want make my wired connection has static ip

[root@saeb-pi saeb]# cat /etc/NetworkManager/system-connections/Wired\ connection\ 1.nmconnection 
[connection]
id=Wired connection 1
uuid=34d29bb9-ef51-3417-9128-82b6ed86531a
type=ethernet
autoconnect-priority=-100
permissions=

[ethernet]
duplex=half
mac-address=B8:27:EB:2A:2F:3F
mac-address-blacklist=
speed=100

[ipv4]
address1=192.168.1.13/24,192.168.1.1
dns=4.2.2.4;
dns-search=
method=manual

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
method=auto

but still I get automatic ip

[root@saeb-pi saeb]# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether b8:27:eb:2a:2f:3f brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global dynamic eth0
       valid_lft 85118sec preferred_lft 85118sec
    inet6 fe80::ba27:ebff:fe2a:2f3f/64 scope link 
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 0a:07:26:52:ae:20 brd ff:ff:ff:ff:ff:ff
4: wlan1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 7c:dd:90:37:d2:99 brd ff:ff:ff:ff:ff:ff
    inet 192.168.10.102/24 brd 192.168.10.255 scope global dynamic noprefixroute wlan1
       valid_lft 85133sec preferred_lft 85133sec
    inet6 2a01:5ec0:5025:d5f0:fb88:c237:8213:ff57/64 scope global mngtmpaddr noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 2a01:5ec0:5025:d5f0:cd39:d0b8:8c88:78bd/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::9d45:4a3f:57b5:9a33/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::fe0f:eba7:1e10:9572/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
[root@saeb-pi saeb]# 

#2

Check which connection NM uses. After you changed the config restart NM. Do not edit connection files with a text editor.

nmcli --fields DEVICE,CONNECTION,CON-UUID device status

Your connection settings are not wrong, but you should use a higher “autoconnect-priority”. Maybe something around 50.

You should definitv change this settings. Better remove both and use “auto-negotiate=true”.
But do not edit the config files. Use either the GUI, nmtui or nmcli