NetworkManager GUI Icon missing in Manjaro KDE

So after booting up my computer this morning, I had no internet connection and the NetworkManager GUI in the system tray was gone. I managed to get the wired connection to work, but I can't seem to find out why the NetworkManager Icon in the tray is gone. My Wi-Fi is still not working and without the GUI I don't know how to set-up my VPN connection.

So do any one of you know how I can get it back running? I have tried installing and reinstalling different kernels and restarting the network services as well as rebooting the computer.

Thanks.

Right-click an empty spot of the System Tray and choose Configure System Tray from the popup menu. If the icon is in there, it will be listed, but it may be set to not show ─ look at the checkbox in the "General" section ─ and/or it may be set to "auto" or "hidden" in the "Entries" section, in which case you may want to change that to "shown".

Hope this helps. :wink:

Also check plasma-nm is installed, it should be :smiley:

1 Like

That was the problem. Don't know how it got removed.

Thank you both for your help.