Networked Canon MX922 wont show up in Printers



I was always able to add this printer on ubuntu-based oses by Printers just finding it over the wifi, but then i installed Manjaro Gnome and it wont come up. I have tried to search by ip address, restarting printer and router and laptop multiple times, and re-adding it on my mom’s ubuntu gnome system to see if it still worked. I was hoping updates would fix whatever is wrong but it has been about six months now. I can add the printer fine over usb.
The picture shows where the printer should be showing up so i can add it.


Here is an old thread with information that may help you.


alright, i got it thanks! i had the gutenprint package installed, so i installed the foomatic one and was able to find the printer by the ip address.


I can only add it as an LPD printer from the ip address. I did some more searching and it seems snmp is not communicating correctly, snmpwalk timed out with no response. I am confused because this apparently worked fine on ubuntu, and obviously, I would prefer an snmp connection.


So can someone give me some info? is snmp or cups or something just not set up the same way as default in ubuntu? What do i have to do?


alright I figured it out - it all had to do with Avahi.
I narrowed it down with the help of a friend, and after reading through the avahi archwiki page, I found that I already had Avahi and nss-mdns installed, so all i had to do was enable the service and I was good to go:
“systemctl enable avahi-daemon.service”


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.