Network vanished after reboot of new installation

Just installed latest Manjaro via a USB stick on a brand new machine. All went smoothly with possible partitioning setup which I have not yet addressed. This is my third installation of Manjaro on various machines and I’ve been running it as my main desktop for a couple of years or so.

I spent some time setting up the desktop etc, connected via Remmina to a newly installed vino, and proceded to install and remove various apps. I always remove bluetooth, hexchat and pidgin. I’ve never had a need for them. This time I also removed bluez. After a while I rebooted the machine.

All seemed well until I tried to connect with Remmina, when it became obvious there was no connection to the new machine. There was no interface at all, not even a dhcp one. Just a blank panel through which I tried to add a new connection; and failed.

I’m guesing that the removal of bluez may be the cause, although for every warning it gave only “optional”.

a) Is this a reasonable diagnosis; b) if so, how can I get it back without an internet connection; c) if so, could bluez come with a better warning.

Please, check your log files with what command and syntax you removed bluez (if you don’t remember).

I removed it through the pamac gui.

I don’t say that this was the wrong way. Personally, I remove packages only using pacman, i.e.

sudo pacman -R {package}


sudo pacman -Rs {package}

to remove dependent and orphaned packages.

pamac works a bit different and you could end up easily in a recursive removal of packages that depend on the package which you want to remove, depending on your settings. Always check the list of packages to be removed before execution.

There were about half a dozen notifications all saying bluez was OPTIONALLY used by this/that. What I want to know is: is bluez NECESSARY for the internet connection and/or could it be the reason for the connection going missing.

And if so, what do I need to copy from the installation usb to make it right; or should I just cut my losses and reinstall from scratch?

Please post the output of inxi -Fazy.

  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=6da9bbf6-c496-45cd-8bfe-f189370b2f9e rw quiet apparmor=1 
  security=apparmor resume=UUID=6b5358f6-061a-4a11-bab5-479aa944d947 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop System: Gigabyte product: B450M DS3H v: N/A serial: <filter> 
  Mobo: Gigabyte model: B450M DS3H-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F50 date: 11/27/2019 
  Info: Quad Core model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 
  type: MCP arch: Zen+ family: 17 (23) model-id: 18 (24) stepping: 1 
  microcode: 8108109 L2 cache: 2048 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 28759 
  Speed: 1258 MHz min/max: 1400/3600 MHz boost: enabled Core speeds (MHz): 
  1: 1260 2: 1282 3: 1259 4: 1260 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Picasso driver: amdgpu v: kernel bus ID: 07:00.0 
  chip ID: 1002:15d8 
  Display: x11 server: X.Org 1.20.10 driver: amdgpu,ati unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1280x1024 s-dpi: 96 s-size: 338x270mm (13.3x10.6") 
  s-diag: 433mm (17") 
  Monitor-1: HDMI-A-0 res: 1280x1024 hz: 60 dpi: 96 
  size: 338x270mm (13.3x10.6") diag: 433mm (17") 
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.39.0 
  5.9.11-3-MANJARO LLVM 11.0.0) 
  v: 4.6 Mesa 20.2.3 direct render: Yes 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
  v: kernel bus ID: 07:00.1 chip ID: 1002:15de 
  Device-2: AMD Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel 
  v: kernel bus ID: 07:00.6 chip ID: 1022:15e3 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee 
  v: kernel port: e000 bus ID: 03:00.0 chip ID: 10ec:818b 
  IF: wlo1 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus ID: 04:00.0 
  chip ID: 10ec:8168 
  IF: enp4s0 state: down mac: <filter> 
  Local Storage: total: 1.15 TiB used: 7.85 GiB (0.7%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 238.47 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 32B3T8EA scheme: GPT 
  ID-2: /dev/sda vendor: Seagate model: ST1000DM010-2EP102 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC43 
  ID-3: /dev/sdb type: USB model: USB DISK 2.0 size: 7.47 GiB block size: 
  physical: 512 B logical: 512 B serial: <filter> rev: PMAP scheme: MBR 
  ID-1: / raw size: 229.37 GiB size: 224.77 GiB (97.99%) used: 7.84 GiB (3.5%) 
  fs: ext4 dev: /dev/nvme0n1p2 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 8.80 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 
  System Temperatures: cpu: 39.5 C mobo: N/A gpu: amdgpu temp: 39.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 194 Uptime: 11m Memory: 13.67 GiB used: 628.0 MiB (4.5%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1155 lib: 351 
  Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.08

It seems two network interfaces are detected, although both are down. Which one is that did work during installation but it doesn’t work now: the wired or the wireless one?

There was only one registered - wired.

First of all I would recommend you to upate using

sudo pacman-mirrors -f && sudo pacman -Syyu

Afterwards, reboot.

What network tools did you use, NetworkManager or something else?

Would be nice if you could share output of:

nmcli device
nmcli connection
ip link
systemctl status NetworkManager.service

A little bit awkward. There is no internet connection, not even a local one.

The day after the last reply here I reinstalled Manjaro on the new machine. Again I removed hexchat, pidgin and bluetooth but this time I left bluez installed. So far all is well.

I have long believed that bluetooth should be completely seperated from all other libs and, for preference, not installed in the first place. For those who do use bluetooth (about 40% internationally but what percentage of Manjaro?), a simple question during installation should suffice. Just a thought.