Network issue. Can't access to some websites

Hello Community,
just installed couple of days ago the latest manjaro with deepin. Everything seems to work fine except loading of several internet sites.

(I didn’t find the answers in this forum and nore in the manjaro wiki)

for example:
addons-mozilla-org
but at the same time official mozilla site works fine, which i forbidden to include here

in google i did find this topic some times. one of the results was behind the link
which i forbidden to include here - but it doesn’t load.

I wondered if it a browser issue, installed chromium - the same result.

the error page message text is:
"
Hmm. We’re having trouble finding that site.

We can’t connect to the server at ### links including is forbidden here ###

If that address is correct, here are three other things you can try:

Try again later.
Check your network connection.
If you are connected but behind a firewall, check that Firefox has permission to access the Web.

"
github

  • doesn’t load

with big sites like google-com, youtube-com, facebook-com - is no problem.

Interesting was also, that last week I was installing an lubuntu on another pc, and it had the same issue.
I wandered, if it closed by the router, but with my phone I am in the same network, and from my android device I can load all this pages.

What need I to do?

ps. kid a strange, when I cannot put links in my post…

Hi @me_em, and welcome!

That is because you are a new user and not the required trust level yet.

To post links, wrap them in single backticks (`). That will make them better displayed and worked with.

`www.startpage.com`

will be displayed as,

www.startpage.com

which makes it easier to work with.

Then, what you’re describing sounds like some kind of DNS error. I know the Androids bandwidth saving feature makes it use some Google server as a proxy, so Chrome isn’t a reliable test for this kind of thing.

Do you have any other device, that’s not an Android you can use to test? Alternatively, and I don’t know how effective this is, you can try turning the bandwidth saving feature off
on Android. No, sorry, I can’t remember right now where to find it.