Network failed to connect after restarting

Hi guys, after rebooting I get a message that the network could not connect. If I turn off the wifi and turn it on again, it works.

Is there any way to fix this problem?

here’s the output of the inxi -Fxxa command

System:    Host: lachiweb Kernel: 5.14.10-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64
           root=UUID=e202b061-39cd-4efa-ac94-1207f1a89b40 rw quiet splash apparmor=1
           security=apparmor resume=UUID=faf55b60-f509-460c-bfd9-e58d06de2bcf udev.log_priority=3
           Desktop: GNOME 40.5 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 Distro: Manjaro Linux
           base: Arch Linux
Machine:   Type: Laptop System: Hewlett-Packard product: HP EliteBook 8570w v: A1029D110C
           serial: <superuser required> Chassis: type: 10 serial: <superuser required>
           Mobo: Hewlett-Packard model: 176B v: KBC Version 50.1F serial: <superuser required>
           UEFI: Hewlett-Packard v: 68IAV Ver. F.71 date: 04/19/2019
Battery:   ID-1: BAT0 charge: 39.8 Wh (100.0%) condition: 39.8/39.8 Wh (100.0%) volts: 16.5
           min: 14.8 model: Hewlett-Packard Primary type: Li-ion serial: 00000 2017/07/27
           status: Full
CPU:       Info: Quad Core model: Intel Core i7-3630QM bits: 64 type: MT MCP arch: Ivy Bridge
           family: 6 model-id: 3A (58) stepping: 9 microcode: 21 cache: L2: 6 MiB
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 38324
           Speed: 1197 MHz min/max: 1200/3400 MHz Core speeds (MHz): 1: 1197 2: 1739 3: 1237
           4: 1200 5: 2942 6: 2009 7: 1316 8: 1197
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP:
           conditional, RSB filling
           Type: srbds status: Vulnerable: No microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GK107GLM [Quadro K1000M] vendor: Hewlett-Packard driver: nvidia
           v: 390.144 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:0ffc
           class-ID: 0300
           Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo
           bus-ID: 1-1.2:4 chip-ID: 046d:082d class-ID: 0102 serial: CAF982EF
           Device-3: Primax HP HD Webcam [Fixed] type: USB driver: uvcvideo bus-ID: 1-1.3:5
           chip-ID: 0461:4dfe class-ID: 0e02 serial: PMX02
           Display: x11 server: 1.20.13 compositor: gnome-shell driver: loaded: nvidia
           resolution: <missing: xdpyinfo>
           OpenGL: renderer: Quadro K1000M/PCIe/SSE2 v: 4.6.0 NVIDIA 390.144 direct render: Yes
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard
           driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
           Device-2: NVIDIA GK107 HDMI Audio vendor: Hewlett-Packard driver: snd_hda_intel
           v: kernel bus-ID: 01:00.1 chip-ID: 10de:0e1b class-ID: 0403
           Device-3: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo
           bus-ID: 1-1.2:4 chip-ID: 046d:082d class-ID: 0102 serial: CAF982EF
           Sound Server-1: ALSA v: k5.14.10-1-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.38 running: no
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard driver: e1000e
           v: kernel port: 5040 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
           IF: enp0s25 state: down mac: d4:c9:ef:52:f7:64
           Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi v: kernel bus-ID: 25:00.0
           chip-ID: 8086:422b class-ID: 0280
           IF: wlo1 state: up mac: 3c:a9:f4:3c:f3:20
Bluetooth: Device-1: Broadcom HP Portable SoftSailing type: USB driver: btusb v: 0.8
           bus-ID: 2-1.6:3 chip-ID: 0a5c:21e1 class-ID: fe01 serial: 1C3E84FCF6FA
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
Drives:    Local Storage: total: 238.47 GiB used: 14.83 GiB (6.2%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/sda maj-min: 8:0 vendor: Micron model: MTFDDAK256MBF-1AN15ABHA
           size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
           serial: 153610833F99 rev: M6T3 scheme: GPT
Partition: ID-1: / raw-size: 73.24 GiB size: 71.54 GiB (97.68%) used: 11.33 GiB (15.8%) fs: ext4
           dev: /dev/sda2 maj-min: 8:2
           ID-2: /boot/efi raw-size: 513 MiB size: 512 MiB (99.80%) used: 288 KiB (0.1%) fs: vfat
           dev: /dev/sda1 maj-min: 8:1
           ID-3: /home raw-size: 24.01 GiB size: 23.47 GiB (97.73%) used: 3.5 GiB (14.9%) fs: ext4
           dev: /dev/sda4 maj-min: 8:4
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
           ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3
           maj-min: 8:3
Sensors:   System Temperatures: cpu: 66.0 C mobo: 62.0 C gpu: nvidia temp: 61 C
           Fan Speeds (RPM): N/A
Info:      Processes: 251 Uptime: 11m wakeups: 2 Memory: 7.7 GiB used: 2 GiB (26.0%) Init: systemd
           v: 249 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1214 lib: 308
           flatpak: 0 Shell: Zsh v: 5.8 running-in: kitty inxi: 3.3.08

You can try some different kernels for one.

You can also try some options for the iwlwifi module:

printf 'options iwlwifi 11n_disable=8 swcrypto=1' | sudo tee -a /etc/modprobe.d/iwlwifi.conf > /dev/null

And the same for its powersaving module:

printf 'options iwlmvm power_scheme=1' | sudo tee -a /etc/modprobe.d/iwlmvm.conf > /dev/null

(you can remove the files to revert the changes)

1 Like

Will do