Network Connects, but has an upload of 0 and download of 0. Can't fix

Hey All,

I just installed Manjaro yesterday. I am loving the system. I had a lot of problems setting stuff up, but figured out almost everything. My only remaining problem is my network. When I reboot my computer it connects to the Wifi network right away, however, my connection upload and download B/s fluctuate between 0 and 1000. They mostly just stay at 0 B/s. I am currently on Linux515, I downgraded to linux510 to see if that helped. It didn’t.

I followed a NetworkManager guide: (I added spaces because I can’t provide links apparently)
linuxhint. com / arch_linux_network_manager

I followed this guys suggestions:
https:// org/t/solved-internet-connectivity-issues/70146/2

None of that worked. So I am curious if anyone has any thoughts while I try to troubleshoot this. I want to use Manjaro, but if I can’t solve this network problem then I can’t use it.

It is definitely a Manjaro problem as when I switch to my Windows 10 partition the wifi is fine and also my MacBook sitting right next to my computer has perfectly fine internet and they are both connected to the same wifi network.

Here is system info:

inxi -Nxxxa                                                                                         
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  Device-2: Ralink MT7610U (Archer T2U 2.4G+5G WLAN Adapter type: USB
    driver: mt76x0u bus-ID: 1-9:5 chip-ID: 148f:761a class-ID: 0000 serial: 1.0

inxi -Fazy                                                                                   ✔  31s  
  Kernel: 5.15.28-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=883544ae-4caa-4007-bd04-ab6172e8d40c rw nvidia-drm.modeset=1
    quiet apparmor=1 security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 wm: kwin_wayland vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: MSI product: MS-7A71 v: 1.0
    serial: <superuser required>
  Mobo: MSI model: Z270-A PRO (MS-7A71) v: 1.0 serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: 1.30 date: 06/28/2017
  Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: Discharging
  Info: model: Intel Core i5-7600K bits: 64 type: MCP arch: Kaby Lake
    family: 6 model-id: 0x9E (158) stepping: 9 microcode: 0xEC
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1397 high: 1900 min/max: 800/4200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 1900 2: 1792 3: 1098
    4: 800 bogomips: 30409
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort mitigation: TSX disabled
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Gigabyte driver: nvidia
    v: 510.54 alternate: nouveau,nvidia_drm pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: none off: DVI-D-1,HDMI-A-1 empty: DP-1 bus-ID: 01:00.0
    chip-ID: 10de:1c82 class-ID: 0300
  Display: wayland server: v: with: Xwayland v: 22.1.0
    compositor: kwin_wayland driver: X: loaded: nvidia gpu: nvidia
    d-rect: 3840x1080 display-ID: 0
  Monitor-1: DVI-D-1 pos: primary,left res: 1920x1080 size: N/A
  Monitor-2: HDMI-A-1 pos: right res: 1920x1080 size: N/A
  OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.54 direct render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a2f0
    class-ID: 0403
  Device-2: NVIDIA GP107GL High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.28-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.20 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.48 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: down mac: <filter>
  Device-2: Ralink MT7610U (Archer T2U 2.4G+5G WLAN Adapter type: USB
    driver: mt76x0u bus-ID: 1-9:5 chip-ID: 148f:761a class-ID: 0000
    serial: <filter>
  IF: wlp0s20f0u9 state: up mac: <filter>
  Local Storage: total: 1.82 TiB used: 58.43 GiB (3.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Hitachi model: HDS722020ALA330
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: B37B scheme: GPT
  ID-1: / raw-size: 91.7 GiB size: 89.7 GiB (97.82%) used: 23.33 GiB (26.0%)
    fs: ext4 dev: /dev/sda6 maj-min: 8:6
  Alert: No swap data was found.
  System Temperatures: cpu: 29.8 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
  Processes: 243 Uptime: 5m wakeups: 2 Memory: 15.59 GiB
  used: 2.24 GiB (14.3%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1226 lib: 327 flatpak: 0
  Shell: Zsh v: 5.8.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13

I have also installed rtl88xxau-aircrack-dkms-git using pamac as a driver for the Archer T2U. (saw it on another forum post I don’t have the link though)
Though I don’t know if it is working or not as when I do lsmod I do not see 8821au. if I do grep 88 then I get an intel_uncore which isn’t important for this. I am not that experienced with AUR so I might have not installed it correctly even though there were no errors when installing and also I downloaded the headers for it.

Hi @TheFreaknPope ,
Welcome to the forum, could you please read the following post:
Looking for a driver for my wireless adapter - #2 by visone

Maybe, you could solve the problem.


Hey @j8a ,

Thanks for the post. I went to the bottom and built the package that he had /archive/Packages/mt7610u-src.tar.gz particularly by extracting the contents and then navigating to the t2u-pkgbuild folder that had the PKGBUILD file in it. It seemed to go successfully. I then updated everything with yay and pacman and I rebooted the system and my B/s are still 0.

I also downloaded this using pamac. Might be screwing stuff up?

 pamac list | grep 'mt76'                                           0|1 ✘ 
mt7610u_wifi_sta-git               16911de-1                   AUR        2.6 MB

Let me know if you have any other thoughts or if there was something else I needed to do?

I removed the mt7610u_wifi_sta-git package that I installed using pamac still didn’t fix the problem.

I am curious how I can find the particular package that I just installed using makepkg -sri I’m checking against pacman -Ql <folder name> and I don’t see it.

Hi @TheFreaknPope ,
Maybe, you have to install the extra/dkms or the extra/nvidia-dkms 510.54-1 from the pamac gui interface.
I really do not know.