Network can connect locally, but not to external locations

dual-boot
i3

#1

This is a continuation of my last post, in which I explain how I broke my installation and some people and I start to work out a solution (Mostly them, I just followed instructions)

I’ve been watching some videos on i3 so I decided to give it a try. I have a laptop with 2 SSD, one of 250GB which came with Windows 10 and another of 500GB. I originally had it with Manjaro GNOME on 250 GB and another partition of 250GB for storage, though I didn’t use it that much. That’s why I thought it would be perfect to repurpose it for a brand new Manjaro i3wm.
I installed it, but after restarting my laptop, and trying to access Manjaro i3, I was greeted by [this error message]
More in Broke my Manjaro installation... again

The next day, however, I woke up to a new problem

Ok, something big happened. Before I could try any of your suggestions, I can no longer access the terminal. This is what I’m greeted with now.
More at Broke my Manjaro installation... again in post #10

With help of the people that answered me, we managed to solve some of the issues we had, but when trying to follow @gohlip’s advice, @tbg realized the title, I can connect locally, but not to external locations

@gohlip’s advice

Okay, noted. Now that looks like another issue.
You’ve got your grub, it tries to boot. Good.
Okay, now try to boot to fallback (since the error is not loading modules). At grub menu, select that not the default entry.
And put in a ‘3’ (no appostrophes just 3) at the linux line.
Boot to prompt. Let us know if it can boot to prompt.
If it boots to prompt, login with passwaord, do (as root, sudo)
…pacman -Syyuu
…mkinitcpio -P
Let ius know if that boots to prompt (my job is done here) and let us know if the commands work to boot normally (else others will have to come in to help).
More at Broke my Manjaro installation... again in post #31

I’m currently stuck at this step, and as @tbg said:

If localhost is working than the problem is your configuration, not your network adapter.

You should really open a separate support thread for your networking issue, as this was not the subject of this thread.

So here we are.


TL:DR
Worked from a previous problem to here, I’m trying to pacman -Syyuu but I can’t conncect to the repos.

This is the output of some commands that may be useful

[bower ~]# ping -c3 google.com
ping: google.com: Name or service not know
[bower ~]# ping -c3 localhost
PING localhost(localhost (::1)) 56 data bytes
64 from localhost (::1): icmp_seq=1 ttl=64 time=0.028 ms
64 from localhost (::1): icmp_seq=2 ttl=64 time=0.062 ms
64 from localhost (::1): icmp_seq=3 ttl=64 time=0.144 ms

--- localhost ping statistics ---
3 packets transmitted, 3 recieved, 0% packet loss, time 6ms
rtt min/avg/max/mdev = 0.028/0.078/0.144/0.048 ms

Broke my Manjaro installation... again
#2

just not sure at all about that as localhost don’t use any network hardware interface. :thinking:


#3

What is the output of

ping -c3 8.8.8.8


#4

Maybe start with some basic network info’s

inxi -Nnxz
ip addr s
ip route s
ip -6 route s
cat /etc/resolv.conf

Which software do you use to create a network connection? If you use the NetworkManager, maybe show us

sudo journalctl --no-pager -b -u NetworkManager

#5

I have no idea, to be honest.


It’s the same output, we also tried it in the last thread, to be precise in Broke my Manjaro installation... again, post #45


I’m sorry, I dont know which software I used to create network connection, but it was GNOME’s default in Manjaro GNOME, as I changed nothing of that.
I’m going to try and run the other commands for now.

The output is here. Sorry for the image, I have no other way to get the text out of it.


#6

Looks like your system has only a wifi device, no ethernet. Your wifi device is not up and not connected to a wifi network.

You need to connect to a wifi network to access the internet or any other network.


#7

How do I do that from the command line though? (I not well versed in bash or Linux)
I have internet in my other partition, if that tells you anything


#8

You need to type out your network info for your wifi and post it. I am not at home and only have use of my phone. I cannot read pics of your outputs on a small phone phone screen.


#9

Try to start the NetworkManager (NM). By default the Gnome Edition uses NM and the i3 community edition also uses NM.

sudo systemctl start NetworkManager.service

If you don’t get an error, you can try to ping google. If you get an error, look in your journal.

sudo journalctl -b -u NetworkManager

Normally NM starts by default. But your journal output suggest that NM is not starting at boot or was removed.
If you removed NM, then you can try systemd-networkd with wpa_supplicant. But it is not easy. And since NM might be missing, wpa_supplicant also might be not on your system.

If you really want to fix this system without a live system, you would need a USB to Ethernet adapter.

A better choice would be to boot a Manjaro live system, connect to a network and then chroot.

Another alternative would be a reinstall. But you don’t learn much about your system and how to fix it.


#10

I used sudo systemctl start NetworkManager, and although it doesn’t give me an error, I didn’t know what to do (I did run ping-c3 google.com and with 8.8.8.8, but both failed)
In sudo journalctl -b -u NetworkManager, it says that it starts at 2019-01-02, ends at 2019-02-13, but had no entries.

I’m going to try your other suggestion, chrooting to fix it. I just have to learn how


#11

Ok, update, I’ve followed this guide from the manjaro wiki:
https://wiki.manjaro.org/index.php/Restore_the_GRUB_Bootloader#Chroot_into_your_existing_Manjaro_Installation (The relevant part is further down this post)
and followed this instructions to chroot:


Manually Identify and Prepare the Installed Partition(s)

1. Ensure that you are using the Root account, which is identified by a hash (’#’) at the beginning of the command line, rather than a dollar (’$’). To switch to Root, enter the command:

sudo su

2. List your partitions. This is necessary in order to identify the partition your Manjaro system is installed on. If you have used a separate boot partition, it will be necessary to identify this as well. For a list of your paritions, enter the command:

lsblk -f

or

sudo blkid -o list -c /dev/nul

In this particular instance, having used the assisted preparation method to install Manjaro earlier , the partitions for the author’s Manjaro system are as follows:

  • /dev/sda1 : Boot partition
  • /dev/sda2 : Swap partition
  • /dev/sda3 : Manjaro system
  • /dev/sda4 : Space for personal files.

If you are still unsure, then you can also use an application called gparted , which should be in Menu > System > GPartEd. This will provide a simple visual illustration of the partitions on your hard drive(s). If a separate partition for the GRUB exists, it will be marked as ‘bootable’, and should only be about 100MB in size.

3. Mount your Manjaro system partition. The syntax to mount the Manjaro system partition is:

mount /dev/ **[partition used for Manjaro system]** /mnt

In this instance, as the Manjaro system partition is /dev/sda3 , this will be mounted using the following command:

mount /dev/ **sda3** /mnt

IF you have used a separate partition for your GRUB bootloader, then this must also be mounted. The syntax to mount a separate partition used to boot is:

mount /dev/ **[partition used for GRUB]** /mnt/boot

In this instance, a separate partition – /dev/sda1 – has been used for the GRUB, and will be mounted using the following command:

mount /dev/ **sda1** /mnt/boot

note: Again, if you have not used a separate boot partition, then it (obviously) does not need to be mounted!

4. Change to the root directory of your mounted partitions.

cd /mnt

This is undertaken so that you are working from --and with-- your installed system, rather than the installation media. To do so, it will be necessary to enter a series of commands in the following order:

mount -t proc proc /mnt/proc mount -t sysfs sys /mnt/sys mount -o bind /dev /mnt/dev mount -t devpts pts /mnt/dev/pts/ chroot /mnt


The problem I find myself into is that, after doing all of this, I’m still in manjaro-i3 and not in GNOME, my end goal.

Output:

[manjaro@manjaro-i3 ~]$ sudo blkid -o list -c /dev/null
device              fs_type   label      mount point             UUID
------------------------------------------------------------------------------------------------------
/dev/nvme0n1                             (not mounted)           
/dev/nvme0n1p1      vfat      ESP        (not mounted)           1A8F-0CDD
/dev/nvme0n1p2                           (not mounted)           
/dev/nvme0n1p3      ntfs      OS         (not mounted)           A4948F9C948F701A
/dev/nvme0n1p4      ntfs                 (not mounted)           608AB0278AAFF7A4
/dev/nvme0n1p5      ntfs      WinRE      (not mounted)           1E1E915D1E912EB1
/dev/loop0          squashfs             /run/miso/sfs/livefs    
/dev/loop1          squashfs             /run/miso/sfs/mhwdfs    
/dev/loop2          squashfs             /run/miso/sfs/desktopfs 
/dev/loop3          squashfs             /run/miso/sfs/rootfs    
/dev/sda2           ext4                 (not mounted)           d8f6568e-3528-4e69-aa40-193ba5ce9e08
/dev/sda4           vfat                 (not mounted)           F5D8-7A8F
/dev/sdb1           iso9660   MJRO180    /run/miso/bootmnt       2018-11-24-14-22-05-00
/dev/sdb2           vfat      MISO_EFI   (not mounted)           A28E-A0A1
[manjaro@manjaro-i3 ~]$ sudo mount /dev/sda2 /mnt
[manjaro@manjaro-i3 ~]$ sudo mount -t sysfs sys /mnt/sys
[manjaro@manjaro-i3 ~]$ sudo mount -o bind /dev /mnt/dev
[manjaro@manjaro-i3 ~]$ sudo mount -t devpts pts /mnt/dev/pts/
[manjaro@manjaro-i3 ~]$ sudo chroot /mnt
[manjaro-i3 /]# 

I can still see in Nautilus that my files from GNOME are still accessible, so why cant I chroot to the system?


#12

As you can see in your output, you successfully chroot into your install at /dev/sda2

What do you expect to see. From there you need to fix your system.

Maybe you should simply reinstall Gnome.


#13

Well, if you see, it says [manjaro-i3 /]#.

But the partition I’m trying to get to was supposed to be a GNOME one, on sda2
I can even access the files and see that sda2 is where I had all the files I had in my GNOME session, but when I access it, it suddenly appears as if it was a manjaro i3 one. Is this correct, am I chrooted to an i3 distro, or is it just a resemblance of the specific distro right now?

I got into this problem after trying to install manjaro i3 along with my regular manjaro gnome installation. They both broke, and we didn’t know how it happened.

After tinkering around in the last post, we finally fixed something and got rid of the manjaro i3 I had installed and started working with the manjaro gnome installation that was broken. However, when I chroot into sda2, where I originally had gnome installed, I see it as i3.
Did we mess up earlier and deleted gnome? If so, how is it that I can still access the files? If not, how do I get to gnome then? What is going on?


#14

Well, this is just the hostname of this live system. Do you use a i3 iso?

I’m not sure if the default hostname changes after a chroot. I don’t think so,but I can’t test it right now.


#15

Yes, I am using an i3 iso. The same one I used to install the partition that created this mess in the first place. Seems proper that it is the one who solves the problem after making it


#16

You used a live system to install i3 over your Gnome install?


#17

Actually, it was supposed to be alongside, as a dual boot, but I ended messing something up and here I am


#18

Not sure if that can be fixed.

However, after you do the chroot, it is similar as if you started your system and landed on a terminal. But know you should have internet access if you connected to a wifi in that live system.

So you can now do what you wanted to do as you discovered that you don’t have internet access.


#19

Yeah, I actually did try the pacman -Syyuu, but it did nothing.

It seems like I’ll have to reinstall everything :frowning:


#20

It might be the best solution.