Network brother printer woes

so far i have managed to install my brother dcp-j4120dw as a usb device only.
what i have done so far is ensure cups is on.
i have rigorously followed every bit of advice.
manjaro printers config printers all installed
pinged the printer ip and yep its there.
i have tried ipp ipps http https but cannot find the printer either using localhost 631 or the add printer on the laptop. kde plasma.
i checked the filters that got installed with usb connection and there are only the lpdwrapper filters.
i have installed the latest driver from AUR.
just cant seem to find the printer at the IP.
new laptop has kernel 5.15. last time i installed i had 5.4. but new computer wont boot from 5.4.
has anyone had better luck building a package from the .deb package.
what am I missing.
at the mo i am stuck with a usb connection only.
the test page from the usb connectiongave me a pdd file name which i cant find. if someone else has succeeded in getting a brother printer recognised spill the beans pls. exactly what you typed in.

also tried modifying the usb printer to no succcess. it just cant find the printer on the network

I have no such printer - so my suggestions is close to generic - and I have no means of verifying.

From you initial topic you have build the available packages from AUR - keep them - they are required.

From the Brother support web page - download the source files for the printer driver.

Unpack the archive

tar -xzf brother_dcpj4120dw_GPL_source_3.0.1-1.tar.gz

Create the folder (it may already exist)

sudo mkdir -p /usr/share/ppd/Brother

Copy the ppd file from the archive

sudo cp brother_dcpj4120dw_GPL_source_3.0.1-1/ppd/*.ppd /usr/share/ppd/Brother

Check your user’s group membership - look for lp


Ensure the cups service is enabled and active

sudo systemctl enable --now cups

using CUPS webinterface

Open your cups web interface (if your user is not member of lp group - use your system root account and password when queried for permission)


Add printer
→ Option AppSocket/HP JetDirect
→ Connection string socket://{hostname|ip.x.y.z}:9100
→ Name your printer e.g. brother
→ Clock Browse… and navigate to the ppd file you copied to /usr/share/ppd/Brother
→ Save the printer


→ click the queuename e.g. brother
→ click Administration dropdown
→ configure printer defaults
→ ensure the media size matches your locale
→ save the configuration


→ in Maintenance select print testpage

If all is good your printer should print

using print-manager on Plasma

Open System Settings
→ Printers
→ Add Printer
→ AppSocket/HP JetDirect
→ ip.x.y.z port 9100
→ Brother
→ DCP-J4120DW

i reinstalled the entire system because i could even find cups in the end.
so i rebooted the printer and got a new ip address…now it is recognised in the add printers box…but i have entered the new ip address and there is a box called queue…what do you enter into that? because the internet seems not to know…
p.s. none of the other methods worked. because i suspect the printers link to the router was somehow not being picked up which turned out to be true.

also i am assuming the file from the brother site is the rpm file and not the deb file??

the web interface cant find the printer.
this is just plain weird.

print manager doesnt list the 4120

so finally got there.
rebooted printer and reconnected to the router.
got a different ip address in the reconnect.
downloaded the 3.0.1-3 driver as this installs the ppd to the right place. the xx-01 downloads didnt. also it installed the usb printer by default so i already had a functioning printer just not network
the localhost:631 selected the printer that was recognised administration modify printer
then as simple as ipp:// then when it asks for print driver I chose the ipp everywhere driver. not the cups that got installed from the driver package. bam

Remember - always assign a static ip address to devices which must be all times reachable.

Next time your network is rebooted - you will face a simlilar problem.

DHCP is not static - the D is for Dynamic - you can make it reserved for a given mac address - that must be done in the DH;CP server - in most home networks - the router.

Just in case the solution to my woes of Brother printer not found was the following
For some reason the root owned file /etc/mdns.allow was not present in my new KDE Manjaro 22.1 Talos installation and it needs
needs to have the following 2 lines
once created and rebooted the machine the printer finally started printing. I used the AUR printer driver , my printer is a MFC-J995DW .
Thanks to Linuxious with his forum entry CUPS: “Unable to Copy PPD file” (read till the very end) for providing the solution.

back here the 3.01-3 file because it no longer installs due to failing to build lib32-libstdc++5 668 someone has put a patch in this which doesnt work. in the interim i am manually connecting the usb or using the android app on my phone. i am considering also reinstalling elementary it works flawlessly there.