Network-8168 and network-8169 works really bad with my computer

So it is not working anymore? Did you change something in your system? Did you try to change the port you use on your router? Did you try another cable?

Already tried everything you mentioned. Still having problems. I just installed latest Manjaro stable update and firefox font rendering messed up.

I’m just curious to know how people are able to use Manjaro as daily driver. Am I just unlucky?

Definitely, or you’re doing something wrong. I basically have 0 issue since almost two years, besides this weirdness where I can’t set my DNS server in NetworkManager from some point in time.

For the font issue search the forum it has been discussed since multiple updates ago. Install ttf-dejavu and start following the update announcement threads to not miss valuable info, and make sure you’re also not forgetting to follow the new config files to merge or replace (.pacnew or .pacsave files, search forum for that).

Man, I don’t have time for all these things. I have a work and a family to follow. It’s probably better for me switching to Ubuntu LTS, hoping I don’t have the same network problems (but I really doubt).

There is no solution for now.

Manjaro is a rolling release distro so yes, you’ll have to take care of your system and at minimum read the update announcement, if it is too much for you I can’t help.

That’s something to take into consideration before installing the OS. Go with Debian even if you want nothing to change in your system forever.

Ok, I still have the same problem on Linux Mint and Ubuntu.

EDIT: oups wrong driver :slight_smile:

At absolutely no point in the thread WIFI or Bluetooth has been discussed.

I don’t know man, I use the same network chip, on similar board, with same kernel 5.8, with the r8168 driver installed from Manjaro Settings, with the parameters I told you, and it just works. For Linux Mint and Ubuntu you should now go to their respective forums to troubleshoot the issue.

There is definitely an issue as when I change NetworkManager from full auto to auto (only adresses) and set my DNS servers it stop being able to connect. But besides that everything works as expected.

Maybe this specific chip has an issue with current drivers and only thing we can do is report issues upstream, but without understanding why/what breaks it is difficult.

Something I notice is you do not have the latest BIOS, I do, but this Bios only update the AMD stuff, and fixes the vulnerability discovered this year in GRUB (careful, updating this BIOS and fixing the GRUB vulnerability may break you ability to boot and you’ll need to chroot your installation, I know I had to but lot of people didn’t), so maybe worth a try, you decide.

Grub 2.04-11.1

Fixes Boot-Hole issue.
You need to re-install grub on your system to complete the security fix: Bios-MBR , UEFI Systems

//EDIT: something I found, describing part of the issues with this chip Ubuntu Forums (FFS I had to create an account to read it, not cool)

TLDR; shutdown computer and unplug network cable for 15 seconds, then plug cable first then boot and see.

HOWTO FIX no link detected Realtek 8168/8169 cards

A number of users have been independently reporting an issue where they see no link detected and/or no link light on their Realtek 8168/8169-based wired ethernet cards when booting Ubuntu on a dual-boot Windows host. The card works in Windows but in Ubuntu it shows no link light and ethtool reports no link detected. (This can also affect you on initial installation of a single-boot system, but after running Windows on the host.)

Several users have now reported that this works for some Realtek 8139 cards as well.

(You can check if you have this type of card by typing the command lspci -nn and looking for your wired ethernet card in the list.)

Here is a fix for the most common causes.

First check that your ethernet cable is connected at boot. There is a known bug in the Ubuntu driver for this card that the cable must be connected to an active link at boot time for the card to work (…20/+bug/86798)

If your ethernet cable is connected at boot time and you are experiencing the no link problem, try this: Shutdown, power down. Unplug your host (this cuts power to the card if wake-on-lan power is maintained). Wait 15 seconds. Plug in. Boot ubuntu.

If that routine works, you are probably affected by the following (excerpt from gentoo wiki Note the second and third paragraphs. Then read the Windows-side workaround/solution in the first paragraph.

As of 27 May 2007, in kernel, you may experience the issues with the r8169 driver if you dual boot Windows on some systems. Windows by defaults disables the NIC at Windows shutdown time in order to disable Wake-On-Lan, and this NIC will remain disabled until the next time Windows turns it on. The r8169 driver in the kernel does not know how to turn the NIC on from this disabled state; therefore, the device will not respond, even if the driver loads and reports that the device is up. To work around this problem, simply enable the feature “Wake-on-lan after shutdown.” You can set this option through Windows’ device manager.

Edit: Problem with dual-booting with Windows exist also in and kernel, so it is safe to assume that it will concern all 2.6 kernels until the kernel developers update the drivers for RTL8168 to the version that will be able to turn on the NIC from disabled state. (Corey)

Second edit: Powering off and unplugging the machine for a few seconds (around 10 usually does it) seems to reset the card, so it will work in Linux again until you boot Windows again.

So read it all carefully maybe you’ll have your solution :wink:

I can relate my experience with this post, I initially noticed issue after rebooting from Windows 7 (see my self resolved thread linked earlier)

@omano @freed00m I have news about this issue.

I’m start believing is a dual-boot problem, I’ll show you why:
I have two SSD, the fist with Windows and the second one with Linux (no matter which distro for this issue, I have it with Manjaro, Linux Mint, etc.)
When I reboot from Windows internet doesn’t work on Linux (no matter which driver I have currently installed). If I SHUT DOWN Windows then internet will work flawlessly on Linux. The same problem goes when I reboot from Linux to go again on my Linux partition, for some weird reasons internet will not work in this occasion.

I have disabled Windows 10 hybernation (which causes thousands of problem with Linux, it seems) but the problem it’s still here. Although it seems not a problem related to Linux, but how my motherboard behaves with both operating system.


  • Disable fast boot from BIOS
  • Disable Windows 10 hibernation (CMD->right click->Run as administrator-> powercfg.exe /hibernate off
  • Disable Fast boot from control panel
  • Always shut down, never reboot.

This workaround is ass, I know, but at least I am able to work with both operating system without problems (for now).

I am genuinely curious if this problem persists without dual boot.

1 Like

Do you use the UTC time to BIOS in the windows installation?

Windows Registry Editor Version 5.00


It’s sad your motherboard vendor botched your motherboard.
Gigabyte grinds my gears as well. B450 is a relatively new chipset solution. I would check for firmware update more often. ( If Gigabyte cares. Often they don’t ).

Yeah, there’s 1 hour difference from Windows to Linux. Could this be the problem?

Well might be, the I’ve only seen a Intel’s UEFI bios source code and the implementation is very bad. I would expect simillar quality on AMD part.

I am thinking removing any friction could help. It probably wont help but worth the try if it’s only setting up one registry value :slight_smile:

Non UTC in a bios is a relic from a past that Microsoft still chose to do.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.