Network-8168 and network-8169 works really bad with my computer

Hello there, I have problems with my connection using Manjaro KDE. And it’s super annyoing.
I’m currently using network-8169 even though it keeps disconnecting every time I put my computer on sleep. When I boot up my computer I have to wait ~1 minutes before it connects correctly to my network. I tried using network-8168 but with no luck: boot time becomes extremely long (2 minutes) and sometimes my computer freezes repeatedly making it unusable.

[greenbarbers@alpha-linux ~]$ inxi -F
System:    Host: alpha-linux Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.19.5 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Gigabyte model: B450 AORUS M v: x.x serial: <superuser/root required> UEFI: American Megatrends 
           v: F50 date: 11/27/2019 
CPU:       Topology: Quad Core model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 type: MCP L2 cache: 2048 KiB 
           Speed: 2783 MHz min/max: 1400/3600 MHz Core speeds (MHz): 1: 2783 2: 1366 3: 2375 4: 1404 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Cape Verde XT [Radeon HD 7770/8760 / R7 250X] driver: radeon v: kernel 
           Display: x11 server: X.Org 1.20.9 driver: radeon FAILED: ati unloaded: modesetting resolution: 1920x1080 
           OpenGL: renderer: AMD VERDE (DRM 2.50.0 5.8.11-1-MANJARO LLVM 10.0.1) v: 4.5 Mesa 20.1.8 
Audio:     Device-1: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000 Series] driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.8.11-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: b4:2e:99:e0:0a:4e 
Drives:    Local Storage: total: 4.31 TiB used: 1.32 TiB (30.7%) 
           ID-1: /dev/sda vendor: Western Digital model: WD30EZRZ-00GXCB0 size: 2.73 TiB 
           ID-2: /dev/sdb vendor: Seagate model: ST1000LM048-2E7172 size: 931.51 GiB 
           ID-3: /dev/sdc vendor: Crucial model: CT480BX500SSD1 size: 447.13 GiB 
           ID-4: /dev/sdd vendor: Crucial model: CT256MX100SSD1 size: 238.47 GiB 
Partition: ID-1: / size: 438.82 GiB used: 23.96 GiB (5.5%) fs: ext4 dev: /dev/sdc2 
Swap:      Alert: No Swap data was found. 
Sensors:   System Temperatures: cpu: 43.2 C mobo: N/A gpu: radeon temp: 47 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 306 Uptime: 8m Memory: 15.64 GiB used: 2.05 GiB (13.1%) Shell: Bash inxi: 3.1.05

What about r8168 driver ? Could it work better?

Else you can try disabling Ipv6.

Also I use r8169 and I have troubles with connection with Wide 40Mhz channels. If you could modify your router settings to use only Full 20Mhz channel widths you might have a better chance. (Speaking only with my experience resulting from similar simptomps you have).

You can also proceed with pinpointing of the problem by trying kernel 5.9 or the older LTS if it has the same troubles.

No luck. I tried using r8168, disabling ipv6, even reset my modem router, but the problem is still there.

What drives me mad is that my moteherboard is widely used in the world, and manjaro (and linux in general) can’t figure out how to handle it. It’s like 1997 again.

Get your feelings man, for me it’s bluetooth problems like in early 00’s.

What about the logs, drop them here in a expandable Hide details so we can see, maybe it’s a comon issue.

When trying r8168 you should blacklist the r8169 module. It maybe automatically done but check /etc/modprobe.d/* for line blacklist r8169

Which logs? Could you post the procedure?

From systemd

$ journalctl -b > bootlog.txt

Then post the bootlog.txt here so we can see.

I knew friends and colleagues that had problems with these NICs on AM3 motherboards
over 10 years ago

Manjaro Settings Manager GUI works to get the correct kernel modules and headers installed, and blacklist the r8169 driver

this command should do the same

sudo mhwd --install pci network-r8168
1 Like

As I said before, I had no luck using r8168, my problem is still here.

bootlog is too long for posting here. You can download it here:

https://drive.google.com/file/d/19BRQ_BD602Y38eUgsGGpEn8yG1txgT9n/view?usp=sharing

Do you have a custom DNS? if so try to have full auto configuration for a test, reboot and see if it connects instantly on boot with the r8168 installed from the System Settings.

PS: I have similar hardware (B450M DS3H), and at some point the r8168 wasn’t installed anymore, not sure how/why, it took me time to figure that out, I reinstalled the driver from System Settings -> Hardware and rebooted, still same behavior, then I reset all configs in Network Manager, full auto, rebooted, works perfectly.

PS2: my auto solved thread Ethernet connection fails after reboot

PS3: reinstall from here so that it also does the necessary steps required to have this properly installed and functional

CLICK TO SEE

3 Likes

Ok, using default network option doesn’t put my system on hangs during boot, although I still have to wait ~1 minute before the connection is working.

Currently using network-r8168 and 5.4 kernel. I will tell you if I don’t have problem on resumes after sleep.

P.S connection seems to survive after on resume.

You can try to see if you have errors maybe?

journalctl -k -p err -b
journalctl -u NetworkManager.service -f

Can you share you Network Manager config for each tabs?
Did you install or reinstall the driver as I mentioned?

Currently at work, will post all the information after launch.

Yeah, I’ve installed it via GUI on Plasma settings. It automatically puts network-8169 in blacklist.

This is my log:

journal -k -p err -b: 
Riepilogo

– Logs begin at Fri 2020-10-09 21:18:39 CEST, end at Wed 2020-10-14 17:05:51 CEST. –
ott 14 17:03:05 alpha-linux kernel: pci 0000:00:00.2: AMD-Vi: Unable to read/write to IOMMU perf counter.
ott 14 17:03:06 alpha-linux kernel: kvm: disabled by bios
ott 14 17:03:06 alpha-linux kernel: kvm: disabled by bios
ott 14 17:03:06 alpha-linux kernel: kvm: disabled by bios
ott 14 17:03:06 alpha-linux kernel: kvm: disabled by bios

journalctl -u NetworkManager.service -f
Riepilogo
-- Logs begin at Fri 2020-10-09 21:18:39 CEST. --
ott 14 17:03:20 alpha-linux NetworkManager[512]: <info>  [1602687800.8265] manager: NetworkManager state is now CONN
ECTED_SITE
ott 14 17:03:20 alpha-linux NetworkManager[512]: <info>  [1602687800.8266] policy: set 'Nuova connessione 802-3-ethe
rnet' (eno1) as default for IPv4 routing and DNS
ott 14 17:03:20 alpha-linux NetworkManager[512]: <info>  [1602687800.8352] device (eno1): Activation: successful, de
vice activated.
ott 14 17:03:20 alpha-linux NetworkManager[512]: <info>  [1602687800.8635] audit: op="statistics" arg="refresh-rate-
ms" pid=1026 uid=1000 result="success"
ott 14 17:03:20 alpha-linux NetworkManager[512]: <info>  [1602687800.9087] manager: NetworkManager state is now CONN
ECTED_GLOBAL
ott 14 17:03:21 alpha-linux NetworkManager[512]: <info>  [1602687801.7853] audit: op="statistics" arg="refresh-rate-
ms" pid=1026 uid=1000 result="success"
ott 14 17:04:04 alpha-linux NetworkManager[512]: <warn>  [1602687844.3839] dhcp6 (eno1): request timed out
ott 14 17:04:04 alpha-linux NetworkManager[512]: <info>  [1602687844.3840] dhcp6 (eno1): state changed unknown -> ti
meout

Just booted my computer, it seems everything works fine.

Wait didn’t you reboot before? And now after a reboot everything is working perfectly no more issue whatsoever?

I don’t see any relevant error.

Yeah I already tried to reboot several times, although after installing network-r8168 and using defualt network settings everything seems to work just fine. I will tell you guys if there’s any other problems.

What really bothers me is the inability of using custom DNS.

Hum… OK… I just see your log file starts 5 days ago :rofl: but OK :slightly_smiling_face: I specifically wrote you needed to reboot for changes to properly take effect.

Yep, this is the only problem I don’t know why yet, for now I use the setting in Firefox to have custom DNS in web browser (General Settings -> scroll to bottom -> Network Settings -> scroll to bottom -> Enable DNS over HTTPS -> select CloudFlare or whatever).

Wait, is it possible Manjaro KDE doesn’t reboot properly? I’m currently dual booting with Windows 10.

Honestly I believe you didn’t reboot :joy: as the command I made you type specifically check the current boot log.

Dual booting should not affect your system in any way.

//EDIT: I marked my post as Solution, you can change or remove the Solution status all you want but for now it seems this was the solution.

1 Like

Sadly, it’s not the solution. This is what journalctl -u NetworkManager.service -f provides:

ott 21 12:06:30 alpha-linux NetworkManager[516]: <info>  [1603274790.1002] device (eno1): state change: ip-config -> failed (reason 'ip-config-unavailable', sys-iface-state: 'managed')