Net filter hangs boot


#1

I have a problem with booting in that it hangs at the starting cli net filter manager. I have a live usb to boot from but what exactly can I do to bypass this hang once I’m in the hard disk?


#2

need more info, that explanation does not describe much.
is this happening on an installed manjaro or on live usb?

on installed? then post following outputs

systemd-analyze blame
inxi -Fxxxz

if you cant boot your installed manjaro then boot the live usb and from terminal do this
manjaro-chroot -a
and then post requested info and please put 3 backtics ``` above and below each output so they are formatted properly, or you can hit the </> button and paste output.


#3

Thanks dgit. I was able to get in with the live usb and at least partially fixed something because I’ve rebooted into my HD. Yesterday, I was experimenting with iptables and the firewall, and probably screwed something up on the “services” end. Anyway, I’ve rebooted twice now because the first time I tried to activate the firewall and it crashed the system.
If you have any suggestions on what I should look for, don’t hesitate to let me know.
Thanks.


#4

along with:
journalctl -b0 -p4
cat /var/log/Xorg.0.log | grep -E "(EE)|\(WW)|\error|\failed|\Time"


#5

That is quite a bit to post. What is the more efficient way to post this stuff. It can’t be just copy/paste…what is the preferable way to do this?


#6
sudo pacman -S wgetpaste
journalctl -b0 -p4 | wgetpaste
cat /var/log/Xorg.0.log | grep -E "(EE)|\(WW)|\error|\failed|\Time" | wgetpaste

post links


#7

https://paste.pound-python.org/show/6zv8mElFzl1JEnqMqw7i/
https://paste.pound-python.org/show/jdul1Z8serp875cRcIX9/


#8

inxi -FGxxxz please post this in forum, only really long outputs need be posted to wgetpaste

are you using encryption?
what changes did you make right before this happened?
did you install/remove and drivers recently?

cat /etc/default/grub | grep CMDLINE
cat /etc/modprobe.d/*
mhwd -li


#9

[ron@ron-pc ~]$ cat /etc/default/grub | grep CMDLINE
GRUB_CMDLINE_LINUX_DEFAULT=“quiet resume=UUID=7869b77d-4327-422a-81c6-f7db97617892”
GRUB_CMDLINE_LINUX_DEFAULT=“ipv6.disable=1”
GRUB_CMDLINE_LINUX=""

[ron@ron-pc ~]$ cat /etc/modprobe.d/*

Generated by mhwd - Manjaro Hardware Detection

blacklist nouveau
blacklist ttm
blacklist drm_kms_helper
blacklist drm
install libnvdimm /usr/bin/ndctl load-keys ; /sbin/modprobe --ignore-install libnvdimm $CMDLINE_OPTS


#10

where is
mhwd -li (i asked because of all the erros related to nvidia in logs)
and
inxi -FGxxxz
also include
mhwd-kernel -li

can you remove ipv6.disable=1 , save, update-grub
sudo nano /etc/default/grub
remove ipv6.disable=1
save/exit
mkinitcpio -P
update-grub
post any errors, if none. reboot and see if your able to boot properly.

ALSO: if you believe this to be from messing with iptables/netfilter then disable and try again
systemctl disable ufw


#11

Got rid of ip6.
[ron@ron-pc ~]$ mkinitcpio -P
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: ‘default’
-> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64.img
==> ERROR: Unable to write to /boot/initramfs-4.19-x86_64.img
==> Building image from preset: /etc/mkinitcpio.d/linux419.preset: ‘fallback’
-> -k /boot/vmlinuz-4.19-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.19-x86_64-fallback.img -S autodetect
==> ERROR: Unable to write to /boot/initramfs-4.19-x86_64-fallback.img
==> Building image from preset: /etc/mkinitcpio.d/linux420.preset: ‘default’
-> -k /boot/vmlinuz-4.20-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.20-x86_64.img
==> ERROR: Unable to write to /boot/initramfs-4.20-x86_64.img
==> Building image from preset: /etc/mkinitcpio.d/linux420.preset: ‘fallback’
-> -k /boot/vmlinuz-4.20-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.20-x86_64-fallback.img -S autodetect
==> ERROR: Unable to write to /boot/initramfs-4.20-x86_64-fallback.img

[ron@ron-pc ~]$ mhwd-kernel -li
Currently running: 4.20.7-1-MANJARO (linux420)
The following kernels are installed in your system:
error: could not open file /var/lib/pacman/local/upower-0.99.9-1/desc: No such file or directory

  • linux419
  • linux420
    error: could not open file /var/lib/pacman/local/upower-0.99.9-1/desc: No such file or directory

[ron@ron-pc ~]$ inxi -Fxxxz
System:
Host: ron-pc Kernel: 4.20.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1
Desktop: N/A wm: xfwm4 dm: LightDM 1.28.0 Distro: Manjaro Linux
Machine:
Type: Desktop Mobo: ASUSTeK model: P5Q v: Rev 1.xx serial:
BIOS: American Megatrends v: 2209 date: 03/11/2010
CPU:
Topology: Quad Core model: Intel Core2 Quad Q6600 bits: 64 type: MCP
arch: Core Merom rev: B L2 cache: 4096 KiB
flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 19204
Speed: 1600 MHz min/max: 1603/2403 MHz Core speeds (MHz): 1: 1600 2: 1600 3: 1600
4: 1600
Graphics:
Device-1: NVIDIA G92 [GeForce 9800 GT] driver: nvidia v: 340.107 bus ID: 01:00.0
chip ID: 10de:0605
Display: x11 server: X.org 1.20.3 driver: nvidia resolution:
OpenGL: renderer: GeForce 9800 GT/PCIe/SSE2 v: 3.3.0 NVIDIA 340.107
direct render: Yes
Audio:
Device-1: Intel 82801JI HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus ID: 00:1b.0 chip ID: 8086:3a3e
Sound Server: ALSA v: k4.20.7-1-MANJARO
Network:
Device-1: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet
vendor: ASUSTeK driver: ATL1E v: N/A port: dc00 bus ID: 02:00.0 chip ID: 1969:1026
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac:
Drives:
Local Storage: total: 1.19 TiB used: 22.53 GiB (1.9%)
ID-1: /dev/sda vendor: Hitachi model: HDP725032GLA360 size: 298.09 GiB
speed: 3.0 Gb/s rotation: 7200 rpm serial: rev: A52A scheme: MBR
ID-2: /dev/sdb vendor: Maxtor model: STM3500320AS size: 465.76 GiB speed: 3.0 Gb/s
rotation: 7200 rpm serial: rev: MX1A scheme: MBR
ID-3: /dev/sdc vendor: Hitachi model: HDP725032GLA360 size: 298.09 GiB
speed: 3.0 Gb/s rotation: 7200 rpm serial: rev: A52A scheme: MBR
ID-4: /dev/sdd vendor: Hitachi model: HDT722516DLA380 size: 153.39 GiB
speed: 1.5 Gb/s serial: rev: A96A scheme: MBR
Partition:
ID-1: / size: 46.64 GiB used: 14.89 GiB (31.9%) fs: ext3 dev: /dev/sda2
ID-2: /boot size: 294.1 MiB used: 98.9 MiB (33.6%) fs: ext3 dev: /dev/sda1
ID-3: /home size: 239.37 GiB used: 7.54 GiB (3.2%) fs: ext4 dev: /dev/dm-0
ID-4: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdd2
ID-5: swap-2 size: 5.94 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4
Sensors:
System Temperatures: cpu: 57.0 C mobo: N/A gpu: nvidia temp: 56 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 35%
Info:
Processes: 210 Uptime: 1h 50m Memory: 7.79 GiB used: 2.83 GiB (36.4%) Init: systemd
v: 240 Compilers: gcc: 8.2.1 Shell: bash v: 5.0.0 running in: xfce4-terminal
inxi: 3.0.30

I’VE ALREADY DISABLED UFW.


#12

i was under the impression you were doing this from chroot, from your install you would need to add sudo before update-grub and mkinitcpio -P . but first, what is this and did you add or remove it in the last few days?

i dont see why mhwd-kernel -li would be looking for it. please post
pacman -Qs upower


#13

No, at the very beginning I DID chroot from a live usb. I then did a systemctl disable ufw and tried to reboot into my normal install, which worked. Then I went on Firewall and tried to enable and it crashed the system. And rebooted into my normal system and have NOT touched my firewall config so I can communicate here. Then I followed your suggestions and updated grub.

[ron@ron-pc ~]$ pacman -Qs upower
error: could not open file /var/lib/pacman/local/upower-0.99.9-1/desc: No such file or directory
local/cpupower 4.20-2 (linux-tools)
Linux kernel tool to examine and tune power saving related features of your
processor
local/upower 0.99.9-1


#14

for some reason its installed but missing something,
sudo pacman -S upower (no errors? continue)
sudo pacman -Syyu
then
sudo mkinitcpio -P
sudo update-grub
no errors? reboot.
mhwd-kernel -li
upower error gone?


#15

ron@ron-pc ~]$ sudo pacman -S upower
[sudo] password for ron:
warning: upower-0.99.9-1 is up to date – reinstalling
resolving dependencies…
looking for conflicting packages…
error: could not open file /var/lib/pacman/local/upower-0.99.9-1/desc: No such file or directory
warning: could not fully load metadata for package upower-0.99.9-1
error: failed to prepare transaction (invalid or corrupted package)


#16

do this first
sudo pacman-mirrors -f5
sudo pacman -Syyu


#17

Ok, I rebooted successfully. When I went on Firewall and tried to activate it, it crashed my system.


#18

ok so you no longer have any issue with boot? the only issue is the firewall crashing when you try to disable it?


#19

Yes. I think I’ll try a reinstall of ufw at this point.


#20

hope you get it figured out, unfortunately i dont know all that much regarding custom firewall/iptables