Neo Geo emulator for retro arch problem

Maybe someone has already installed a geo-geo emulator for retro? I wondering because i can't emulate and i can't find in repository neo-geo core or assets.

Did you try the online updater inside Retroarch itself? It should have a core updater. Final Burn Neo is what I use.

Edit: Sometimes the core updater does not show on the online updater by default, in which case you have to navigate to Settings/User Interface/Show Advanced Settings (Enable), then you go to Views/Show Core Updater (Enable).

I don't know, i do as you said but i don't have neo Geo in download Rom. Only neo Geo pocket. And i can't update the core because i don't have running neo Geo core. Maybe you can send me core, i don't really know how but maybe you know how :sweat_smile:

It is not that you need to update it, but to download it.

Do you have an interface like this one?

If so, you have to get into Online Updater, then here:

Then you should see a core list like this:

Do you get this list?

It would not work, since I am using the x86_64 version, but you can find all the ARM cores here: http://buildbot.libretro.com/nightly/android/latest/arm64-v8a/

Edit: Even easier! It is in the AUR:

Thanks for your support, but i have Rpi4 and arch64 build. I download from all folders in "Linuks' core and none of it is working, and none of it is loading in core.
I think this is fresh system and he have only couple of cores.

Would you mind posting a screenshot of what your Retroarch interface and core list looks like, please?

Ok no problem, when i will come back from work to home, for about 4 hour :wink:

What version of Manjaro and on which device you have?

Now i downloaded NeoGeo from aur and github and I compile the emulator. i let you know when finish.

You could also download the "Arcade" core, which must be Final Burn Alpha and should work.

In arcade i have only:

Sorry - it is alienarena.zip

Oh, nevermind, you are on Content Downloader. You should be on "Core Updater".


What options do you get here?

If i run it, nothing happens. only short blink :frowning:

Please try this one and see if it works: buildbot.libretro.com/nightly/linux/armhf/latest/fbalpha2012_neogeo_libretro.so.zip

Nothing happens when i am loading core, but install successful. Tomorrow i will install with noobs on another sd card retroarch.
That worked for me for now.

Don't know if it has anything to do with it, but Manjaro ARM is arm64 and that file you linked is armhf. So it might not be able to do any arm64 stuff?

I think that is for another platform. But when i compile grom repositiry git neo geo core, it compile and install only for android :thinking:

Yeah, it is just that we tried the ARMv8 version earlier and it did not work either, so I was giving this version a shot, just in case. I am very familiar with Retroarch, just not with ARM devices. The other option would be armv7-neon-hf, but I think it would make no difference.

karol1988, what device are you running Manjaro ARM on?

Forum kindly sponsored by