Need to reinstall grub Windows+Manjaro hdd+ssd

So i had my Manjaro on my SSD, then i reinstalled windows on the HDD of my notebook, afterwards i cant boot into my sdd, i was using the F12 boot menu to choose, now only windows work, after some research i manage to put grub up again, but only windows entry appears, everytime i mess up with grub i cant repair, and now i think its time to learn if someone can help.

SDA - HDD - Windows
SDB - SSD - Manajaro
SDc - USB Stick -Manjaro liveCD

Is your system all uefi/gpt or all /bios-legacy/msdos?
Take a look at this. Provide the information as written there.

If you have trouble booting into Manjaro from that link, boot up livecd and provide as much information from it. And search … oh here it is… on your windows system.

1 Like

So both gpt and EFI, i was following manjaro Wiki GRUB restore and now I realize Ive made a mistake prob a great one “rm -r /boot/EFI” after the mount the EFI partition, dont know why i did that, now its done, If its easier to reinstall manjaro then i’m going to do this, I seriously want/need to learn about grub and bootloaders better, always messing things with grub.

Edit: I’m afraid after your post with Lenovo issues, it’s a kinda new ideapad 320, I just switched my oldest sad into it and reinstalled windows.

Then just create a new /boot/efi $esp, change fstab for it. Boot up using that link and do the commands there.

Fix windows as well ( if it is not) with a separate $esp.

1 Like

so i manage to fix manjaro with some research, but now i’m with the same problem but on the other side, strangely only manjaro SSD appears on the boot screen (F12), i tried update-grub and that dont detect windows, its like my windows hdd its sleeping.

$ sudo update-grub
[sudo] password for cassianoblonski:
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-4.19-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-4.19-x86_64.img
Found initrd fallback image: /boot/initramfs-4.19-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

i really dont know how to do this(add windows there), i’m even stuck searching how to do this, when i got the notebook from my sister with the w10 i just installed the ssd from my old notebook and then choose between the 2 OS on the boot menu, after I reinstalled this w10 things are going downhill, now i’m stuck on Manjaro, thats crazy 1.5 year not using linux can make you newbie again so fast

,

I didn’t understand what info I can provide, I runned some lines on grub cli and got these returns. I tried to add windows to grub, but didn’t work, neither (hd0,gpt2) nor (hd0,gpt2), gpt1 is the partition windows create alone and gpt2 windows bigger partition the one I selected to install

other commands:

efibootmgr -v
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,2003,2001,2002
Boot0003* EFI Hard Drive (CT250MX500SSD1) PciRoot(0x0)/Pci(0x17,0x0)/Sata(1,0,0)/HD(1,GPT,db69e7a0-d9ba-45c1-b7b2-8a2682cfa6db,0x1000,0x96000)RC
Boot0004* EFI Network 0 for IPv4 (64-1C-67-8D-93-0F) PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(641c678d930f,0)/IPv4(0.0.0.00.0.0.0,0,0)RC
Boot0005* EFI Network 0 for IPv6 (64-1C-67-8D-93-0F) PciRoot(0x0)/Pci(0x1c,0x0)/Pci(0x0,0x0)/MAC(641c678d930f,0)/IPv6([::]:<->[::]:,0,0)RC
Boot2001* EFI USB Device RC
Boot2002* EFI DVD/CDROM RC
Boot2003* EFI Network RC
####################################
sudo parted -l
[sudo] password for cassianoblonski:
Model: ATA WDC WD5000LPCX-2 (scsi)
Disk /dev/sda: 500GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 17,8MB 16,8MB Microsoft reserved partition msftres
2 17,8MB 215GB 215GB ntfs Basic data partition msftdata
3 215GB 500GB 285GB ntfs Basic data partition msftdata

Model: ATA CT250MX500SSD1 (scsi)
Disk /dev/sdb: 250GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 2097kB 317MB 315MB fat32 boot, esp
2 317MB 241GB 241GB ext4
3 241GB 250GB 8598MB linux-swap(v1)
######################################
sudo blkid
/dev/sda1: PARTLABEL=“Microsoft reserved partition” PARTUUID=“9830cfba-77c9-4ba4-8196-d00be14c9fb5”
/dev/sda2: UUID=“C8F04A2AF04A1F56” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“2c8f3345-2bf2-4c34-aefd-ba6cb8e84275”
/dev/sda3: LABEL=“Bag of ■■■■■ UUID=“02A05CCDA05CC8B5” TYPE=“ntfs” PARTLABEL=“Basic data partition” PARTUUID=“f48ef5db-15f1-4f5b-ba25-3b386269612f”
/dev/sdb1: UUID=“226E-F046” TYPE=“vfat” PARTUUID=“db69e7a0-d9ba-45c1-b7b2-8a2682cfa6db”
/dev/sdb2: UUID=“9042021d-f3fb-4675-8bcc-5a29ee5b28e1” TYPE=“ext4” PARTUUID=“fc957a3c-68b4-4354-b48e-7e1fa350ca93”
/dev/sdb3: UUID=“3fe39613-46d8-4059-866d-98f31de1931a” TYPE=“swap” PARTUUID=“615c6e7a-435c-4168-96f4-33d3b78cc1cb”
####################################################
findmnt -s
TARGET SOURCE FSTYPE OPTIONS
/boot/efi UUID=226E-F046 vfat defaults,noatime
/ UUID=9042021d-f3fb-4675-8bcc-5a29ee5b28e1 ext4 defaults,noatime,discard
swap UUID=3fe39613-46d8-4059-866d-98f31de1931a swap defaults,noatime,discard
/tmp tmpfs tmpfs defaults,noatime,mode=1777
###################################################
findmnt /boot/efi
TARGET SOURCE FSTYPE OPTIONS
/boot/efi /dev/sdb1 vfat rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed
#####################################################
this is what I tried before

sudo cat /etc/grub.d/40_custom
#!/bin/sh
exec tail -n +3 $0

This file provides an easy way to add custom menu entries. Simply type the

menu entries you want to add after this comment. Be careful not to change

the ‘exec tail’ line above.

menuentry “Windows 10” {
set root=’(hd0,gpt1)’
chainloader +1
}

Looks like you’ve deleted the windows $esp (EFI) partition.
You’ve installed Manjaro with a new $esp in sdb (and that’s okay) but now you’re missing the windows boot.

To check that, go to grub prompt (press ‘c’ at grub menu) and do the following…

grub> insmod fat
grub> insmod ntfs
grub> search.file /bootmgr
grub> search.file /EFI/Microsoft/Boot/bootmgfw.efi

Provide output of the last 2 grub commands.
To be sure, double check at Manjaro file manager if there are the 2 files
‘bootmgr’ at any ntfs partition (not within any directory - at the ‘base’ partition itself)
‘bootmgfw.efi’ within any fat32 partition (within directory /efi/Microsoft/boot/)

I doubt there are any of the 2, but check that so you don’t have to reinstall windows boot if any of the 2 exists.

If none exists, you have to reinstall windows boot (not the whole OS) but make sure you set up another $esp (in fat32) partition in sda and install your windows boot there. Then boot up manjaro using boot key and reset your manjaro as default and do ‘update-grub’.

sorry for the delay, busy week at work and home move, so the info i got:

Found this file:

then this thing after i runned:
$ sudo mount -t auto -v /dev/sda1 mount_point
mount: /home/cassianoblonski/mount_point: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error.

now you can point me a direction on how to do this, like how to set up this $esp, i’m looking at what is $esp right now, thats the boot partition the 500mb fat32? basically i never successfully reinstalled a windows boot, so if you could point me a reliable source, i already tried that but failed following the wrong commands, thanks in advance for the help, sorry for the low knowledge on some subjects, and the delay to reply with the info.

Neither have I ever reinstalled windows. And the methods have changed with each iterations of windows, fixboot, fixmbr, etc. to something else. You will need to check out the windows websites on the windows version that you have. And I think since you still have the ‘reserved partition’ in sda1, using that may be easier. And, I do not know what 500 MB partition you are referring to. You do not have a 500 MB fat32 partition.

Hopefully you can get back your windows boot, and remember…

Good luck.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.