Need some help with an intractable Xorg issue

No, he writes that xfce4-screenshooter is working normally, but probably this is due to the fact that it cannot do more than one screenshot after being launched.

Spectacle (KDE) can, and I pushed it to its limit, as you described. Could not reproduce.

Still updating this netbook. Almost done. Need to install Shutter as well. :crossed_fingers:

EDIT: Whoa! Shutter requires a lot of dependencies! It pulled in 43 packages. :astonished:

Yes, luckily just very small Perl modules. :sweat_smile:

I can’t even get a desktop, only a mouse cursor, when I login to my Xfce4 session. :neutral_face:

Did it work before the update?

Didn’t test with Shutter. (though I never had Shutter installed prior to this.)

I’ll have to revert with Timeshift to try again.

I meant logging into the Xfce session, sorry. :slight_smile:

Yes. Without a hitch.

Now when I login to an Xfce session it’s a blank screen with a mouse cursor. I can pull up “Application Finder” with ALT + F2 and launch something, like Chromium or Thunar, yet nothing is shown.

What if you launch xfce4-panel and/or xfdesktop by hand, any output from the terminal?

xfce4-panel: symbol lookup error: xfce4-panel: undefined symbol: xfce_gdk_device_grab

I feel like we just switched roles in this thread. :sweat_smile:

EDIT: Oh I’ve had a now unsupported package installed. I’ll fix it, one second.

1 Like

Well, you tried to help me, I try to help you! :smiley:

Possibly Xfce packages from AUR involved? See

1 Like

Confirmed. Same issue as you described with Shutter. :frowning:

It doesn’t matter if I use “Selection” or “Desktop”. The old image (from the initial screenshot) remains.

Ok, so I don’t feel that lonely with this bug now! :slight_smile: But what next? Downgrading Xorg packages?

Either it’s Shutter not catching up with some new update/bugfix/feature of Xorg, or it’s Shutter itself, using some sort of built-in buffer?

Because this happens with or without Compositing enable, and with modesetting or xf86-video-intel.

But it used to work before the update and Shutter didn’t get updated (in fact, it didn’t get updated for quite some time now but hopefully there will be a little bugfix release soon :smiley: ).

That’s what I meant by “not catching up” because it hasn’t been updated in a while.

Well, as a matter of fact I’m part of the Shutter team (mostly doing easy stuff, almost not touching the code at all) and now I’m trying to figure out what is going on. If there are any hints what has been changed on the Xorg side, I can present any such findings to our main developer and he can have a look.

Probably I should try some other screenshot tool to rule out a Shutter specific problem. Let me check if there are some which allow multiple screenshots and don’t pull to many QT deps as spectacle would.

Well, if I take a screenshot with Xfce-screenshooter, and then click “Back” to take another one, it behaves without issue. (No old image lingers.)

Maybe Flameshot?

EDIT: Just tried with Flameshot, and it behaves as expected. Clicking “Take New Screenshot” doesn’t capture the old image. Fullscreen or Selection, doesn’t matter. Works as it should.

My suspicion is that Shutter is using some sort of “buffer” after capturing the first screenshot. It’s not clearing this, and hence it is the base of any further screenshots (whether fullscreen, selection, or window.)

Even if I choose to take a screenshot of a “window”, I can click to select which window (such as Xterm on the right side of the screen, while Thunar is on the left side of the screen.) However, all it does is capture the rectangular area of where Xterm’s window is located on the screen… while the final screenshot is a “cutout” of the old capture before I ever opened Xterm. (It uses the rectangular area of Xterm’s window size, but Xterm is not in the saved screenshot, since Shutter is using the old image as the base. :sweat: )

Yep, looks like this is how it works, but it used to work before this way, so it cannot be that wrong. :slight_smile: The buffer should be updated and before the Xorg update it got updated correctly…