Need help with BTRFS, please.

In terms of compatibility with games and software in general nothing beats EXT4.
Even Steam Libraries for linux should be on ext4, on NTFS they won't work, but modding windows games on linux that are installed through wine/steamplay/lutris isn't easy in general.
For your SSD/RAM cache, do you want to use something like Intel's Optane Technology for Windows or do you mean something else?

I don't know of any tool for that in Linux. (Edit: See below. :man_facepalming:) I came to read about DragonflyBSD doing something similar: https://www.dragonflybsd.org/docs/howtos/swapcache/

IMO you should simply install your Linux on the SSD and use the HDD for large data.

I don't say that btrfs is a bad option, but you need to uderstand what is it good for and what not. It is good for easy and quick snapshots of your system so that you can revert changes quickly and easily. It is also good for sending snapshots to a different disk (but Timeshift's btrfs setup can't do it, yet).
I only recommend not to listen too much to videos or follow inofficial tutorial. Stick to the Arch Wiki on btrfs, Snapper. Timeshift is documented on github.

I dont have Intel's nvme drives so idk if i can even use Optane plus i hear it is pretty bad.
On windows i first used StoreMi(once known as FuzeDrive iirc, AMD kinda bought it i think).
Tiered Storage it is also called.
Then i found PrimoCache on windows and oh that was really nice software. Cost-effective as well compared to what StoreMI gives and how limited it is.

Additionally if i convert my game folder to EXT4 then windows cant read it, right?
My game folder is over 500 Gb, so its quite large. :smiley:

There are tools for Windows to read and write ext4. But I don't know if it is good enough for running games on it. But surprisingly WinBTRFS is making big progress. Read and write works without hassle. Since recently it is even possible to install Windows on btrfs.

Copy the files over to your ssd as needed or get another ssd :grin:

From a quick search:

https://www.rath.org/ssd-caching-under-linux.html


https://wiki.archlinux.org/index.php/Bcache
https://wiki.archlinux.org/index.php/LVM2#LVM_cache
https://wiki.archlinux.org/index.php/Flashcache
https://wiki.archlinux.org/index.php/EnhanceIO

1 Like

That is correct but is not entered in grub.cfg there is

submenu 'Arch Linux snapshots' {
        configfile "${prefix}/grub-btrfs.cfg"

must be

configfile "/@/boot/grub/grub-btrfs.cfg"

I had already changed that last night but only today it worked :smiley:
So now it look


:slight_smile:
until update grub, so I must write a little hook/script that change the grub.cfg :wink:

Maybe @Librewish can show me his/the output from

sudo cat /boot/grub/grub.cfg | grep 'configfile '                                                                                     
[sudo] Passwort fΓΌr sgs: 
       configfile "/@/boot/grub/grub-btrfs.cfg"

Solution #2

I went with your custom Manjarowish install.
It looks really nice. Great work!

i am currectly figuring out how to import my steam library, since it is on hdd (NTFS) .
Doing research currently on this.
What is the best way, should i make a new partition and copy my library there? So it is in a better format.
So far i went with the easy way of creating a steamapps link on Linux desktop, Steam could identify the games, but pressing Play does nothing. :smiley:
The game i tried is Tekken 7, Steam should be downloading Proton since this game has proton support.
Maybe you can help me.
Thank you.

first launch steam from terminal

lsi-steam

then launch game and post output

1 Like

Okay i did lsi-steam.
Steam started downloading all sorts of Shader Caches, then Proton.
Sorry the text is quite long.
Result:

https://hastebin.com/azenuyoxog.sql

Game did not launch.
Btw my controllers were all switched off during this.

have you enabled steam play to run all titles?
its in steam-> settings -> steam play
and enable steam play for all other title and choose proton 5.0

1 Like

Yes it is now enabled on all games, but Proton 5.0.2, i cant choose Proton 5.0
Steam downloaded more stuff under steamworks common redistributables.
Still the game did not launch.
Now i did lsi-steam again.
"Nothing interesting happens" in the words of Runescape. :smiley:

lsi-steam
Running Steam on manjarowishlinux Rolling 64-bit
STEAM_RUNTIME is enabled by the user
Pins up-to-date!
/home/crash/.local/share/Steam/ubuntu12_32/steam
~ >>>

try other small windows game by copying its files
to ~/.local/share/steam
and launch it

1 Like

The file or folder /local does not exist.
i am abit lost here.

it is .local in home

okay i created a /home/share/steam path pasted Blasphemous there.
Steam offered to update Blasphemous (and my other windows games).
Updated
Preparing to launch... this is taking quite awhile.
Oh, Play game is available.
Its loading
It crashed or something, green play button is back on steam.
Clementine freezed for a second with music.

I will try updating another game
Launching
...
Same result.
Also tried this with Tekken 7

how about just download a game from steam instead of using from ntfs drive.
so we can be sure.
also post your
inxi -Fxxxza

okay , I picked Sanctum. Downloaded.
It does not start, same problem, even tho its in the share folder.

inxi -Fxxxza                                                           
System:
  Host: crash-pc Kernel: 5.4.20-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.1 
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.4-x86_64 
  root=UUID=924dfe38-8545-45ce-862a-610767e2060a rw rootflags=subvol=@ 
  quiet splash apparmor=1 security=apparmor 
  resume=UUID=70d96b58-d1e6-48c9-b8db-0ba3e5cca497 audit=0 loglevel=3 
  rd.udev.log_priority=3 vt.global_cursor_default=0 apparmor=1 
  security=apparmor 
  Desktop: KDE Plasma 5.18.0 tk: Qt 5.14.1 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
Machine:
  Type: Desktop System: Gigabyte product: X470 AORUS ULTRA GAMING v: N/A 
  serial: <filter> 
  Mobo: Gigabyte model: X470 AORUS ULTRA GAMING-CF v: x.x serial: <filter> 
  UEFI: American Megatrends v: F50 date: 11/27/2019 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701013 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 86427 
  Speed: 3910 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 3910 2: 3960 3: 3820 4: 4089 5: 3882 6: 4105 7: 3693 8: 3939 9: 3904 
  10: 4071 11: 4040 12: 4116 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  STIBP: conditional, RSB filling 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
  driver: amdgpu v: kernel bus ID: 0c:00.0 chip ID: 1002:731f 
  Display: x11 server: X.org 1.20.7 driver: amdgpu FAILED: ati 
  unloaded: modesetting,radeon alternate: fbdev,vesa compositor: kwin_x11 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: AMD NAVI10 (DRM 3.35.0 5.4.20-1-MANJARO LLVM 9.0.1) 
  v: 4.5 Mesa 19.3.4 direct render: Yes 
Audio:
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 0c:00.1 chip ID: 1002:ab38 
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus ID: 0e:00.4 chip ID: 1022:1487 
  Sound Server: ALSA v: k5.4.20-1-MANJARO 
Network:
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb 
  v: 5.6.0-k port: f000 bus ID: 07:00.0 chip ID: 8086:1539 
  IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: f000 
  bus ID: 08:00.0 chip ID: 8086:2723 
  IF: wlp8s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 2.37 TiB used: 1.39 TiB (58.7%) 
  ID-1: /dev/nvme0n1 vendor: Silicon Power model: SPCC M.2 PCIe SSD 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B 
  speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: ECFM12.3 scheme: GPT 
  ID-2: /dev/sda vendor: Hitachi model: HDS721680PLA380 size: 74.53 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  serial: <filter> rev: ABEA scheme: GPT 
  ID-3: /dev/sdb vendor: Seagate model: ST2000DM006-2DM164 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC26 scheme: GPT 
  ID-4: /dev/sdc type: USB vendor: SanDisk model: Ultra Fit 
  size: 14.32 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 1.00 scheme: MBR 
  ID-5: /dev/sdd vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: 2B6Q scheme: GPT 
Partition:
  ID-1: / raw size: 229.38 GiB size: 229.38 GiB (100.00%) 
  used: 155.23 GiB (67.7%) fs: btrfs dev: /dev/nvme0n1p2 
  ID-2: /home raw size: 229.38 GiB size: 229.38 GiB (100.00%) 
  used: 155.23 GiB (67.7%) fs: btrfs dev: /dev/nvme0n1p2 
  ID-3: swap-1 size: 8.80 GiB used: 186.8 MiB (2.1%) fs: swap 
  swappiness: 5 (default 60) cache pressure: 50 (default 100) 
  dev: /dev/nvme0n1p3 
Sensors:
  System Temperatures: cpu: 48.8 C mobo: N/A gpu: amdgpu temp: 54 C 
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 705 
Info:
  Processes: 392 Uptime: 1h 48m Memory: 15.63 GiB used: 3.75 GiB (24.0%) 
  Init: systemd v: 244 Compilers: gcc: 9.2.1 Shell: zsh v: 5.7.1 
  running in: konsole inxi: 3.0.37 
~ >>>
1 Like

Please :slight_smile:

Important knowledge

Please select the text in the terminal
Paste the text into the post
Select the newly pasted text in the post
Click the </> icon in the post toolbar

This creates nicely formatted text.

(Text was copied from @ linux-aarhus)

Need less place and will like very much by phone/tablet user :wink:

To edit old posts seems possible :slight_smile: with the pencil button.

3 Likes

well i dont know how to proceed.
at least check if linux native games run
like albion online.
this should definitely run.

TF2 is native as well right?
I can play that game.

Forum kindly sponsored by