Need help to install opencl on nvidia prime laptop for davinci resolve

need help to run davinci resolve 16
i installed davinci resolve 16 from AUR
but it shut down automatically on startup

i used davinchi resolve compatability checker script on arch wiki
here is the output

[davinci-resolve-checker]$ sudo ./
[sudo] password for sherlock:
DaVinci Resolve checker 1.2.1

You do not have opencl-nvidia package. Install it, otherwise you could not use D.R. Even if you are planning to use cuda, opencl-nvidia will be installed as its dependency.

it showed opencl is not installed
but i have installled opencl and rebooted
i am pretty sure that i installed the right drivers because all other apps are working

Maybe you took the wrong version of opencl. What is the output to:

pamac install opencl-nvidia


also, an inxi --full --admin --verbosity=7 --filter --no-host would be of help (and should always be provided regardless of the question you’re asking…


OUTPUT OF nvidia-smi

Mon Aug 24 16:48:06 2020       
| NVIDIA-SMI 450.57       Driver Version: 450.57       CUDA Version: 11.0     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  GeForce GTX 166...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   45C    P0    10W /  N/A |      6MiB /  5944MiB |      0%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      1054      G   /usr/lib/Xorg                       4MiB |
+-----------------------------------------------------------------------------+ ```

**sudo pacman -S opencl-nvidia**
```warning: opencl-nvidia-450xx-450.57-2 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) opencl-nvidia-450xx-450.57-2

Total Installed Size:  80.71 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n]

**inxi --full --admin --verbosity=7 --filter --no-host** 

System:    Kernel: 5.8.1-3-MANJARO x86_64 bits: 64 compiler: N/A 
          parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=2c81bae5-004a-4056-80e0-10e3b251f6b5 rw quiet apparmor=1 
          security=apparmor udev.log_priority=3 
          Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 info: latte-dock wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Nitro AN715-51 v: V1.05 serial: <filter> 
          Mobo: CFL model: Citigo_CFS v: V1.05 serial: <filter> UEFI: Insyde v: 1.05 date: 05/31/2019 
Battery:   ID-1: BAT1 charge: 57.0 Wh condition: 57.0/58.8 Wh (97%) volts: 17.5/15.4 model: Simplo PABAS0241231 type: Li-ion 
          serial: <filter> status: Full 
Memory:    RAM: total: 23.33 GiB used: 1.21 GiB (5.2%) 
          RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
          stepping: A (10) microcode: D6 L2 cache: 12.0 MiB bogomips: 62431 
          Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
          9: 800 10: 800 11: 800 12: 800 
          Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art avx avx2 bmi1 bmi2 bts clflush 
          clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c 
          flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida intel_pt 
          invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe 
          pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep smap 
          smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx 
          vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr 
          Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
          Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
          Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
          Type: meltdown mitigation: PTI 
          Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
          Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
          Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
          Type: srbds mitigation: Microcode 
          Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel UHD Graphics 630 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
          chip ID: 8086:3e9b 
          Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] vendor: Acer Incorporated ALI driver: nvidia v: 450.57 
          alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:2191 
          Device-3: Quanta HD Webcam type: USB driver: uvcvideo bus ID: 1-5:3 chip ID: 0408:a060 serial: <filter> 
          Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 driver: modesetting,nvidia unloaded: intel,nouveau 
          alternate: fbdev,nv,vesa display ID: :0 screens: 1 
          Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9") 
          Monitor-1: eDP-1 res: 1920x1080 hz: 144 dpi: 142 size: 344x194mm (13.5x7.6") diag: 395mm (15.5") 
          OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.5 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
          alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 
          Sound Server: ALSA v: k5.8.1-3-MANJARO 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
          chip ID: 8086:a370 
          IF: wlp0s20f3 state: up mac: <filter> 
          IP v4: <filter> type: dynamic noprefixroute scope: global broadcast: <filter> 
          IP v6: <filter> type: noprefixroute scope: link 
          Device-2: Qualcomm Atheros Killer E2500 Gigabit Ethernet vendor: Acer Incorporated ALI driver: alx v: kernel 
          port: 3000 bus ID: 06:00.0 chip ID: 1969:e0b1 
          IF: enp6s0 state: down mac: <filter> 
          WAN IP: <filter> 
Drives:    Local Storage: total: 223.57 GiB used: 26.63 GiB (11.9%) 
          SMART Message: Unable to run smartctl. Root privileges required. 
          ID-1: /dev/sda type: USB model: External USB3.0 size: 223.57 GiB block size: physical: 4096 B logical: 512 B 
          serial: <filter> rev: 0204 scheme: GPT 
          Message: No Optical or Floppy data was found. 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 port: 5060 bus ID: 00:17.0 
          chip ID: 8086.282a rev: 10 
Partition: ID-1: / raw size: 100.00 GiB size: 97.93 GiB (97.93%) used: 26.63 GiB (27.2%) fs: ext4 dev: /dev/sda2 label: N/A 
          uuid: 2c81bae5-004a-4056-80e0-10e3b251f6b5 
          ID-2: /boot/efi raw size: 512.0 MiB size: 511.0 MiB (99.80%) used: 300 KiB (0.1%) fs: vfat dev: /dev/sda1 
          label: N/A uuid: 51AA-0869 
Swap:      Alert: No Swap data was found. 
Unmounted: ID-1: /dev/sda3 size: 20.00 GiB fs: ext4 label: Backup uuid: a91d379d-c3b4-4734-a5b0-c0d64cc98db2 
          ID-2: /dev/sda4 size: 50.00 GiB fs: ntfs label: storage uuid: EEE4115DE411297B 
          ID-3: /dev/sda5 size: 30.00 GiB fs: ntfs label: workspace uuid: 2CE62761E6272B12 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
          Device-1: 1-1:2 info: USB OPTICAL MOUSE type: Mouse driver: hid-generic,usbhid interfaces: 1 rev: 1.1 
          speed: 1.5 Mb/s chip ID: 30fa:0300 
          Device-2: 1-5:3 info: Quanta HD Webcam type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
          chip ID: 0408:a060 serial: <filter> 
          Device-3: 1-14:4 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: Bluetooth driver: btusb interfaces: 2 
          rev: 2.0 speed: 12 Mb/s chip ID: 8087:0aaa 
          Hub: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s chip ID: 1d6b:0003 
          Device-1: 2-3:2 info: JMicron / JMicron USA JMS578 SATA 6Gb/s type: Mass Storage driver: uas interfaces: 1 rev: 3.0 
          speed: 5 Gb/s chip ID: 152d:0578 serial: <filter> 
Sensors:   System Temperatures: cpu: 64.0 C mobo: N/A 
          Fan Speeds (RPM): N/A 
Info:      Processes: 306 Uptime: 3m Init: systemd v: 245 Compilers: gcc: 10.1.0 clang: 10.0.1 Packages: 1389 pacman: 1381 
          lib: 375 flatpak: 8 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.05 ```

should i install “cuda” ?
i think this might work
but it is quiet heavy download

Erm, that’s quite hard to read for an old fart like me, so could you edit that and put 3 backticks ``` before and after the output you posted so that output looks like this.

Then ping me @Fabby

was that the kernel 5.8 issue
i saw youtubers installing
davici resolve 16 on older kernels got success

i have edited it as you asked

OK, you’re on the 350.xx driver and you have a GTX1660 (TI or not? as that output has ... at the crucial point), but that’s already good!

What’s the output to pamac install opencl-nvidia? Because the first time when you install that, it will ask you:

Choose a provider for opencl-nvidia:
1:  opencl-nvidia-340xx  340.108-1  extra
2:  opencl-nvidia-390xx  390.132-1  extra
3:  opencl-nvidia-418xx  418.113-1  extra
4:  opencl-nvidia-430xx  430.64-1   extra
5:  opencl-nvidia-435xx  435.21-1   extra
6:  opencl-nvidia-440xx  440.100-1  extra
7:  opencl-nvidia-450xx  450.57-2   extra

and if you take the wrong version there, you’re in a heap of trouble, so the output to clinfo would be appreciated as well.


thanks for taking time
my gpu is 1660 ti mobile 6gb ddr6

but i am a premere pro user
i just got into manjaro a month ago and wanted to
give a editing test so that i could stop paying for adobe
kdenlive works fine but davinci resolve 16 has some additional features
i think installing cuda will fix it
but as you have asked for clinfo i installed it and here is the output

i am sure that i have installed nvidia450 with opencl v450
i think

Number of platforms                               1
  Platform Name                                   NVIDIA CUDA
  Platform Vendor                                 NVIDIA Corporation
  Platform Version                                OpenCL 1.2 CUDA 11.0.210
  Platform Profile                                FULL_PROFILE
  Platform Extensions                             cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_fp64 cl_khr_byte_addressable_store cl_khr_icd cl_khr_gl_sharing cl_nv_compiler_options cl_nv_device_attribute_query cl_nv_pragma_unroll cl_nv_copy_opts cl_nv_create_buffer cl_khr_int64_base_atomics cl_khr_int64_extended_atomics
  Platform Extensions function suffix             NV

  Platform Name                                   NVIDIA CUDA
Number of devices                                 1
  Device Name                                     GeForce GTX 1660 Ti
  Device Vendor                                   NVIDIA Corporation
  Device Vendor ID                                0x10de
  Device Version                                  OpenCL 1.2 CUDA
  Driver Version                                  450.57
  Device OpenCL C Version                         OpenCL C 1.2 
  Device Type                                     GPU
  Device Topology (NV)                            PCI-E, 01:00.0
  Device Profile                                  FULL_PROFILE
  Device Available                                Yes
  Compiler Available                              Yes
  Linker Available                                Yes
  Max compute units                               24
  Max clock frequency                             1590MHz
  Compute Capability (NV)                         7.5
  Device Partition                                (core)
    Max number of sub-devices                     1
    Supported partition types                     None
    Supported affinity domains                    (n/a)
  Max work item dimensions                        3
  Max work item sizes                             1024x1024x64
  Max work group size                             1024
  Preferred work group size multiple              32
  Warp size (NV)                                  32
  Preferred / native vector sizes                 
    char                                                 1 / 1       
    short                                                1 / 1       
    int                                                  1 / 1       
    long                                                 1 / 1       
    half                                                 0 / 0        (n/a)
    float                                                1 / 1       
    double                                               1 / 1        (cl_khr_fp64)
  Half-precision Floating-point support           (n/a)
  Single-precision Floating-point support         (core)
    Denormals                                     Yes
    Infinity and NANs                             Yes
    Round to nearest                              Yes
    Round to zero                                 Yes
    Round to infinity                             Yes
    IEEE754-2008 fused multiply-add               Yes
    Support is emulated in software               No
    Correctly-rounded divide and sqrt operations  Yes
  Double-precision Floating-point support         (cl_khr_fp64)
    Denormals                                     Yes
    Infinity and NANs                             Yes
    Round to nearest                              Yes
    Round to zero                                 Yes
    Round to infinity                             Yes
    IEEE754-2008 fused multiply-add               Yes
    Support is emulated in software               No
  Address bits                                    64, Little-Endian
  Global memory size                              6233391104 (5.805GiB)
  Error Correction support                        No
  Max memory allocation                           1558347776 (1.451GiB)
  Unified memory for Host and Device              No
  Integrated memory (NV)                          No
  Minimum alignment for any data type             128 bytes
  Alignment of base address                       4096 bits (512 bytes)
  Global Memory cache type                        Read/Write
  Global Memory cache size                        786432 (768KiB)
  Global Memory cache line size                   128 bytes
  Image support                                   Yes
    Max number of samplers per kernel             32
    Max size for 1D images from buffer            268435456 pixels
    Max 1D or 2D image array size                 2048 images
    Max 2D image size                             32768x32768 pixels
    Max 3D image size                             16384x16384x16384 pixels
    Max number of read image args                 256
    Max number of write image args                32
  Local memory type                               Local
  Local memory size                               49152 (48KiB)
  Registers per block (NV)                        65536
  Max number of constant args                     9
  Max constant buffer size                        65536 (64KiB)
  Max size of kernel argument                     4352 (4.25KiB)
  Queue properties                                
    Out-of-order execution                        Yes
    Profiling                                     Yes
  Prefer user sync for interop                    No
  Profiling timer resolution                      1000ns
  Execution capabilities                          
    Run OpenCL kernels                            Yes
    Run native kernels                            No
    Kernel execution timeout (NV)                 Yes
  Concurrent copy and kernel execution (NV)       Yes
    Number of async copy engines                  3
  printf() buffer size                            1048576 (1024KiB)
  Built-in kernels                                (n/a)
  Device Extensions                               cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_fp64 cl_khr_byte_addressable_store cl_khr_icd cl_khr_gl_sharing cl_nv_compiler_options cl_nv_device_attribute_query cl_nv_pragma_unroll cl_nv_copy_opts cl_nv_create_buffer cl_khr_int64_base_atomics cl_khr_int64_extended_atomics

NULL platform behavior
  clGetDeviceIDs(NULL, CL_DEVICE_TYPE_ALL, ...)   Success [NV]
  clCreateContext(NULL, ...) [default]            Success [NV]
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_DEFAULT)  No platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CPU)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_GPU)  No platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ACCELERATOR)  No devices found in platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_CUSTOM)  Invalid device type for platform
  clCreateContextFromType(NULL, CL_DEVICE_TYPE_ALL)  No platform

ICD loader properties
  ICD loader Name                                 OpenCL ICD Loader
  ICD loader Vendor                               OCL Icd free software
  ICD loader Version                              2.2.12
  ICD loader Profile                              OpenCL 2.2

this post refers to same issue
he uses other gpu

That’s all looking good, so go to a terminal and type:


and provide the output for that, please?


hey i found a fix
i used command
prime-run /opt/resolve/bin/resolve
then it works
i read this in medium post

i heartfully thank you for spending time for me
for your kind suppourt
please suggest this fix if any one face the same issue

1 Like

hey i found a fix
i used command
prime-run /opt/resolve/bin/resolve
then it works
i read this in medium post

i need help

how to not type this command again

This would have told me that 3 hours ago!

:stuck_out_tongue_winking_eye: :crazy_face:

But good that you solved your own problem! :+1:

Please do me a favour and add the output to the inxi in your original question so that the next person looking for a solved issue can compare its output to yours!


i dont know how to change the default command to launch resolve 16 to use prime-run
not using the terminal

you need to edit its desktop file to add prime-run before the /opt/resolve/bin/resolve


P.S. Note: I don’t use nor have resolve installed, so can’t give you exact instructions but it’s probably /opt/resolve/bin/resolve.desktop

sudo nano --backup /opt/resolve/bin/resolve.desktop

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.