Need help to fix my networking issue

Hey,can someone help me with my network management a little? I’m on manjaro kde.

I was trying to setup dns and meessed up so I can’t connect to internet anymore(in browser dns address couldn’t be found and in terminal when I try nslookup a domain it says no server could be reached).

What I did was I deleted my resolv.conf and resolvconf.conf file and setup /etc/systemd/resolved.conf file.There I setup the dns ip and fallbackdns and changed the dnsovertls to yes since the dns server(libredns) has this support. Then I enabled systemd-resolved.service and rebooted.Now my internet connection isn’t working anymore.

After that I created a new file /etc/resolvconf.conf and inputted the ip of nameserver there but that didn’t fix anything. I tried to edit the /etc/resolv.conf but it says it’s managed by systemd-resolved and asked not to edit.

I have no idea what to do now.

Have you read this? systemd-resolved - ArchWiki

So I created a new directory : /etc/systemd/resolved.conf.d
and a config file dns_servers.conf
with these lines
[Resolve] DNS= ::1 Domains=~. DNSOverTLS=yes
After that I restarted Networkmanager.
But it’s still not working.



Did you try to reinstall network manager ?

I think you have to restart systemd-resolved. Also shouldn’t add to this config.

Does that DNS server you have set support DNS over TLS?

Why? What’s the problem?

I’m maybe wrong, it is not his private ip ?

No, it’s not. DNS = Domain Name Server.
Even if it were, usually there is no problem…

yes. It’s libredns and it has DNS over TLS support

No,it’s a public DNS.

That’s the fallback address. Should I removed it?

Do you have a DNS server with DNSoverTLS support in your machine?

But the libredns documentation and archwiki said systemd can handle it.

Yes, but if you add, you are informing systemd-resolved that there is a DNS server (with TLS capabilities, as you enabled it) in the local machine. If that is true, then you can leave the address, if not you should remove it.

I removed that it’s still not working.
from the resolvectl status output I noticed that the dns server is diifferent for the global and wifi(mobile hotspot). Is that the reason for this problem?

All the efforts have failed. Can someone tell me atleast how to reset everything back to default?
In the default, the systemd-resolved was disabled.

So didn’t find any solutions.Disabled systemd-resolved and manually set the nameservers in \etc\resolv.conf and in \etc\resolvconf.conf.
I couldn’t achieve DNSoverTLS but atleast my internet is working now.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.