Need help setting up Arctis 7 gaming headset

Hello everybody, let me start by thanking you for your time and for any help you may provide.

I am a new manjaro user, I just installed manjaro last Wednesday after some 7 years away from linux, dual booting windows 10, but my intention is to eventually remove windows altogether.

On to the issue at hand, I have an Arctis 7 wireless headset, which works just fine with the default configuration; however, it features a sort of pass through, by plugging in my speakers directly into the headset’s USB adapter, which in turn is plugged into the PC. When I connect my speakers directly to the motherboard, they work as expected, but when I plug them into the adapter, I only get sound out of one of the speakers (the left one, if that matters).

If you have suggestions as to how to fix this, blog posts I should read, terminal output you may need to help, please let me know.

Warm regards,

Hopefully the post below will help, it fixed a similar issue I had. Check the reply by Fabby.

Link: No sound on laptop speaker's left channel - #4 by yannssolo

Hi there Sierrafox,

Is it still supposed to read “Not connected” after overriding and rebooting? I’m talking about the little subtitle thing, just above the Pin ID line.

I get three Not connected pins, two of them only let me choose between “Not connected” and “Internal Mic”, the last one gave me a lot of options:

  1. Line Out (Front)
  2. Line Out (Center/LFE)
  3. Line Out (Back)
  4. Line Out (Side)
  5. Internal Speaker
  6. Internal Speaker (LFE)
  7. Internal Speaker (Back)
  8. Internal Mic
  9. Dock Line Out
  10. Not Connected

I tried #9 and #4 so far. The only difference that made is that now I simply do not hear whatever is supposed to sound on the right speaker; so it’s a bit worse.

Again, thank you for any help you can provide.

Mine still shows up as unconnected under the hdajackretask software, but since doing the override I can hear audio out of said unconnected speakers.

Sorry, I posted prematurely, please read my full response above.

At the top of the software where it says select a codec, do you have any other options in that drop down?

I have one called “Realtek ALC1220”, from my motherboard, and one “ATI R6xx HDMI”, from my videocard’s HDMI output, unless I’m mistaken; I have not tried the latter since my headset is plugged in via USB directly to the motherboard. I’ll give it a shot.

There’s no unconnected pins on the ATI codec.

Ok, that should give you more options mine defaults to my Nvidia card too. I’m no expert by any means, but it seems most people fix these types of issues using this software. If this doesn’t work hopefully someone will come along that knows more about the audio backend of Linux…

Thank you very much Sierrafox,

I’m trying out all the line out options I get, maybe one of those will work.

No problem. Let me know if it ends up working. You can also use the dmesg command to view driver errors from the kernel.

It seems my problem was at the hardware level after all; I tried unplugging and reconnecting everything back and now both my speakers and my headset are working as expected, I’m guessing I had a loose connection somewhere.

Thanks again for your help.

1 Like