Nach grafiktreiberwechsel - system geht nicht mehr

ich habe die grafiktreiber gewechselt, was ich hätte nicht tun sollen. mir ging nur das screentearing so auf den zeiger.
habe gewechselt von den video-nvidia zu den glaub video-mesa…
nach neustart ging da nix mehr.
strg+alt+f2 oder f1 geht nicht, um das terminal zu starten. das system meldet sich an und dann is feierabend.
ist das ganze noch rettbar, oder darf ich neu machen?

Hi,

versuch mal folgende Schritte:

Währen des Startvorgang, wenn Grub angezeigt wird, die F10 taste drücken und dem Kernel folgende Bootoption 3 nomodeset hinzufügen. So gelangst du zu einen Eingabe prompt in dem du dich einloggst und folgende Befehle nacheinander ausführst:

sudo mhwd -r pci $(mhwd -li |grep 'video-' | awk '{print $1}')

sudo mhwd -a pci free 0300

und zum Schluss

reboot

Nun sollte wieder alles funktionieren.

das waere ja der hammer.
rechner startet. dann kommt das grub menue zur auswahl des systems. hier geht kein F10.
unten steht aber
e fuer edit selection
und
c fuer grub comandline.
bei beiden koennte ich was machen. welches nehme ich?

beides hat damit nix zu tun. merk ich grad…
hab jetzt mehrfach probiert beim booten bis grubmenue F10 zu druecken.aber da geht nix.

Hi,

leider kann ich aktuell meinen PC nicht neu starten um es zu verifizieren.
I habe aber mal in Internet geschaut. Es müsste die Option e sein, dort den Parameter hinzufügen und mit F10 booten.

ich hab den ersten manjaro eintrag augewählt und bin dann durch e in eine editierungsmöglichkeit gekommen.
wenn ich die erste zeile mit sudo am anfang eingebe, reicht die länge der zeile nicht aus. das ende }') rutscht auf die neue zeile, es wird aber ein anderes symbol draus, warum auch immer.
nehm ich sodu raus, dann riecht die länge,
nach F10 kommt eine fehlermeldung für $. syntax error
hm…

Dort musst du nach der Zeile suchen die den Kernel lädt. Normalerweise fängt die mit “linux” an. Danach kommt das Kernel Image und alle Kernel Optionen. Ganz ans Ende dieser Zeile fügst du eine “3” hinzu. Versuche nichts weiter zu ändern. Nachdem du die 3 hinzugefügt hast startest du dein System mit F10.

Hi,

folgendes Vorgehen:

  1. Wenn Grub angezeigt wird, ersten Eintrag auswählen und e drücken
  2. Eine der letzten Zeilen fängt mit linux an, dort hinter quiet splash folgendes ergänzen:
    3 nomodeset
  3. dann F10 drücken
  4. Linux sollte nun booten und ein Prompt zum Login erscheinen.
  5. Anmelden
  6. die Befehle von oben nacheinander ausführen.

das is eine sehr gute anleitung. danke!!!
nur steht bei mir
rw quiet resume=
ist der auszug dieser zeile

sollte auch funktionieren, hast du es schon getestet?

Add: hier findest du eine Übersicht der Parameter:
https://wiki.archlinux.org/index.php/kernel_parameters#GRUB

resume= bedeutet:
Specify a swap device to use when waking from hibernation.

sehr geil…
wieder da…
merci und fuehel dich geknutscht :wink::wink::wink:

Schön zu hören, dass bei dir wieder alles läuft.

Super wäre noch, wenn du den Thread als gelöst markierst, indem du bei einer der Antworten den Haken setzt.

schon lange passiert. hab ich gleich gemacht. aber danke :wink: