Mysterious crash from Proton games

Recently, my computer started freezing up when I was playing games. Screen frozen, no inputs were accepted, couldn’t switch to TTY, but audio continued playing like normal and I could REISUB. Looking in my journal, I have determined that these logs are linked to the issue, as they consistently show up at the time of crash:

Apr 24 20:14:03 xps15 obexd[1179]: DISCONNECT(0x1), <unknown>(0xff)
Apr 24 20:14:03 xps15 obexd[1179]: DISCONNECT(0x1), Success(0x20)
Apr 24 20:14:03 xps15 wireplumber[1213]: 0x5599fe467458: error 24
Apr 24 20:14:03 xps15 obexd[1179]: disconnected: Transport got disconnected
Apr 24 20:14:03 xps15 bluetoothd[721]: src/profile.c:ext_io_disconnected() Unable to get io data for Hands-Free Voice gateway: getpeername: Transport endpoint is not connected (107)
Apr 24 20:14:03 xps15 bluetoothd[721]: src/profile.c:ext_io_disconnected() Unable to get io data for Phone Book Access: getpeername: Transport endpoint is not connected (107)
Apr 24 20:14:03 xps15 wireplumber[1213]: (bluez_output.78_2B_64_CD_B0_84.1-21) running -> error (Received error event)
Apr 24 20:14:03 xps15 wireplumber[1213]: Failure in Bluetooth audio transport /org/bluez/hci0/dev_78_2B_64_CD_B0_84/fd0
Apr 24 20:14:03 xps15 dbus-daemon[723]: [system] Rejected send message, 0 matched rules; type="method_return", sender=":1.42" (uid=1000 pid=1213 comm="/usr/bin/wireplumber") interface="(unset)" member="(unset)" error name="(unset)" requested_reply="0" destination=":1.1" (uid=0 pid=721 comm="/usr/lib/bluetooth/blue>
Apr 24 20:14:03 xps15 pipewire[1205]: pw.node: (bluez_output.78_2B_64_CD_B0_84.1-86) running -> error (Received error event)

I am using bluetooth headphones, but they maintain their connection after the crash.

I am not really sure what heralded the change in behavior. The only updates around that time were to the following:

  • Kernels - I tried downgrading and switching to LTS kernel
  • Proton - I tried older Proton versions, Experimental, and Proton GE
  • Steam Runtime Sniper - I switched to the “previous version” beta branch, no download was shown so I’m not 100% sure I was actually on the branch, but it didn’t solve the issue

I have so far tested with 3 games:

I have not experienced this issue at all during normal usage of the computer.

inxi -v7azy
  Kernel: 6.2.12-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/vmlinuz-6.2-x86_64
    root=UUID=d10cb460-c32f-4e3c-b883-afb0d4c1d53d rw quiet
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.9 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 15 9520 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0MWGD4 v: A00 serial: <superuser required> UEFI: Dell
    v: 1.10.0 date: 12/14/2022
  ID-1: BAT0 charge: 59.1 Wh (87.2%) condition: 67.8/84.3 Wh (80.4%)
    volts: 11.9 min: 11.4 model: BYD DELL M59JH24 type: Li-poly serial: <filter>
    status: discharging
  RAM: total: 15.3 GiB used: 5.59 GiB (36.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
    arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
    process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
    microcode: 0x429
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 2028 high: 2700 min/max: 400/4600:4700:3500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 760 2: 2700 3: 400 4: 2700
    5: 906 6: 2700 7: 1505 8: 2700 9: 1089 10: 2700 11: 886 12: 2700 13: 2700
    14: 2700 15: 2700 16: 2700 17: 1514 18: 2700 19: 2700 20: 1116
    bogomips: 107560
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_lbr arch_perfmon art avx avx2 avx_vnni bmi1 bmi2
    bts clflush clflushopt clwb cmov constant_tsc cpuid cpuid_fault cx16 cx8
    de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est f16c flexpriority
    flush_l1d fma fpu fsgsbase fsrm fxsr gfni hfi ht hwp hwp_act_window
    hwp_epp hwp_notify hwp_pkg_req ibpb ibrs ibrs_enhanced ibt ida intel_pt
    invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor movbe
    movdir64b movdiri msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdpid
    rdrand rdseed rdtscp rep_good sdbg sep serialize sha_ni smap smep smx
    split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm
    tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes
    vme vmx vnmi vpclmulqdq vpid waitpkg x2apic xgetbv1 xsave xsavec xsaveopt
    xsaves xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 0000:00:02.0
    chip-ID: 8086:46a6 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Dell
    driver: nvidia v: 530.41.03 alternate: nouveau,nvidia_drm non-free: 530.xx+
    status: current (as of 2023-03) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 bus-ID: 0000:01:00.0
    chip-ID: 10de:25a2 class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-6:4 chip-ID: 0c45:6a15 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x317mm (20.00x12.48")
    s-diag: 599mm (23.57")
  Monitor-1: eDP-1 model: Sharp 0x1515 built: 2021 res: 1920x1200 hz: 60
    dpi: 145 gamma: 1.2 size: 336x210mm (13.23x8.27") diag: 396mm (15.6")
    ratio: 16:10 modes: 1920x1200
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
  API: ALSA v: k6.2.12-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlp0s20f3 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A mac: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-2: proton0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IP v6: <filter> virtual: stable-privacy scope: link
  IF-ID-3: pvpnksintrf0 state: unknown speed: N/A duplex: N/A mac: <filter>
  Message: Output throttled. IPs: 3; Limit: 10; Override: --limit [1-x;-1
  WAN IP: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 3-10:6
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Device-1: luks-4eedbe31-4667-41d3-8f2d-59c2a59f8cd1 maj-min: 254:0
    type: LUKS dm: dm-0 size: 263.61 GiB
  p-1: nvme0n1p3 maj-min: 259:3 size: 263.61 GiB
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 476.94 GiB used: 47.64 GiB (10.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN810 NVMe WDC 512GB size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 61520012 temp: 41.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 263.61 GiB size: 258.42 GiB (98.03%) used: 47.4 GiB (18.3%)
    fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-4eedbe31-4667-41d3-8f2d-59c2a59f8cd1 label: N/A
    uuid: d10cb460-c32f-4e3c-b883-afb0d4c1d53d
  ID-2: /boot raw-size: 1024 MiB size: 973.4 MiB (95.06%)
    used: 152.2 MiB (15.6%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
    label: N/A uuid: cdb47359-d9ef-4216-8f7c-0c7c2c160219
  ID-3: /boot/efi raw-size: 240 MiB size: 236 MiB (98.33%)
    used: 93.4 MiB (39.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: ESP
    uuid: C8BF-C023
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p4 maj-min: 259:4 size: 15 GiB fs: ext4 label: N/A
    uuid: 47163614-89c9-4fa0-988d-ab87851f704c
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 20 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-6:4 info: Microdia Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0c45:6a15 class-ID: 0e02
  Device-2: 3-10:6 info: Intel type: Bluetooth driver: btusb interfaces: 2
    rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0033 class-ID: e001
  Hub-4: 4-0:1 info: Super-speed hub ports: 4 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 393 Uptime: 1h 34m wakeups: 26478 Init: systemd v: 252
  default: graphical tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1225 libs: 320 tools: pamac,yay pm: flatpak
  pkgs: 0 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: yakuake
  inxi: 3.3.26

Weird how none of the messages seem to indicate anything wrong with the user interface that could explain the freeze. Audio continuing to play and REISUB working seems to point towards user space problem and not kernel being locked.

Why aren’t you using Steam Soldier?

Is TTY switching done in userspace?

I didn’t specifically select any runtime, Steam auto-installed Soldier and Sniper. My understanding is that each game depends on a specific one, and Steam handles it for you? All I know is I got a Sniper update around the time it started.

I only have Soldier installed. What if you remove Steam Runtime Sniper?

When I click “uninstall,” I get the following error message:

Failed to uninstall Steam Linux Runtime - Sniper due to:

Uninstall error - missing shared content

OK so probably it is required by something, either a whitelisted game, or a Proton version used for one of your game.

Maybe you could try Proton 8 as it released with a Sniper update recently (also reset the Proton prefix if you know what you’re doing).

I have tried Proton 8, 7, 6, experimental, and latest GE.

I don’t.

Switching between Proton version can lead to issues in the prefix.

To reset the prefix for your game (the prefix is the ‘virtual Windows’ hard drive, kinda) you can (on default installation path) delete the folder /.local/share/Steam/steamapps/compatdata/XXX/ where XXX is the Steam AppID of your game. Be careful doing so, as some games do NOT save to the cloud so you can lose a savegame deleting the folder. For safe keeping, just rename XXX to XXX_old and you can bring savegames back if needed then.

Deep Rock Galactic AppID = 548430
Demon Turf Neon Splash AppID = 1747890

After folder is deleted or renamed, start the game and it will recreate it from the Proton version you selected.

Verifying game files from game properties before starting the game could also be a good thing.

Also, can you reproduce the issue without using bluetooth at all?


That would make sense, I did play both of these games on Proton 7 and then on Proton 8 when it came out.

If the prefixes are different, can I be certain that they will go back in at the same location without issues?

You just bring the save file to the newly created prefix. DRG has Steam cloud save so you don’t need that. I don’t know the other game.

The other game does as well. Having now tested for about an hour, I am fairly certain your solution works.

So it was not a bluetooth issue, but a messed up game/prefix? Let see play more and if the issue doesn’t come back it may be that.

I am fairly certain the bluetooth issue was a symptom and not the cause. DRG is bugged on Proton 8 it seems (unrelated to this thread), so after I fixed it I had to revert to 7 and forgot to remake the prefixes again, triggering the crash. My headphones weren’t connected, and I was unable to find anything in the journal at the time of the crash.

1 Like

LOL nevermind DRG just crashed again. I gleaned some new info from it though: the mouse also works and can move around the screen, it was just hidden all the other times this happened. Also, it seems that this time Discord crashed alongside the game? The bluetooth crash log didn’t show up this time, even though the headphones were connected, but that issue may have been fixed in the latest testing update.

Apr 26 19:35:24 xps15 plasmashell[8757]: [0426/193524.381846:ERROR:elf_dynamic_array_reader.h(64)] tag not found
Apr 26 19:35:24 xps15 plasmashell[8757]: [0426/] opendir /home/fasto/.config/discord/Crashpad/attachments/5ba68b32-7fde-4790-b635-e973b02a7895: No such file or directory (2)

Can you show more information about this? Links, possibly? I’d like to know exactly what in the prefix is affected if so.

No. This is how it is. Switching Proton version forces the prefix to be "updated’ with the new Proton version files, and different version have sometimes different structures especially the GE versions. The “update” process of the prefix can lead to issues then.

This is all experience, if you are around long enough with Proton games it will happen to you, resetting the prefix will instantly fix unexplainable issue (most likely game not starting anymore).

Here, some evidence for people that like actual facts and not stupid hearsay.

But sure, let’s just assume and than make technical decisions based on assumptions. That would get me fired at my job if I worked that way.

No need to be butthurt… because… why by the way?

Well I tried getting a log of one of the crashes with PROTON_LOG=1 and ended up with a 23GB file of incomprehensible assembly stacktraces.