My windows installation ran smoother than my Manjaro does now

Hello,

thanks for the suggestion.
I have applied GRUB_CMDLINE_LINUX="nvidia-drm.modeset=1"

But the stutter persists.
I’ve come to the conclusion that maybe the problem is KDE it self?

unoptimized or my hard not being to old.

Atleast the games run very smooth. Thats the most important xD

Hello,
Is the Compositor enabled in KDE Plasma System settings?


In some situations disabling composition pipeline in nvidia-settings might help. Also, just noticed that you do not have this last lines in your nvidia.conf file, at the bottom:


Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Hello thanks for the input ^^

Your desktop look nice.
Currently I use precustomized GUI from the kde market place.

In regard of BAR yeah, totally.
But still I’ll manage some 15-20 fps then, not much but managable xD
Though when I place structures and I place them to square to que build with mines to. Instant freeze xD

I think you wanted to replie to me, since CSCS didnt showed his desktop.

What you mean with precustomized? Which theme?

Here are my custom settings:
Global Theme: Se7en Aero (unchecked box)
Plasma Style: Win7OS
Application Style:
GTK2 theme: bisoft-win7
GTK3 theme: Windows-7-2.1 (Aero)
Colours: Win7OS
Window Decorations: WinConceptOS
Icons: Oxygen + Diamond Method (Diamond Icons Gen4 + Diamond)
Cursors: Win8E

On my 144Hz TFT i can’t complain…

So after some googling I found a Redit post that gave exactly the same advice given here add kernel option to the like GRUB_CMDLINE_LINUX="nvidia-drm.modeset=1" .
But the Redit post gave additional information, which I presume, I don’t have clue… Means initializing the new grub configuration by regenerating /boot/grub/grub.cfg grub-mkconfig -o /boot/grub/grub.cfg.

After these settings plasma(wayland) started without problems.
On top of that it fixed my problem with stuttering as well!!! FINALLY A SMOOTH DESKTOP EXPERIENCE like windows offers.
I can scroll in Vs-code, browser and virtual desktops in peace WITHOUT stuttering.

What I found strange is that a lot of people on various forums swear by, that with nvidia hardware goes best with the use of x11 and not wayland for smoother and better experience, well not in my case. Wayland it is!!!

EDIT

The only solution I have found that works is basically start the right window manager from the login.
Going to basic desktop activities, like web surfing and editing documents, then i’ll start up the desktop with wayland.
Am I going to game I have to start up the desktop with X11.

2 Likes