My Wifi took a nosedive after I installed KDE Manjaro

I just bought a Dell Latitude E6530 laptop in January so that I could install Linux and get further away from Big Tech (I’m looking at you, Microsoft!). Well, I decided to go with KDE Manjaro, but ever since I installed it, my wifi is no longer working properly. Here are some deets:

System:
  Kernel: 5.15.25-1-MANJARO x86_64 bits: 64 Desktop: KDE Plasma 5.24.2
    Distro: Manjaro Linux
Machine:
  Type: Laptop System: Dell product: Latitude E6530 v: 01
    serial: <superuser required>
  Mobo: Dell model: 0JJT5F v: A00 serial: <superuser required> BIOS: Dell
    v: A17 date: 08/19/2015
CPU:
  Info: dual core Intel Core i5-3340M [MT MCP] speed (MHz): avg: 1411
    min/max: 1200/3400
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: NVIDIA GF108GLM [NVS 5200M] driver: N/A
  Display: x11 server: X.Org v: 1.21.1.3 driver: X: loaded: intel gpu: i915
    resolution: 1600x900~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
    v: 4.2 Mesa 21.3.7
Network:
  Device-1: Intel 82579LM Gigabit Network driver: e1000e
  Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi
Info:
  Memory: 7.67 GiB used: 2.01 GiB (26.2%)

Now, because I live with a roommate and he has the router in his room, I have not been able to try out the Ethernet connection, but two things on that:

  1. I have an HP ProBook 6550b running Windows 10, and the last speedtest.net report in Microsoft Edge I generated on the wifi had it with Ping: 16, Download: 121.11 Mbps, and Upload: 23.59 Mbps, which is pretty good. (We have Spectrum, and my roommate pays for 200 Mbps Download – not sure what the Upload is supposed to be.)
  2. When I first got my Dell laptop, it was pre-installed with Windows 10, and while it did not ever get as good of a Download speed as my HP laptop, it usually could make it into the 80s and 90s.

Now, when I run speed tests in KDE Manjaro, it does this weird thing where the Download starts off really good in the 80s or even 90s, but then immediately craters down to the 30s or 40s. My last speedtest.net report in Brave on the wifi had it with Ping: 30, Download: 38.92 Mbps, and Upload: 4.17 Mbps. Worse than this is when I’ve been attempting to download things in Pamac and I check the ACTUAL download speeds coming through, it’s barely been enough to keep the download from cutting off in a fatal error, early EOF.

It’s interesting because the above inxi report shows that my Intel Centrino wifi has iwlwifi for its driver, but when you check in the Manjaro Settings Manager Hardware Configuration section AND in Pamac, it does not appear that the driver is installed. So, the first thing I tried doing was installing iwlwifi-next from the AUR, and the first problem I continually was running into was error: RPC failed; curl 56 OpenSSL SSL_read: Connection reset by peer, errno 104. This is how it would appear on the screen in the Pamac UI:

Building iwlwifi-next...
==> Making package: iwlwifi-next 2022.02.10.r0.gb8c1228a0-1 (Sat 05 Mar 2022 04:05:57 PM EST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
==> Removing existing $srcdir/ directory...
==> Extracting sources...
==> Starting prepare()...
Cloning into 'iwlwifi-next'...
error: RPC failed; curl 56 OpenSSL SSL_read: Connection reset by peer, errno 104
error: 19854 bytes of body are still expected
fetch-pack: unexpected disconnect while reading sideband packet
fatal: early EOF
fatal: fetch-pack: invalid index-pack output
==> ERROR: A failure occurred in prepare().
    Aborting...

So, I eventually realized I was in a bit of a catch 22 because I was trying to download data over the wifi network while it was barely providing me any speed at all, so it kept cutting off. Well, I had a bit of an ingenious solution to this: I connected it to my phone’s hotspot so that I could have it sitting right next to my laptop, and that did the trick! It was still an extremely slow speed, but it was just enough to clone the build. The next problem came when trying to actually START the build. This is what I got in the Pamac UI (I added in the {filter}s):

==> Starting build()...
make: Entering directory '/usr/lib/modules/5.15.25-1-MANJARO/build'
  CC [M]  /var/tmp/pamac-build-<filter>/iwlwifi-next/src/iwlwifi-next/drivers/net/wireless/intel/iwlwifi/dvm/main.o
In file included from /var/tmp/pamac-build-<filter>/iwlwifi-next/src/iwlwifi-next/drivers/net/wireless/intel/iwlwifi/dvm/power.h:12,
                 from /var/tmp/pamac-build-<filter>/iwlwifi-next/src/iwlwifi-next/drivers/net/wireless/intel/iwlwifi/dvm/dev.h:31,
                 from /var/tmp/pamac-build-<filter>/iwlwifi-next/src/iwlwifi-next/drivers/net/wireless/intel/iwlwifi/dvm/main.c:37:
/var/tmp/pamac-build-<filter>/iwlwifi-next/src/iwlwifi-next/drivers/net/wireless/intel/iwlwifi/dvm/commands.h:1255:17: error: expected specifier-qualifier-list before ‘DECLARE_FLEX_ARRAY’
 1255 |                 DECLARE_FLEX_ARRAY(u8, payload);
      |                 ^~~~~~~~~~~~~~~~~~
make[2]: *** [scripts/Makefile.build:277: /var/tmp/pamac-build-<filter>/iwlwifi-next/src/iwlwifi-next/drivers/net/wireless/intel/iwlwifi/dvm/main.o] Error 1
make[1]: *** [scripts/Makefile.build:540: /var/tmp/pamac-build-<filter>/iwlwifi-next/src/iwlwifi-next/drivers/net/wireless/intel/iwlwifi/dvm] Error 2
make: *** [Makefile:1868: /var/tmp/pamac-build-<filter>/iwlwifi-next/src/iwlwifi-next/drivers/net/wireless/intel/iwlwifi] Error 2
make: Leaving directory '/usr/lib/modules/5.15.25-1-MANJARO/build'
==> ERROR: A failure occurred in build().
    Aborting...

So, a couple errors occured in the build, but I’m still too new to Linux to really make heads or tails of what it’s trying to tell me is wrong in the build. Maybe there is an easy fix to this? That’s why I’m here. The other problem, though, is that I’ve wasted a LOT of time trying to get this to all go through, and I don’t even know if getting this iwlwifi-next to build even SOLVES my wifi issue! :weary:

I mean, at this point, it’s either solve the wifi issue with my Intel Centrino network card OR buy a USB one. Kind of wondering if I’ve been wasting time in vain and if just buying a USB wifi is the quicker path. The only problem is that I don’t know if I buy a new one if it will be as simple as a plug-in-play, seeing as Manjaro doesn’t apparently recognize my current wifi card.

I was loooking on Amazon and found some inexpensive ones, but I don’t know what the compatibility will be. Some of them mention Ubuntu compatibility and say that they don’t cover RPM, but they say nothing about Arch-based Linux OSes! :expressionless: Here is a link to the page:
https://www.amazon.com/s?k=usb+wifi+linux&ref=nb_sb_noss
If anything good stands out, please, let me know. I’d rather not start buying things on Amazon, only to have them arrive and not work and have to send it back and go through that several times.

Sorry, this was kind of a long one, but I am a very thorough person. Also, if I can’t figure out this wifi issue, I kind of wasted money even buying this laptop. :sweat_smile:

It should work with the default driver, just maybe you need to do this [Solved] Intel 6300 on 5 Ghz wifi can't connect / Kernel & Hardware / Arch Linux Forums

The comments on the AUR page are quite clear, it fails to build for all users AUR (en) - iwlwifi-next

Same with the other AUR package https://aur.archlinux.org/packages/linux-firmware-iwlwifi-git in case you think to try it, not worth for now to waste time with it.

Usually disabling mac address randomization and IPv6 makes the connection a bit more reliable in some cases.