My wifi adapter stopped working in manjaro

My wifi adapter is a Realtek 8812BU and it stopped working in manjaro, but it does work in windows.

Any ideas?

Which kernel are you using?
For me, after upgrading from kernel 5.9.16-1 to 5.10.2-2, the ethernet interface disappeared.

The device names RTL8111/8168/8411
In 5.9 the driver used is: r8168

Does that mean that I should use one of the older kernels?

I also found the guide that allowed me to install the driver: driver

Actually I don’t know where exactly the problem is located. But currently I don’t have spare time to search for the reason of the missing device, so I decided to switch back to 5.9 until a fix is found.

Booting into the previous kernel seems to solve the issue. There must be some sort of bug in the latest kernel.

and thanks

Actually I would not accept my answer as solution since it’s only a workaround and the real problem is not solved - a non working hardware driver.
I’d a appreciate every hint on solving this issue!

It actually just stopped working again, I tried it in windows and it works there but not in linux. I wonder what could be the issue?

the newer kernel makes changes to grub. when you remove the newer kernel or boot to an older kernel they remain in force. for me it was 5.9 rubbishing linux54-broadcom-wl. as conflicting even though they are the exact same driver. now i cant run 5.4 as the connection is dodgy. 4.19 was last kernel that ran flawlessly for me. it is LTS so should get security updates. try that kernel and remove all other kernels and do sudo update-grub after a restart. then restart again

This might be a issue: Windows keeps the hardware ‘on’ to boot faster and locking linux out of the hardware. Disable Windows fastboot and hybrid sleep to solve this if that is the issue.