My touchpad is not found under kde plasma

Hello,

my touchpad is recognized as “ITE Tech. Inc ITE Device(8595)” but it works like a mouse and not a touchpad. In system settings of kde plasma, it is not found as a touchpad (all options are grayed out). The system tell me “touchpad not found”. I searched on the net for a solution but I didn’t find anything. That’s why I posted this message.

Do you know a way to enable this hardware as a touchpad ?

Thanks.

You may be missing something or another.
But often my suggestion with things like this is to try xf86-input-synaptics which is the legacy input handler … it should take precedence over libinput and sometimes works better in some setups.

All xf86-intput packages are installed but despite it my touchpad is not recognized as a touchpad but as a mouse.

Please post the output of timeout 2 libinput debug-events and ls -lR /dev/input/by-*/.

Thanks for your help. I will give you the results later.

I want to tell you that ITE Device(8595) is well recognized under plasma but in the system configuration it is see as a mouse and not as a touchpad.

@pobrn: Here are the results of your two commands:

sudo timeout 2 libinput debug-events

-event10 DEVICE_ADDED Video Bus seat0 default group1 cap:k
-event0 DEVICE_ADDED Lid Switch seat0 default group2 cap:S
-event1 DEVICE_ADDED ITE Tech. Inc. ITE Device(8595) seat0 default group3 cap:kp scroll-nat
-event2 DEVICE_ADDED ITE Tech. Inc. ITE Device(8595) seat0 default group3 cap:p left scroll-nat scroll-button
-event9 DEVICE_ADDED bytcr-rt5640 Headset seat0 default group4 cap:k
-event3 DEVICE_ADDED FTSC1000:00 2808:50C5 seat0 default group5 cap:t size 273x154mm ntouches 10 calib
-event4 DEVICE_ADDED FTSC1000:00 2808:50C5 UNKNOWN seat0 default group5 cap:T size 292x164mm
-event6 DEVICE_ADDED axp20x-pek seat0 default group6 cap:k
-event7 DEVICE_ADDED gpio-keys seat0 default group7 cap:k
-event8 DEVICE_ADDED gpio-keys seat0 default group7 cap:k

ls -lR /dev/input/by-*/

/dev/input/by-id/:
total 0
lrwxrwxrwx 1 root root 9 11 nov 00:11 usb-ITE_Tech._Inc.ITE_Device_8595-event-kbd -> …/event1
lrwxrwxrwx 1 root root 9 11 nov 00:11 usb-ITE_Tech._Inc.ITE_Device_8595-if01-event-mouse -> …/event2
lrwxrwxrwx 1 root root 9 11 nov 00:11 usb-ITE_Tech._Inc.ITE_Device_8595-if01-mouse -> …/mouse0

/dev/input/by-path/:
total 0
lrwxrwxrwx 1 root root 10 11 nov 00:11 pci-0000:00:02.0-platform-hdmi-lpe-audio-event -> …/event12
lrwxrwxrwx 1 root root 9 11 nov 00:11 pci-0000:00:14.0-usb-0:2.1:1.0-event-kbd -> …/event1
lrwxrwxrwx 1 root root 9 11 nov 00:11 pci-0000:00:14.0-usb-0:2.1:1.1-event-mouse -> …/event2
lrwxrwxrwx 1 root root 9 11 nov 00:11 pci-0000:00:14.0-usb-0:2.1:1.1-mouse -> …/mouse0
lrwxrwxrwx 1 root root 9 11 nov 00:11 platform-80860F41:03-event -> …/event3
lrwxrwxrwx 1 root root 9 11 nov 00:11 platform-80860F41:03-event-mouse -> …/event4
lrwxrwxrwx 1 root root 9 11 nov 00:11 platform-80860F41:03-mouse -> …/mouse2
lrwxrwxrwx 1 root root 9 11 nov 00:11 platform-80860F41:04-platform-axp221-pek-event -> …/event6
lrwxrwxrwx 1 root root 9 11 nov 00:11 platform-bytcr_rt5640-event -> …/event9
lrwxrwxrwx 1 root root 9 11 nov 00:11 platform-gpio-keys.0.auto-event -> …/event7
lrwxrwxrwx 1 root root 9 11 nov 00:11 platform-gpio-keys.1.auto-event -> …/event8
lrwxrwxrwx 1 root root 9 11 nov 00:11 platform-pcspkr-event-spkr -> …/event5

Can you post the output of inxi -Fazy?

I will give you the results later because I 'm not in my Manjaro system for now.

Thanks for your reply. :wink:

Result of inxi -Fazy

System:
Kernel: 5.9.3-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64
root=UUID=4936d035-5442-4827-8cd6-1f8abbee4cdc rw quiet apparmor=1
security=apparmor udev.log_priority=3 intel_idle.max_cstate=1
Desktop: KDE Plasma 5.20.2 tk: Qt 5.15.1 wm: kwin_x11 dm: SDDM
Distro: Manjaro Linux
Machine:
Type: Portable System: MEDION product: Akoya E2212T MD99720 v: N/A
serial: Chassis: type: 8 serial:
Mobo: MEDION model: WCBT112X v: 1.0 serial:
UEFI: American Megatrends v: 1.3 date: 10/26/2015
Battery:
ID-1: axp288_fuel_gauge charge: 100% condition: N/A volts: 4.3/N/A
model: N/A type: Li-ion serial: N/A status: Full
CPU:
Info: Quad Core model: Intel Atom Z3735F bits: 64 type: MCP arch: Silvermont
family: 6 model-id: 37 (55) stepping: 8 microcode: 838 L2 cache: 1024 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 10671
Speed: 500 MHz min/max: 500/1833 MHz Core speeds (MHz): 1: 1320 2: 649
3: 500 4: 500
Graphics:
Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:0f31
Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel
unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
s-diag: 414mm (16.3")
Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 133 size: 260x140mm (10.2x5.5")
diag: 295mm (11.6")
OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 20.2.1
compat-v: 3.0 direct render: Yes
Audio:
Device-1: bytcr-rt5640 driver: bytcr-rt5640
message: bus/chip ids unavailable
Device-2: Intel HDMI/DP LPE Audio driver: HdmiLpeAudio
message: bus/chip ids unavailable
Sound Server: ALSA v: k5.9.3-1-MANJARO
Network:
Message: No Device data found.
IF-ID-1: wlan0 state: down mac:
Drives:
Local Storage: total: 94.36 GiB used: 13.69 GiB (14.5%)
ID-1: /dev/mmcblk1 vendor: SK Hynix model: HCG8e size: 58.25 GiB block size:
physical: 512 B logical: 512 B serial: rev: 0x7 scheme: GPT
SMART Message: Unknown smartctl error. Unable to get data.
ID-2: /dev/sda type: USB model: USB Flash Memory size: 7.47 GiB block size:
physical: 512 B logical: 512 B serial: rev: PMAP scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
ID-3: /dev/sdb type: USB vendor: SanDisk model: Ultra size: 28.64 GiB
block size: physical: 512 B logical: 512 B serial: rev: 1.00
scheme: GPT
SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
Partition:
ID-1: / raw size: 28.14 GiB size: 27.57 GiB (97.99%) used: 13.69 GiB (49.7%)
fs: ext4 dev: /dev/sdb2
Swap:
Alert: No Swap data was found.
Sensors:
System Temperatures: cpu: 40.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:
Processes: 194 Uptime: 3m Memory: 1.88 GiB used: 666.2 MiB (34.6%)
Init: systemd v: 246 Compilers: gcc: 10.2.0 Packages: pacman: 1327 lib: 374
flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole inxi: 3.1.08

Note: For your information, I don’t have serio folder in /sys/bus/
The touchpad seems to be attached to /sys/bus/usb folder

Could you post the output of lsusb?