My terminal won't launch

Hi Everyone,
I just installed the latest update and my terminal app won’t launch. I tried going into a TTY and running sudo pacmain-mirrors -f5 && sudo pacman -Syu but ended up getting the message that there was nothing to do.

i downloaded xterm, and in place of the characters that would normally be there I see _p9k_init_params:72: character not in range.

The terminal in VSCode says the same thing. i can get by for now. Can anyone assist in how I might solve this issue?

Perhaps a timeshift restoration… certainly more information.

With your comments about characters, I’d say it’s a locale issue.

Try again, edit

sudo nano /etc/locale.gen

uncomment your locale and run

sudo locale-gen

See if that helps.


Thank you Ben. I just found this in another thread and got myself running. However, you put it all in one comment so maybe future users will have an easier time than I did. Thank you so much Ben for the quick response, it’s greatly appreciated.

1 Like

Mark it solved :wink:

I’ll… Mark_It_Solved … and I’ve moved the thread to #support:gnome ─ it’s a GNOME 4.0 issue. :wink:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.