My system is not detecting my gpu

So basically my laptop is only using the very weak integrated gpu this laptop has a R5 M330 how do i enable it

What does this command from terminal show:

DRI_PRIME=1 glxinfo | grep -i "OpenGL renderer"

also share:
mhwd -li
inxi -Fazy

OpenGL renderer string: AMD HAINAN (DRM 2.50.0, 5.13.15-1-MANJARO, LLVM 12.0.1)

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

Info: Dual Core model: Intel Core i3-6006U bits: 64 type: MT MCP
arch: Skylake family: 6 model-id: 4E (78) stepping: 3 microcode: EA cache:
L2: 3 MiB bogomips: 16006
Speed: 500 MHz min/max: 400/2000 MHz Core speeds (MHz): 1: 500 2: 500 3: 500
4: 500
Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art
avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb erms est f16c flush_l1d
fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs
intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp
rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
syscall tm tm2 tsc tsc_adjust tsc_deadline_timer vme x2apic xgetbv1 xsave
xsavec xsaveopt xsaves xtopology xtpr
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
IBRS_FW, STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected

well it seems to read it but whenever im watching something or playing a retrogame theres screentearing

See if by installing xf86-video-amdgpu that tearing thing will be gone.
Report back.

Well it did help alot with performance the stuttering ive experienced is gone but the tearing is still there

Can you please check in /usr/share/X11/xorg.conf.d/10-amdgpu.conf if you have it like this:

Section "Device"
   Identifier  "AMD Graphics"
   Driver      "amdgpu"
   Option      "TearFree"  "true" #this line is fixing the tearing

Section “OutputClass”
Identifier “AMDgpu”
MatchDriver “amdgpu”
Driver “amdgpu”

this is its contents and i cant seem to change the permission to add the tear free line

No need to change permissions on the file. Depending on your DE there are ways to edit it.
Since you trimmed down the inxi output in your previous comment, i don’t know, so you can use:
sudo nano /usr/share/X11/xorg.conf.d/10-amdgpu.conf
and edit it there, save and then reboot.