My sound is not working

Can you post inxi -Fza on console ?

  Kernel: 5.15.57-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=7deb59f0-959a-431d-ac4c-9428f9f3de46 rw quiet
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Google product: Phaser360 v: rev4
    serial: <superuser required> Chassis: type: 9 serial: <superuser required>
  Mobo: Google model: Phaser360 v: rev4 serial: <superuser required>
    UEFI: coreboot v: MrChromebox-4.17.2 date: 07/18/2022
  ID-1: BAT0 charge: 37.2 Wh (99.5%) condition: 37.4/41.8 Wh (89.3%)
    volts: 12.6 min: 11.2 model: SMP L17M3PB type: Li-ion serial: <filter>
    status: discharging cycles: 257
  Info: model: Intel Celeron N4020 bits: 64 type: MCP arch: Goldmont Plus
    built: 2017 process: Intel 14nm family: 6 model-id: 0x7A (122) stepping: 8
    microcode: 0x1E
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 112 KiB
    desc: d-2x24 KiB; i-2x32 KiB L2: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1084 high: 1299 min/max: 800/2800 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 870 2: 1299
    bogomips: 4378
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel GeminiLake [UHD Graphics 600] driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
    empty: DP-1,DP-2 bus-ID: 00:02.0 chip-ID: 8086:3185 class-ID: 0380
  Device-2: Luxvisions Innotech EasyCamera 1M type: USB driver: uvcvideo
    bus-ID: 1-7:2 chip-ID: 30c9:001c class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: AU Optronics 0x635c built: 2017 res: 1366x768
    hz: 60 dpi: 136 gamma: 1.2 size: 256x144mm (10.08x5.67")
    diag: 294mm (11.6") ratio: 16:9 modes: 1366x768
  OpenGL: renderer: Mesa Intel UHD Graphics 600 (GLK 2) v: 4.6 Mesa 22.1.4
    direct render: Yes
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
    driver: sof-audio-pci-intel-apl
    alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci_intel_apl
    bus-ID: 00:0e.0 chip-ID: 8086:3198 class-ID: 0401
  Sound Server-1: ALSA v: k5.15.57-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Gemini Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:0c.0 chip-ID: 8086:31dc class-ID: 0280
  IF: wlp0s12f0 state: up mac: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-9:3 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 58.24 GiB used: 19.78 GiB (34.0%)
  ID-1: /dev/mmcblk0 maj-min: 179:0 vendor: SanDisk model: DA4064
    size: 58.24 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 0x8 scheme: GPT
  SMART Message: Unknown smartctl error. Unable to generate data.
  ID-1: / raw-size: 57.95 GiB size: 56.74 GiB (97.91%) used: 19.78 GiB
    (34.9%) fs: ext4 dev: /dev/mmcblk0p2 maj-min: 179:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/mmcblk0p1 maj-min: 179:1
  Alert: No swap data was found.
  System Temperatures: cpu: 40.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 224 Uptime: 1h 4m wakeups: 30979 Memory: 3.7 GiB used: 1.63 GiB
  (44.1%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: 1236 pacman: 1230 lib: 339
  flatpak: 6 Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.20

alsamixer without a card or device option will only show level controls for default sound server.
I expect that default in alsamixer and aplay -L is probably PulseAudio rather than PipeWire

If you are unable to locate ALSA settings for audio card in alsamixer with F6 try using these commands:

    alsamixer -c sofglkda7219max
    alsamixer -D sysdefault

If you still cannot access ALSA settings with either alsamixer or amixer
I suggest you install qastools and try using qasmixer to turn up level to headphone jack

i just came back from somewhere and it doesn’t work. i am so confused

should i rerun the info script?

I do not understand comment in post #24 and #25
But I can at least compare latest ALSA data with data in post #5

Audio device is now detected as card 0 instead of card 1:

"**** List of PLAYBACK Hardware Devices ****"]
card 0: sofglkda7219max [sof-glkda7219max], device 0: Speakers (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofglkda7219max [sof-glkda7219max], device 1: Headset (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofglkda7219max [sof-glkda7219max], device 5: HDMI1 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofglkda7219max [sof-glkda7219max], device 6: HDMI2 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: sofglkda7219max [sof-glkda7219max], device 7: HDMI3 (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Audio levels for headphone output have been increased but levels for left and right channels are mismatched. output is now muted [off]

so you managed to access audio control ?

Simple mixer control 'Headphone',0
  Capabilities: volume pswitch
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 63
  Front Left: 44 [70%] [-13.00dB] Playback [off]
  Front Right: 52 [83%] [-5.00dB] Playback [off]

A modprobe option has been added to system:

!!Modprobe options (Sound related)

snd_hda_intel: model=headset-mode

Kernel documentation shows this modprobe option is intended for Realtek ALC298 audio codec
This system has Dialog DA7219 audio codec + Maxim MAX98357A amplifiier

I suggest you remove that if it is not working

I also suggest installing kernel v5.18 or v5.19 to see if the audio codec is supported on a later kernel