My PCI Wireless Adapter is not visible

I have been using my Manjaro for some time and had no serious problems until now. I have used VirtualBox, installed Debian on virtual machine and everything worked, i could use internet also… but after i restarted my whole PC, I couldn’t access my internet connection on my main system. When i used rfkill list command, there was only one device (Bluetooth), but my PCI wifi card is not there. I tried various solutions from Arch and Manjaro forums but nothing really worked. Also, it’s tp-link AC1300 Archer T6E model, i had some problems with it at the beginning (drivers), but i solved it and everything was fine until now.

Also, green diode of it is shining still, but my OS can’t find it, strange.

:+1: Welcome to Manjaro! :+1:

What you’ve probably done is what’s called a “pass-through”: the WiFi card is controlled by VirtualBox now, not by Manjaro, so you have two options:

  • remove the card from the Debian subsystem in VirtualBox
  • Remove VirtualBox entirely if you don’t know how to do the above.

I can’t tell you what to do exactly, as I don’t use VirtualBox, but VMWare (which I used to use professionally) could do the same thing…


1 Like